summaryrefslogtreecommitdiffstats
path: root/libraries/python-lastfm
diff options
context:
space:
mode:
author Mihai Militaru <mihai.militaru@gmx.com>2010-05-12 23:31:17 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:31:17 +0200
commitbab6f3a953a63044b73839fedfea966e1c799173 (patch)
tree9f1697f8874569ccd3e10a772678dcaea94dc572 /libraries/python-lastfm
parentd2ca5058516f93e865f8321326be7cd8ceccd964 (diff)
downloadslackbuilds-bab6f3a953a63044b73839fedfea966e1c799173.tar.gz
slackbuilds-bab6f3a953a63044b73839fedfea966e1c799173.tar.xz
libraries/python-lastfm: Added to 12.2 repository
Diffstat (limited to 'libraries/python-lastfm')
-rw-r--r--libraries/python-lastfm/README2
-rw-r--r--libraries/python-lastfm/nostdeb.diff.gzbin0 -> 238 bytes
-rw-r--r--libraries/python-lastfm/python-lastfm.SlackBuild54
-rw-r--r--libraries/python-lastfm/python-lastfm.info8
-rw-r--r--libraries/python-lastfm/slack-desc19
5 files changed, 83 insertions, 0 deletions
diff --git a/libraries/python-lastfm/README b/libraries/python-lastfm/README
new file mode 100644
index 0000000000..f043600b95
--- /dev/null
+++ b/libraries/python-lastfm/README
@@ -0,0 +1,2 @@
+A python interface to the last.fm web services API. Its under development
+now and the code in SVN is incomplete.
diff --git a/libraries/python-lastfm/nostdeb.diff.gz b/libraries/python-lastfm/nostdeb.diff.gz
new file mode 100644
index 0000000000..dd4ed986a0
--- /dev/null
+++ b/libraries/python-lastfm/nostdeb.diff.gz
Binary files differ
diff --git a/libraries/python-lastfm/python-lastfm.SlackBuild b/libraries/python-lastfm/python-lastfm.SlackBuild
new file mode 100644
index 0000000000..cb1f493d0d
--- /dev/null
+++ b/libraries/python-lastfm/python-lastfm.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+# Slackware build script for python-lastfm
+
+# Written by Mihai Militaru <mihai.militaru@gmx.com>
+# March 2009
+
+PRGNAM=python-lastfm
+ORIGNAM=lastfm
+VERSION=${VERSION:-0.1}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$ORIGNAM-$VERSION.tar.gz
+cd $ORIGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+zcat $CWD/nostdeb.diff.gz | patch -p0 || exit
+
+python setup.py install --root $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/python-lastfm/python-lastfm.info b/libraries/python-lastfm/python-lastfm.info
new file mode 100644
index 0000000000..00f93d8b03
--- /dev/null
+++ b/libraries/python-lastfm/python-lastfm.info
@@ -0,0 +1,8 @@
+PRGNAM="python-lastfm"
+VERSION="0.1"
+HOMEPAGE="http://code.google.com/p/python-lastfm/"
+DOWNLOAD="http://python-lastfm.googlecode.com/svn/trunk/dist/lastfm-0.1.tar.gz"
+MD5SUM="11c85f85fd1bd3a73dbe80473609a151"
+MAINTAINER="Mihai Militaru"
+EMAIL="mihai.militaru@gmx.com"
+APPROVED="dsomero"
diff --git a/libraries/python-lastfm/slack-desc b/libraries/python-lastfm/slack-desc
new file mode 100644
index 0000000000..463f7e833b
--- /dev/null
+++ b/libraries/python-lastfm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------|
+python-lastfm: python-lastfm (python interface to last.fm)
+python-lastfm:
+python-lastfm: A python interface to the last.fm web services API. Its under
+python-lastfm: development now and the code in SVN is incomplete.
+python-lastfm:
+python-lastfm:
+python-lastfm:
+python-lastfm:
+python-lastfm: Homepage: http://code.google.com/p/python-lastfm/
+python-lastfm:
+python-lastfm: