summaryrefslogtreecommitdiffstats
path: root/libraries/python-xlib
diff options
context:
space:
mode:
author Vasilis Papavasileiou <el03020@mail.ntua.gr>2010-05-11 14:56:25 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 14:56:25 +0200
commitff85971308477e1c3b7fb0476c4a9a4738d7b4c4 (patch)
tree972f2551b599690664472be37bd2015f01c41309 /libraries/python-xlib
parent78ed94f075a71136ca0b59b85fb5ff42354c8e1d (diff)
downloadslackbuilds-ff85971308477e1c3b7fb0476c4a9a4738d7b4c4.tar.gz
slackbuilds-ff85971308477e1c3b7fb0476c4a9a4738d7b4c4.tar.xz
libraries/python-xlib: Initial import
Diffstat (limited to 'libraries/python-xlib')
-rw-r--r--libraries/python-xlib/README8
-rw-r--r--libraries/python-xlib/python-xlib.SlackBuild39
-rw-r--r--libraries/python-xlib/python-xlib.info8
-rw-r--r--libraries/python-xlib/slack-desc11
4 files changed, 66 insertions, 0 deletions
diff --git a/libraries/python-xlib/README b/libraries/python-xlib/README
new file mode 100644
index 0000000000..659ee59e2c
--- /dev/null
+++ b/libraries/python-xlib/README
@@ -0,0 +1,8 @@
+python-xlib is an X Library module for Python.
+
+The Python X library is intended to be a fully functional X client for Python
+programs. It is written entirely in Python, in ontrast to earlier X libraries
+for Python. This is possible to do since X client programs communicate with
+the X server via the X protocol. The communication takes over TCP/IP, Unix
+sockets, or any other streaming network protocol.
+
diff --git a/libraries/python-xlib/python-xlib.SlackBuild b/libraries/python-xlib/python-xlib.SlackBuild
new file mode 100644
index 0000000000..c6edea122b
--- /dev/null
+++ b/libraries/python-xlib/python-xlib.SlackBuild
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+# Slackware build script for python-xlib
+# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+
+# Modified by the SlackBuilds.org project
+
+PRGNAM=python-xlib
+VERSION=0.13
+ARCH=noarch # package has no C/C++ code, it is architecture independent
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING NEWS PKG-INFO README TODO"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root $PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/python-xlib/python-xlib.info b/libraries/python-xlib/python-xlib.info
new file mode 100644
index 0000000000..19e9418f45
--- /dev/null
+++ b/libraries/python-xlib/python-xlib.info
@@ -0,0 +1,8 @@
+PRGNAM="python-xlib"
+VERSION="0.13"
+HOMEPAGE="http://python-xlib.sourceforge.net/"
+DOWNLOAD="http://switch.dl.sourceforge.net/sourceforge/python-xlib/python-xlib-0.13.tar.gz"
+MD5SUM="8ff22c7517699c2623feb4e31ed612d2"
+MAINTAINER="Vasilis Papavasileiou"
+EMAIL="el03020@mail.ntua.gr"
+APPROVED="rworkman"
diff --git a/libraries/python-xlib/slack-desc b/libraries/python-xlib/slack-desc
new file mode 100644
index 0000000000..d624633db8
--- /dev/null
+++ b/libraries/python-xlib/slack-desc
@@ -0,0 +1,11 @@
+python-xlib: python-xlib (X Library module for Python)
+python-xlib:
+python-xlib: The Python X library is intended to be a fully functional X
+python-xlib: client for Python programs. It is written entirely in Python, in
+python-xlib: contrast to earlier X libraries for Python. This is possible to
+python-xlib: do since X client programs communicate with the X server via the
+python-xlib: X protocol. The communication takes over TCP/IP, Unix sockets, or
+python-xlib: any other streaming network protocol.
+python-xlib:
+python-xlib: Homepage: http://python-xlib.sourceforge.net/
+python-xlib: