summaryrefslogtreecommitdiffstats
path: root/libraries/pyxdg
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-13 00:33:25 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:33:25 +0200
commit03c845c59f2f0fde0334695f14e67b810d4a3979 (patch)
treea6af8c687e08abae6af69140aa641747c35745e6 /libraries/pyxdg
parent2e962d4d0df4250b45e49fbd72041fa2d43b6d04 (diff)
downloadslackbuilds-03c845c59f2f0fde0334695f14e67b810d4a3979.tar.gz
slackbuilds-03c845c59f2f0fde0334695f14e67b810d4a3979.tar.xz
libraries/pyxdg: Updated for version 0.18
Diffstat (limited to 'libraries/pyxdg')
-rw-r--r--libraries/pyxdg/pyxdg.SlackBuild28
-rw-r--r--libraries/pyxdg/pyxdg.info10
2 files changed, 22 insertions, 16 deletions
diff --git a/libraries/pyxdg/pyxdg.SlackBuild b/libraries/pyxdg/pyxdg.SlackBuild
index dd9dc57017..b16e8ec5ff 100644
--- a/libraries/pyxdg/pyxdg.SlackBuild
+++ b/libraries/pyxdg/pyxdg.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PyXDG
-# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# Copyright 2008-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyxdg
-VERSION=${VERSION:-0.17}
+VERSION=${VERSION:-0.18}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,18 +35,23 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || exit 1
-cd $PRGNAM-$VERSION || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -54,14 +59,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python setup.py build || exit 1
-python setup.py install --root $PKG || exit 1
+python setup.py install --root $PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -73,4 +77,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyxdg/pyxdg.info b/libraries/pyxdg/pyxdg.info
index f494b221a5..dbd3264018 100644
--- a/libraries/pyxdg/pyxdg.info
+++ b/libraries/pyxdg/pyxdg.info
@@ -1,8 +1,10 @@
PRGNAM="pyxdg"
-VERSION="0.17"
+VERSION="0.18"
HOMEPAGE="http://freedesktop.org/wiki/Software/pyxdg"
-DOWNLOAD="http://www.freedesktop.org/~lanius/pyxdg-0.17.tar.gz"
-MD5SUM="a086de99cc536095684d87f15594e4db"
+DOWNLOAD="http://www.freedesktop.org/~lanius/pyxdg-0.18.tar.gz"
+MD5SUM="076b57722e91dab8ab83028c6ef9dcea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Frank Caraballo"
EMAIL="fecaraballo{at}gmail{dot}com"
-APPROVED="Michiel" \ No newline at end of file
+APPROVED="rworkman"