summaryrefslogtreecommitdiffstats
path: root/libraries/reportlab
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-11 20:01:02 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:01:02 +0200
commitedc8fc4d9945d38d53b06c11c34a02374566a85a (patch)
tree25433d636816379dbaf0a2ec5bb8bd43dd583caa /libraries/reportlab
parente5373818ae6fb06163b29aa92ba427a240f6e30c (diff)
downloadslackbuilds-edc8fc4d9945d38d53b06c11c34a02374566a85a.tar.gz
slackbuilds-edc8fc4d9945d38d53b06c11c34a02374566a85a.tar.xz
libraries/reportlab: Added to 12.0 repository
Diffstat (limited to 'libraries/reportlab')
-rw-r--r--libraries/reportlab/README27
-rw-r--r--libraries/reportlab/reportlab.SlackBuild67
-rw-r--r--libraries/reportlab/reportlab.info8
-rw-r--r--libraries/reportlab/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/libraries/reportlab/README b/libraries/reportlab/README
new file mode 100644
index 0000000000..bc2ea13a14
--- /dev/null
+++ b/libraries/reportlab/README
@@ -0,0 +1,27 @@
+The ReportLab Open Source PDF library is a proven industry-strength
+python-based PDF generating solution, suitable for web publishers,
+developers or creative design professionals who need to quickly and
+easily create or automate complex (even data-driven) documents.
+It is released by ReportLab Inc., under BSD license.
+
+It has the following features:
+- create professional portable documents
+- real document layout engine (Platypus)
+- flowable objects such as paragraphs, headlines, tables, images,
+graphics, etc.
+- arbitrary Type-1 fonts
+- bitmap images, vector graphics
+- library of reusable primitive shapes
+- extensible widget library
+- uses Python, a clean OO language
+- layered architecture
+- includes simple demos and more complex tools
+- allows for any data sources
+- fully available source code
+- strong community support
+- platform-independent
+- includes PythonPoint - PDF Presentation Tool
+
+If pil (Python Imaging library) is installed (it is available from
+Slackbuilds.org too), reportlab can use it for working with bitmap
+images.
diff --git a/libraries/reportlab/reportlab.SlackBuild b/libraries/reportlab/reportlab.SlackBuild
new file mode 100644
index 0000000000..38ca63315d
--- /dev/null
+++ b/libraries/reportlab/reportlab.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for reportlab
+
+# Copyright 2007 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=reportlab
+SRC_PRGNAM=ReportLab
+VERSION=2.1
+SRC_VERSION=2_1
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="changes license.txt README docs/*.pdf"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${PRGNAM}_${SRC_VERSION}
+tar xvzf $CWD/${SRC_PRGNAM}_${SRC_VERSION}.tgz || exit 1
+cd ${PRGNAM}_${SRC_VERSION}/${PRGNAM}
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# copy documentation .pdf files and move text files to avoid file duplication in python directory
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+python setup.py build || exit 1
+python setup.py install --root=$PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/reportlab/reportlab.info b/libraries/reportlab/reportlab.info
new file mode 100644
index 0000000000..73956b21a9
--- /dev/null
+++ b/libraries/reportlab/reportlab.info
@@ -0,0 +1,8 @@
+PRGNAM="reportlab"
+VERSION="2.1"
+HOMEPAGE="http://www.reportlab.org/"
+DOWNLOAD="http://www.reportlab.org/ftp/ReportLab_2_1.tgz"
+MD5SUM="d6eefe9e6e06aaa1315462045c9726ba"
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/libraries/reportlab/slack-desc b/libraries/reportlab/slack-desc
new file mode 100644
index 0000000000..766401975e
--- /dev/null
+++ b/libraries/reportlab/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+reportlab: reportlab (PDF generation toolkit using python)
+reportlab:
+reportlab: The ReportLab Open Source PDF library is a proven industry-strength
+reportlab: PDF generating solution, suitable for web publishers, developers
+reportlab: or creative design professionals who need to quickly and easily
+reportlab: create or automate complex (even data-driven) documents.
+reportlab: It is released by ReportLab Inc., under BSD license.
+reportlab: This version does not include optional accelerator C extension
+reportlab: _rl_accel Homepage: http://www.reportlab.org
+reportlab:
+reportlab: