summaryrefslogtreecommitdiffstats
path: root/libraries/sdformat
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2017-07-29 19:50:55 +0200
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:58:01 -0500
commit646cf7ae87601e34a72b1740e8754ac0f51d7c57 (patch)
tree004ce7e08b189bce4dfffc1d9230c7c881b69c21 /libraries/sdformat
parentaff08d2b6dd83b6fa2cd498de5fb6328bd0b6b7e (diff)
downloadslackbuilds-646cf7ae87601e34a72b1740e8754ac0f51d7c57.tar.gz
slackbuilds-646cf7ae87601e34a72b1740e8754ac0f51d7c57.tar.xz
libraries/sdformat: Patch for cmake >= 3.9.x.
For this version, upstream code is already fixed Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/sdformat')
-rw-r--r--libraries/sdformat/cmake.patch20
-rw-r--r--libraries/sdformat/sdformat.SlackBuild3
2 files changed, 23 insertions, 0 deletions
diff --git a/libraries/sdformat/cmake.patch b/libraries/sdformat/cmake.patch
new file mode 100644
index 0000000000..38e6b6cca6
--- /dev/null
+++ b/libraries/sdformat/cmake.patch
@@ -0,0 +1,20 @@
+diff -Naur osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt
+--- osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt 2016-10-10 23:51:37.000000000 +0200
++++ osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt 2017-07-29 19:46:16.021921859 +0200
+@@ -186,11 +186,13 @@
+ # OS Specific initialization
+ if (UNIX)
+ sdf_setup_unix()
+-else (WIN32)
++endif ()
++if (WIN32)
+ sdf_setup_windows()
+-else (APPLE)
++endif ()
++if (APPLE)
+ sdf_setup_apple()
+-endif()
++endif ()
+
+ #################################################
+ # Print warnings and errors
diff --git a/libraries/sdformat/sdformat.SlackBuild b/libraries/sdformat/sdformat.SlackBuild
index 5dea256ef6..b412d5a10d 100644
--- a/libraries/sdformat/sdformat.SlackBuild
+++ b/libraries/sdformat/sdformat.SlackBuild
@@ -71,6 +71,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch for cmake >= 3.9.x
+patch -p1 < $CWD/cmake.patch
+
mkdir -p build
cd build
cmake \