summaryrefslogtreecommitdiffstats
path: root/libraries/simbody
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-24 16:11:42 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-29 10:30:53 -0400
commit4b24be6ca0c314759ab043e260ea4c5498c9cc59 (patch)
tree005426b42693dc0032d403e4fed750b38a87a3c6 /libraries/simbody
parentcd581283b91dad9b2bab0dd9cc6e5fe5061e4a41 (diff)
downloadslackbuilds-4b24be6ca0c314759ab043e260ea4c5498c9cc59.tar.gz
slackbuilds-4b24be6ca0c314759ab043e260ea4c5498c9cc59.tar.xz
libraries/simbody: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/simbody')
-rw-r--r--libraries/simbody/simbody.SlackBuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/libraries/simbody/simbody.SlackBuild b/libraries/simbody/simbody.SlackBuild
index 19b0ddfe14..2f0b277dcb 100644
--- a/libraries/simbody/simbody.SlackBuild
+++ b/libraries/simbody/simbody.SlackBuild
@@ -22,13 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220424 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - don't include api/ in doc dir if it's empty.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=simbody
SRCNAM=Simbody
-DIRNAM=simbody-Simbody-3.5.4
VERSION=${VERSION:-3.5.4}
-BUILD=${BUILD:-1}
+DIRNAM=$PRGNAM-$SRCNAM-$VERSION
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,9 +77,9 @@ cd $DIRNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Move all docs to the correct location
sed -i "s|doc/simbody|doc/simbody-$VERSION|" CMakeLists.txt
@@ -93,13 +93,13 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220424 bkw: if this dir isn't empty, include it in the package.
+# not sure what optional dep is needed to populate it.
+rmdir $PKG/usr/doc/$PRGNAM-$VERSION/api &> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install