summaryrefslogtreecommitdiffstats
path: root/libraries/tagpy
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-13 00:33:38 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:33:38 +0200
commit8f5116594ef4469aad7de5b683d053386857a98a (patch)
treeafe057a25feeb0cacdefa714828e412457455889 /libraries/tagpy
parenta665e45406174f50539f2e4d5fec0118ddb6ba2c (diff)
downloadslackbuilds-8f5116594ef4469aad7de5b683d053386857a98a.tar.gz
slackbuilds-8f5116594ef4469aad7de5b683d053386857a98a.tar.xz
libraries/tagpy: Updated for version 0.94.5
Diffstat (limited to 'libraries/tagpy')
-rw-r--r--libraries/tagpy/README3
-rw-r--r--libraries/tagpy/tagpy.SlackBuild11
-rw-r--r--libraries/tagpy/tagpy.info2
3 files changed, 11 insertions, 5 deletions
diff --git a/libraries/tagpy/README b/libraries/tagpy/README
index 9a45dae8f2..1561d0c25e 100644
--- a/libraries/tagpy/README
+++ b/libraries/tagpy/README
@@ -2,5 +2,4 @@ TagPy is a set of Python bindings for Scott Wheeler's TagLib. It
builds upon Boost.Python, a wrapper generation library which is
part of the Boost set of C++ libraries.
-boost and pysetuptools (available at SBo) are required to build
-TagPy.
+pysetuptools (available at SBo) is required to build TagPy.
diff --git a/libraries/tagpy/tagpy.SlackBuild b/libraries/tagpy/tagpy.SlackBuild
index 5c98c9ac24..d70df4aac8 100644
--- a/libraries/tagpy/tagpy.SlackBuild
+++ b/libraries/tagpy/tagpy.SlackBuild
@@ -35,10 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
rm -rf $PKG
@@ -67,8 +70,10 @@ python setup.py build || exit 1
python setup.py install --root $PKG || exit 1
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -80,4 +85,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/tagpy/tagpy.info b/libraries/tagpy/tagpy.info
index 6b65b5c261..97494f9000 100644
--- a/libraries/tagpy/tagpy.info
+++ b/libraries/tagpy/tagpy.info
@@ -2,7 +2,9 @@ PRGNAM="tagpy"
VERSION="0.94.5"
HOMEPAGE="http://mathema.tician.de/software/tagpy"
DOWNLOAD="http://pypi.python.org/packages/source/t/tagpy/tagpy-0.94.5.tar.gz"
+DOWNLOAD_x86_64=""
MD5SUM="84d7862786ad7bab91d0d45ded15a875"
+MD5SUM_x86_64=""
MAINTAINER="Frank Caraballo"
EMAIL="fecaraballo{at}gmail{dot}com"
APPROVED="dsomero"