summaryrefslogtreecommitdiffstats
path: root/libraries/tre
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2021-10-18 16:25:36 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-29 17:07:16 +0700
commite9f70d2687b73c08a80f9b6ba70d627130608864 (patch)
treec5e4394ff542a2e7717b15c8d0725a325c960ee7 /libraries/tre
parent5aae23bcf130d0fa05f9f538e53e8fa3248fd3ae (diff)
downloadslackbuilds-e9f70d2687b73c08a80f9b6ba70d627130608864.tar.gz
slackbuilds-e9f70d2687b73c08a80f9b6ba70d627130608864.tar.xz
libraries/tre: New maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/tre')
-rw-r--r--libraries/tre/README7
-rw-r--r--libraries/tre/slack-desc8
-rw-r--r--libraries/tre/tre.SlackBuild34
-rw-r--r--libraries/tre/tre.info4
4 files changed, 30 insertions, 23 deletions
diff --git a/libraries/tre/README b/libraries/tre/README
index a7a6703f08..7c5da1f7de 100644
--- a/libraries/tre/README
+++ b/libraries/tre/README
@@ -1,3 +1,8 @@
-TRE is a lightweight, robust, and efficient POSIX compliant regexp
+tre (regular expression matching library)
+
+TRE is a lightweight, robust, and efficient POSIX compliant regex
matching library with some exciting features such as approximate
(fuzzy) matching.
+
+This includes the tre C library, python3 library, and the command-line
+tool "agrep".
diff --git a/libraries/tre/slack-desc b/libraries/tre/slack-desc
index 3b27be9006..66dbfba071 100644
--- a/libraries/tre/slack-desc
+++ b/libraries/tre/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-tre: tre (Regexp Matching Library)
+tre: tre (regular expression matching library)
tre:
-tre: TRE is a lightweight, robust, and efficient POSIX compliant regexp
+tre: TRE is a lightweight, robust, and efficient POSIX compliant regex
tre: matching library with some exciting features such as approximate
tre: (fuzzy) matching.
tre:
-tre: Homepage: https://laurikari.net/tre/
-tre:
+tre: This includes the tre C library, python3 library, and the command-line
+tre: tool "agrep".
tre:
tre:
tre:
diff --git a/libraries/tre/tre.SlackBuild b/libraries/tre/tre.SlackBuild
index cb01b46ce6..05669f8b35 100644
--- a/libraries/tre/tre.SlackBuild
+++ b/libraries/tre/tre.SlackBuild
@@ -2,8 +2,9 @@
# Slackware build script for TRE
-# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# Maintained 2013-2021 by Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2008 Frank Caraballo <email removed>
+# Maintained 2013-2021 by Benjamin Trigona-Harany <email removed>
+# Maintained 2021- by B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,11 +24,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20211018 bkw: v0.8.0, BUILD=3
+# - take over maintenance.
+# - strip python shared lib.
+# - move HTML docs to docdir html/, plus include the CSS.
+# - get rid of useless INSTALL from docdor.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tre
VERSION=${VERSION:-0.8.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +46,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -74,11 +78,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -97,14 +98,15 @@ cd python
CFLAGS="-I$PKG/usr/include" \
LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX" \
python3 setup.py install --root=$PKG
+ strip $PKG/usr/lib*/python*/site-packages/*.so
cd -
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man?/*.*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog INSTALL LICENSE NEWS README THANKS TODO doc/*.html \
- $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a AUTHORS ChangeLog LICENSE NEWS README THANKS TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/*.{html,css} $PKG/usr/doc/$PRGNAM-$VERSION/html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/tre/tre.info b/libraries/tre/tre.info
index 7fc9f23251..3fe2b9e2b7 100644
--- a/libraries/tre/tre.info
+++ b/libraries/tre/tre.info
@@ -6,5 +6,5 @@ MD5SUM="b4d3232593dadf6746f4727bdda20b41"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"