summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2010-04-20 00:51:49 -0500
committer Erik Hanson <erik@slackbuilds.org>2010-05-15 10:38:34 +0200
commit5e9800af732969afb665e7aa87e6f620992cd02a (patch)
tree26c604b59d58944fc977ca5e5663b18721266dbb /libraries/wxPython
parent0b6040200e5e23f40a6c6886ad0ca64bfe515b16 (diff)
downloadslackbuilds-5e9800af732969afb665e7aa87e6f620992cd02a.tar.gz
slackbuilds-5e9800af732969afb665e7aa87e6f620992cd02a.tar.xz
libraries/wxPython: Build bump, BUILD=3
Added patch for newer glib. Added patch for newer libpng.
Diffstat (limited to 'libraries/wxPython')
-rw-r--r--libraries/wxPython/wxGTK-2.8.10.1-gsocket.patch16
-rw-r--r--libraries/wxPython/wxPython-libpng14.diff78
-rw-r--r--libraries/wxPython/wxPython.SlackBuild8
-rw-r--r--libraries/wxPython/wxPython.info2
4 files changed, 102 insertions, 2 deletions
diff --git a/libraries/wxPython/wxGTK-2.8.10.1-gsocket.patch b/libraries/wxPython/wxGTK-2.8.10.1-gsocket.patch
new file mode 100644
index 0000000000..b875cb814a
--- /dev/null
+++ b/libraries/wxPython/wxGTK-2.8.10.1-gsocket.patch
@@ -0,0 +1,16 @@
+--- wxPython-src-2.8.10.1-orig/src/gtk/gsockgtk.cpp
++++ wxPython-src-2.8.10.1/src/gtk/gsockgtk.cpp
+@@ -15,8 +15,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++// newer versions of glib define its own GSocket but we unfortunately use this
++// name in our own (semi-)public header and so can't change it -- rename glib
++// one instead
++#define GSocket GlibGSocket
+ #include <gdk/gdk.h>
+ #include <glib.h>
++#undef GSocket
+
+ #include "wx/gsocket.h"
+ #include "wx/unix/gsockunx.h"
diff --git a/libraries/wxPython/wxPython-libpng14.diff b/libraries/wxPython/wxPython-libpng14.diff
new file mode 100644
index 0000000000..37803b8370
--- /dev/null
+++ b/libraries/wxPython/wxPython-libpng14.diff
@@ -0,0 +1,78 @@
+Index: configure
+===================================================================
+--- configure (revision 62657)
++++ configure (revision 63138)
+@@ -1,4 +1,4 @@
+ #! /bin/sh
+-# From configure.in Id: configure.in 58872 2009-02-13 09:18:23Z CE .
++# From configure.in Id.
+ # Guess values for system-dependent variables and create Makefiles.
+ # Generated by GNU Autoconf 2.59 for wxWidgets 2.8.10.
+@@ -26380,7 +26380,7 @@
+
+ if test "$ac_cv_header_png_h" = "yes"; then
+- echo "$as_me:$LINENO: checking for png_check_sig in -lpng" >&5
+-echo $ECHO_N "checking for png_check_sig in -lpng... $ECHO_C" >&6
+-if test "${ac_cv_lib_png_png_check_sig+set}" = set; then
++ echo "$as_me:$LINENO: checking for png_sig_cmp in -lpng" >&5
++echo $ECHO_N "checking for png_sig_cmp in -lpng... $ECHO_C" >&6
++if test "${ac_cv_lib_png_png_sig_cmp+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+@@ -26400,9 +26400,9 @@
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char png_check_sig ();
++char png_sig_cmp ();
+ int
+ main ()
+ {
+-png_check_sig ();
++png_sig_cmp ();
+ ;
+ return 0;
+@@ -26430,10 +26430,10 @@
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+- ac_cv_lib_png_png_check_sig=yes
++ ac_cv_lib_png_png_sig_cmp=yes
+ else
+ echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
+
+-ac_cv_lib_png_png_check_sig=no
++ac_cv_lib_png_png_sig_cmp=no
+ fi
+ rm -f conftest.err conftest.$ac_objext \
+@@ -26441,7 +26441,7 @@
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-echo "$as_me:$LINENO: result: $ac_cv_lib_png_png_check_sig" >&5
+-echo "${ECHO_T}$ac_cv_lib_png_png_check_sig" >&6
+-if test $ac_cv_lib_png_png_check_sig = yes; then
++echo "$as_me:$LINENO: result: $ac_cv_lib_png_png_sig_cmp" >&5
++echo "${ECHO_T}$ac_cv_lib_png_png_sig_cmp" >&6
++if test $ac_cv_lib_png_png_sig_cmp = yes; then
+ PNG_LINK=" -lpng -lz"
+ fi
+Index: docs/changes.txt
+===================================================================
+--- docs/changes.txt (revision 62511)
++++ docs/changes.txt (revision 63138)
+@@ -128,4 +128,5 @@
+ - Added wxBORDER_THEME to XRC.
+ - Speeded up wxTreeCtrl by caching text size (botg).
++- Fix building with using system libpng 1.4 (Volker Grabsch).
+
+ wxMSW:
+Index: configure.in
+===================================================================
+--- configure.in (revision 62657)
++++ configure.in (revision 63138)
+@@ -3051,5 +3051,5 @@
+
+ if test "$ac_cv_header_png_h" = "yes"; then
+- AC_CHECK_LIB(png, png_check_sig, PNG_LINK=" -lpng -lz", , [-lz -lm])
++ AC_CHECK_LIB(png, png_sig_cmp, PNG_LINK=" -lpng -lz", , [-lz -lm])
+ fi
+
diff --git a/libraries/wxPython/wxPython.SlackBuild b/libraries/wxPython/wxPython.SlackBuild
index 6e5a7632a1..37762a6844 100644
--- a/libraries/wxPython/wxPython.SlackBuild
+++ b/libraries/wxPython/wxPython.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=wxPython
VERSION=2.8.10.1
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -64,6 +64,12 @@ cd $PRGNAM-src-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+#patch for newer glib versions
+patch -p1 -i $CWD/wxGTK-2.8.10.1-gsocket.patch
+
+#patch to also detect newer libpng versions
+patch -p0 -i $CWD/wxPython-libpng14.diff
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/libraries/wxPython/wxPython.info b/libraries/wxPython/wxPython.info
index c6c5f3c4bd..af2a747193 100644
--- a/libraries/wxPython/wxPython.info
+++ b/libraries/wxPython/wxPython.info
@@ -2,8 +2,8 @@ PRGNAM="wxPython"
VERSION="2.8.10.1"
HOMEPAGE="http://wxPython.org/"
DOWNLOAD="http://downloads.sourceforge.net/wxpython/wxPython-src-2.8.10.1.tar.bz2"
-DOWNLOAD_x86_64=""
MD5SUM="65d5ef166f23fe8b4c67f58df164f93e"
+DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Heinz Wiesinger"
EMAIL="pprkut@liwjatan.at"