summaryrefslogtreecommitdiffstats
path: root/libraries/yascreen
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-05-31 19:41:46 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-04 10:37:07 +0700
commita78edc2553a7eaa56a444595d44a35e97dee1bb9 (patch)
tree4cd99f18c2d2bda5aea988b8bf36b26d74d25e8e /libraries/yascreen
parente355a27963fa1abefeab426f7ab79f58cd347fee (diff)
downloadslackbuilds-a78edc2553a7eaa56a444595d44a35e97dee1bb9.tar.gz
slackbuilds-a78edc2553a7eaa56a444595d44a35e97dee1bb9.tar.xz
libraries/yascreen: Added (screen library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/yascreen')
-rw-r--r--libraries/yascreen/README2
-rw-r--r--libraries/yascreen/makefile.patch29
-rw-r--r--libraries/yascreen/slack-desc19
-rw-r--r--libraries/yascreen/yascreen.SlackBuild101
-rw-r--r--libraries/yascreen/yascreen.info10
5 files changed, 161 insertions, 0 deletions
diff --git a/libraries/yascreen/README b/libraries/yascreen/README
new file mode 100644
index 0000000000..e65a76b3c1
--- /dev/null
+++ b/libraries/yascreen/README
@@ -0,0 +1,2 @@
+yascreen - Yet Another Screen Library (curses replacement for daemons
+and embedded apps)
diff --git a/libraries/yascreen/makefile.patch b/libraries/yascreen/makefile.patch
new file mode 100644
index 0000000000..fec2030793
--- /dev/null
+++ b/libraries/yascreen/makefile.patch
@@ -0,0 +1,29 @@
+From a30b8fce66a3db9f1194fede30a48424ed3d696b Mon Sep 17 00:00:00 2001
+From: Boian Bonev <bbonev@ipacct.com>
+Date: Tue, 21 Sep 2021 03:36:23 +0300
+Subject: [PATCH] fix problems with install
+
+---
+ Makefile.main | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.main b/Makefile.main
+index 235bb0a..e88af51 100644
+--- a/Makefile.main
++++ b/Makefile.main
+@@ -108,12 +108,12 @@ yascreen.pc: yascreen.pc.in
+
+ install: libyascreen.a libyascreen.so yascreen.pc yascreen.3
+ $(INSTALL) -Ds -m 644 -t $(DESTDIR)$(PREFIX)$(LIBDIR) libyascreen.a
+- $(INSTALL) -Ds -m 644 -t $(DESTDIR)$(PREFIX)$(LIBDIR)/pkgconfig/ yascreen.pc
++ $(INSTALL) -D -m 644 -t $(DESTDIR)$(PREFIX)$(LIBDIR)/pkgconfig/ yascreen.pc
+ ln -fs libyascreen.so.$(SOVERF) $(DESTDIR)$(PREFIX)$(LIBDIR)libyascreen.so.$(SOVERM)
+ ln -fs libyascreen.so.$(SOVERM) $(DESTDIR)$(PREFIX)$(LIBDIR)libyascreen.so
+ $(INSTALL) -Ds -m 644 -s -t $(DESTDIR)$(PREFIX)$(LIBDIR) libyascreen.so.$(SOVERF)
+- $(INSTALL) -Ds -m 644 -t $(DESTDIR)$(PREFIX)$(INCDIR) yascreen.h
+- $(INSTALL) -TDs -m 0644 yascreen.3 $(DESTDIR)$(PREFIX)/share/man/man3/yascreen.3
++ $(INSTALL) -D -m 644 -t $(DESTDIR)$(PREFIX)$(INCDIR) yascreen.h
++ $(INSTALL) -TD -m 0644 yascreen.3 $(DESTDIR)$(PREFIX)/share/man/man3/yascreen.3
+
+ clean:
+ rm -f yastest yastest.shared yastest.o yascreen.o libyascreen.a libyascreen.so libyascreen.so.$(SOVERM) libyascreen.so.$(SOVERF) yascreen.pc
diff --git a/libraries/yascreen/slack-desc b/libraries/yascreen/slack-desc
new file mode 100644
index 0000000000..91f1d97ae7
--- /dev/null
+++ b/libraries/yascreen/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+yascreen: yascreen (screen library)
+yascreen:
+yascreen: yascreen - Yet Another Screen Library (curses replacement for daemons
+yascreen: and embedded apps)
+yascreen:
+yascreen: homepage: https://github.com/bbonev/yascreen
+yascreen:
+yascreen:
+yascreen:
+yascreen:
+yascreen:
diff --git a/libraries/yascreen/yascreen.SlackBuild b/libraries/yascreen/yascreen.SlackBuild
new file mode 100644
index 0000000000..31707ccd5c
--- /dev/null
+++ b/libraries/yascreen/yascreen.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/bash
+
+# Slackware build script for yascreen
+
+# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=yascreen
+VERSION=${VERSION:-1.86}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/makefile.patch
+sed -i "s|share/man|man|" Makefile.main
+
+CFLAGS="$SLKCFLAGS" \
+make install DESTDIR=$PKG PREFIX=/usr LIBDIR=/lib${LIBDIRSUFFIX}/
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/yascreen/yascreen.info b/libraries/yascreen/yascreen.info
new file mode 100644
index 0000000000..a571c75f41
--- /dev/null
+++ b/libraries/yascreen/yascreen.info
@@ -0,0 +1,10 @@
+PRGNAM="yascreen"
+VERSION="1.86"
+HOMEPAGE="https://github.com/bbonev/yascreen"
+DOWNLOAD="https://github.com/bbonev/yascreen/releases/download/v1.86/yascreen-1.86.tar.xz"
+MD5SUM="997cf5e50c7aee7eb04ca913eff1f057"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"