summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-05-12 23:29:47 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:29:47 +0200
commit1b9c385766b75d8b241cbcc10387b8dac65acd84 (patch)
tree37c1b4f6057f0f60bc24fcd61fed849890ba13ab /libraries
parent0c91c7f00b8e234d7a94ca1a0427d67bdaa63fc5 (diff)
downloadslackbuilds-1b9c385766b75d8b241cbcc10387b8dac65acd84.tar.gz
slackbuilds-1b9c385766b75d8b241cbcc10387b8dac65acd84.tar.xz
libraries/CherryPy: Added to 12.2 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/CherryPy/CherryPy.SlackBuild49
-rw-r--r--libraries/CherryPy/CherryPy.info8
-rw-r--r--libraries/CherryPy/README5
-rw-r--r--libraries/CherryPy/slack-desc19
4 files changed, 81 insertions, 0 deletions
diff --git a/libraries/CherryPy/CherryPy.SlackBuild b/libraries/CherryPy/CherryPy.SlackBuild
new file mode 100644
index 0000000000..00381d9b69
--- /dev/null
+++ b/libraries/CherryPy/CherryPy.SlackBuild
@@ -0,0 +1,49 @@
+#!/bin/sh
+# Slackware build script for CherryPy
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=CherryPy
+VERSION=${VERSION:-3.1.2}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt cherrypy/LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+rm -f $PKG/usr/lib/python2.5/site-packages/cherrypy/LICENSE.txt
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/CherryPy/CherryPy.info b/libraries/CherryPy/CherryPy.info
new file mode 100644
index 0000000000..139be6ca2b
--- /dev/null
+++ b/libraries/CherryPy/CherryPy.info
@@ -0,0 +1,8 @@
+PRGNAM="CherryPy"
+VERSION="3.1.2"
+HOMEPAGE="http://www.cherrypy.org/"
+DOWNLOAD="http://download.cherrypy.org/cherrypy/3.1.2/CherryPy-3.1.2.tar.gz"
+MD5SUM="15c60b3a91886b9a304d366fba93669c"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/libraries/CherryPy/README b/libraries/CherryPy/README
new file mode 100644
index 0000000000..fa7107a588
--- /dev/null
+++ b/libraries/CherryPy/README
@@ -0,0 +1,5 @@
+CherryPy is a pythonic, object-oriented HTTP framework.
+CherryPy allows developers to build web applications in
+much the same way they would build any other object-oriented
+Python program. This results in smaller source code
+developed in less time. \ No newline at end of file
diff --git a/libraries/CherryPy/slack-desc b/libraries/CherryPy/slack-desc
new file mode 100644
index 0000000000..70a5d56b9b
--- /dev/null
+++ b/libraries/CherryPy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+CherryPy: CherryPy (A pythonic, object-oriented web development framework)
+CherryPy:
+CherryPy: A pythonic, object-oriented web development framework. CherryPy
+CherryPy: allows developers to build web applications in much the same way they
+CherryPy: would build any other object-oriented Python program. This results in
+CherryPy: smaller source code developed in less time.
+CherryPy:
+CherryPy: Homepage: http://www.cherrypy.org/
+CherryPy:
+CherryPy:
+CherryPy: