summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Mikhail Zotov <mikhail dot ru at gmail dot com>2011-03-03 23:32:42 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-03-03 23:32:42 -0300
commit232dc2c9efe7ead9936a02c5707c78bfc1a1247b (patch)
tree064d42302f03c61dccdef65625574d36a904fded /libraries
parent63d99c2e9f6f2ff507d0b5d238a12b0054d6ef51 (diff)
downloadslackbuilds-232dc2c9efe7ead9936a02c5707c78bfc1a1247b.tar.gz
slackbuilds-232dc2c9efe7ead9936a02c5707c78bfc1a1247b.tar.xz
libraries/fltk2: Updated for version 2.0.x_r8365.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/fltk2/README18
-rw-r--r--libraries/fltk2/fltk2.SlackBuild45
-rw-r--r--libraries/fltk2/fltk2.info8
-rw-r--r--libraries/fltk2/slack-desc2
4 files changed, 31 insertions, 42 deletions
diff --git a/libraries/fltk2/README b/libraries/fltk2/README
index 3aeca38a2c..6d06b067ce 100644
--- a/libraries/fltk2/README
+++ b/libraries/fltk2/README
@@ -1,10 +1,10 @@
-The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd C++
-graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and Microsoft(r)
-Windows(r). It was originally developed by Mr. Bill Spitzak and is currently
-maintained by a small group of developers across the world with a central
-repository in the US.
+The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd C++
+graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
+Microsoft(r) Windows(r). It was originally developed by Mr. Bill Spitzak
+and is currently maintained by a small group of developers across the world
+with a central repository in the US.
-The build script is for the development branch (version 2.0.x), thus it is
-named "fltk2" to distinguish from the stable one ("fltk") available at
-SlackBuilds.org. Notice that fltk2 does not overwrite any files of fltk;
-thus, it is possible to have both of them in the system if desired.
+The build script is for the development branch (version 2.0.x), thus it is
+named "fltk2" to distinguish from the stable one ("fltk") available at
+SlackBuilds.org. Notice that fltk2 does not overwrite any files of fltk.
+Thus, it is possible to have both of them in the system if desired.
diff --git a/libraries/fltk2/fltk2.SlackBuild b/libraries/fltk2/fltk2.SlackBuild
index 8d21ecb682..2b74b682f4 100644
--- a/libraries/fltk2/fltk2.SlackBuild
+++ b/libraries/fltk2/fltk2.SlackBuild
@@ -1,32 +1,14 @@
#!/bin/sh
-
-# Slackware build script for fltk, version 2
-
-# The script is based on the build script for FLTK, version 1, by LukenShiro.
-# The script has been fixed by the SlackBuilds.org team.
-
-# Copyright 2009-2010 Mikhail Zotov <mikhail dot ru@gmail dot com>
-# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
+# Slackware build script for fltk, version 2
#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# Maintainer of the script: Mikhail Zotov <mikhail dot ru@gmail dot com>
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# The script is based on the build script for FLTK, version 1, by LukenShiro.
+# The script has been fixed by the SlackBuilds.org team.
PRGNAM=fltk2
-VERSION=2.0.x_r7513
+VERSION=2.0.x_r8365
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,13 +53,20 @@ rm -rf $SRC_PRGNAM-$SRC_VERSION
tar xvf $CWD/$SRC_PRGNAM-$SRC_VERSION.tar.bz2
cd $SRC_PRGNAM-$SRC_VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
# Fix linking when --libdir=/usr/lib64
sed -i \
-e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
src/Makefile || exit
+# Make building more "verbose"
+sed -i 's/\.SILENT://' makeinclude.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -86,18 +75,18 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--enable-shared
-make
+make VERBOSE=1
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# No manpages are installed
+# Remove empty directories since no manual pages are installed
rm -rf $PKG/usr/man
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/fltk2.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/fltk2.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/libraries/fltk2/fltk2.info b/libraries/fltk2/fltk2.info
index 8dd2985e41..25eb0a41fa 100644
--- a/libraries/fltk2/fltk2.info
+++ b/libraries/fltk2/fltk2.info
@@ -1,10 +1,10 @@
PRGNAM="fltk2"
-VERSION="2.0.x-r7513"
+VERSION="2.0.x_r8365"
HOMEPAGE="http://www.fltk.org/"
-DOWNLOAD="http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/fltk/snapshots/fltk-2.0.x-r7513.tar.bz2"
-MD5SUM="557544badbacca4ee1ebb2448f6e1f8a"
+DOWNLOAD="http://ftp.easysw.com/pub/fltk/snapshots/fltk-2.0.x-r8365.tar.bz2"
+MD5SUM="a4a78694b8fc0e602cbc1c2a44267847"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Mikhail Zotov"
EMAIL="mikhail dot ru at gmail dot com"
-APPROVED="Erik Hanson"
+APPROVED="Niels Horn"
diff --git a/libraries/fltk2/slack-desc b/libraries/fltk2/slack-desc
index beff5e4e5c..b18872bdc2 100644
--- a/libraries/fltk2/slack-desc
+++ b/libraries/fltk2/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
-fltk2: FLTK (Fast Light Tool Kit), version 2
+fltk2: FLTK (Fast Light Tool Kit, version 2)
fltk2:
fltk2: The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
fltk2: C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r),