summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Grigorios Bouzakis <grbzks@xsmail.com>2011-05-15 22:04:30 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-05-15 22:04:30 -0500
commitad3f3308e812407b46cc134d2b46b759aad342f2 (patch)
treeeb182684c6adb82b67c6619b44340f8dc071b07f /libraries
parent0d668fab90a0297150c63a7f244c6bab3e6ea293 (diff)
downloadslackbuilds-ad3f3308e812407b46cc134d2b46b759aad342f2.tar.gz
slackbuilds-ad3f3308e812407b46cc134d2b46b759aad342f2.tar.xz
libraries/imlib2: Updated for version 1.4.4.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/imlib2/README2
-rw-r--r--libraries/imlib2/imlib2.SlackBuild51
-rw-r--r--libraries/imlib2/imlib2.info12
-rw-r--r--libraries/imlib2/slack-desc12
4 files changed, 36 insertions, 41 deletions
diff --git a/libraries/imlib2/README b/libraries/imlib2/README
index be22c6d4b3..eec04717d2 100644
--- a/libraries/imlib2/README
+++ b/libraries/imlib2/README
@@ -6,7 +6,7 @@ images, render images to an X-Windows drawable, produce pixmaps and
pixmap masks of images, apply filters to images, rotate images,
accept RGBA data for images, scale images, and more.
-Slackware 13.0 comes with Imlib 1.9.x - Note that the imlib2 site says:
+Slackware 13.37 comes with Imlib 1.9.x - Note that the imlib2 site says:
"Imlib2 can be installed alongside Imlib 1.x without any problems since
they are effectively different libraries - but they have very similar
functionality."
diff --git a/libraries/imlib2/imlib2.SlackBuild b/libraries/imlib2/imlib2.SlackBuild
index f3b6f3e182..ff6da4cdc1 100644
--- a/libraries/imlib2/imlib2.SlackBuild
+++ b/libraries/imlib2/imlib2.SlackBuild
@@ -1,40 +1,34 @@
#!/bin/sh
-
-# Slackware build script for Imlib2
+# Slackware build script for imlib2
# Copyright 2006-2009 Chess Griffin <chess@chessgriffin.com>
+# Copyright 2011 Grigorios Bouzakis <grbzks@xsmail.com>
# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# Permission to use, copy, modify, and distribute this software for any purpose
+# with or without fee is hereby granted, provided that the above copyright
+# notice and this permission notice appear in all copies.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by the SlackBuilds.org project
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
+# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+# FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# AUTHORS AND COPYRIGHT HOLDERS AND THEIR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=imlib2
-VERSION=1.4.2
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.4.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -58,6 +52,8 @@ else
LIBDIRSUFFIX=""
fi
+DOCS="AUTHORS COPYING COPYING-PLAIN ChangeLog INSTALL README TODO"
+
set -e
rm -rf $PKG
@@ -80,20 +76,19 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
- --enable-static=no \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Makefile*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/libraries/imlib2/imlib2.info b/libraries/imlib2/imlib2.info
index da73a340a8..53448cb99d 100644
--- a/libraries/imlib2/imlib2.info
+++ b/libraries/imlib2/imlib2.info
@@ -1,10 +1,10 @@
PRGNAM="imlib2"
-VERSION="1.4.2"
+VERSION="1.4.4"
HOMEPAGE="http://www.enlightenment.org"
-DOWNLOAD="http://downloads.sourceforge.net/enlightenment/imlib2-1.4.2.tar.gz"
-MD5SUM="0c866a7e696ad5ac58bc9312149f15f0"
+DOWNLOAD="http://downloads.sourceforge.net/enlightenment/imlib2-1.4.4.tar.gz"
+MD5SUM="20d59c7cda06742015baade6f5975415"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Chess Griffin"
-EMAIL="chess@chessgriffin.com"
-APPROVED="dsomero"
+MAINTAINER="Grigorios Bouzakis"
+EMAIL="grbzks@xsmail.com"
+APPROVED="rworkman"
diff --git a/libraries/imlib2/slack-desc b/libraries/imlib2/slack-desc
index dbe55c8ee1..7f7b26ad99 100644
--- a/libraries/imlib2/slack-desc
+++ b/libraries/imlib2/slack-desc
@@ -5,15 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler-------------------------------------------------------|
imlib2: Imlib2 (successor to Imlib)
-imlib2:
+imlib2:
imlib2: Imlib2 can load image files from disk in one of many formats, save
imlib2: images to disk in one of many formats, render image data onto other
imlib2: images, render images to an X-Windows drawable, produce pixmaps and
imlib2: pixmap masks of images, apply filters to images, rotate images,
imlib2: accept RGBA data for images, scale images, and more.
-imlib2:
-imlib2:
-imlib2:
-imlib2:
+imlib2:
+imlib2:
+imlib2:
+imlib2: