summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2016-08-22 00:14:58 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:59 +0100
commit1214131e1dff07f74462ae23a8ed3544cb6849ea (patch)
tree40a83803010fcd6dc858db530485c8d3d43eba59 /libraries
parent91be75add67bd9071446aa6a77f0f99699ce9690 (diff)
downloadslackbuilds-1214131e1dff07f74462ae23a8ed3544cb6849ea.tar.gz
slackbuilds-1214131e1dff07f74462ae23a8ed3544cb6849ea.tar.xz
libraries/grantlee-qt5: Added (template engine written in Qt5).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/grantlee-qt5/README8
-rw-r--r--libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch40
-rw-r--r--libraries/grantlee-qt5/grantlee-qt5.SlackBuild104
-rw-r--r--libraries/grantlee-qt5/grantlee-qt5.info10
-rw-r--r--libraries/grantlee-qt5/slack-desc19
5 files changed, 181 insertions, 0 deletions
diff --git a/libraries/grantlee-qt5/README b/libraries/grantlee-qt5/README
new file mode 100644
index 0000000000..276b9ca53a
--- /dev/null
+++ b/libraries/grantlee-qt5/README
@@ -0,0 +1,8 @@
+Grantlee is a set of Free Software libraries written using the Qt
+framework. Currently two libraries are shipped with Grantlee: Grantlee
+Templates and Grantlee TextDocument.
+
+The goal of Grantlee Templates is to make it easier for application
+developers to separate the structure of documents from the data they
+contain, opening the door for theming and advanced generation of other
+text such as code.
diff --git a/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch b/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch
new file mode 100644
index 0000000000..8788469924
--- /dev/null
+++ b/libraries/grantlee-qt5/grantlee-5.1.0-install_headers_into_versioned_directory.patch
@@ -0,0 +1,40 @@
+diff -up grantlee-5.1.0/CMakeLists.txt.orig grantlee-5.1.0/CMakeLists.txt
+--- grantlee-5.1.0/CMakeLists.txt.orig 2016-04-19 01:33:17.000000000 -0500
++++ grantlee-5.1.0/CMakeLists.txt 2016-04-19 06:44:06.371122149 -0500
+@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
+ set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+ set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
+ set( BIN_INSTALL_DIR bin )
+-set( INCLUDE_INSTALL_DIR include )
++set( INCLUDE_INSTALL_DIR include/Grantlee5 )
+ set( DATA_INSTALL_DIR share/apps )
+
+ # set up RPATH/install_name_dir
+diff -up grantlee-5.1.0/templates/lib/CMakeLists.txt.orig grantlee-5.1.0/templates/lib/CMakeLists.txt
+--- grantlee-5.1.0/templates/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
++++ grantlee-5.1.0/templates/lib/CMakeLists.txt 2016-04-19 06:44:55.763336264 -0500
+@@ -107,6 +107,10 @@ if (Qt5Script_FOUND)
+
+ target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
+ target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
++ target_include_directories(Grantlee_Templates
++ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
++ )
++
+ target_link_libraries(Grantlee_Templates
+ LINK_PRIVATE Qt5::Script
+ )
+diff -up grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig grantlee-5.1.0/textdocument/lib/CMakeLists.txt
+--- grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
++++ grantlee-5.1.0/textdocument/lib/CMakeLists.txt 2016-04-19 06:45:56.268598553 -0500
+@@ -43,6 +43,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Stud
+ endforeach()
+ endif()
+
++target_include_directories(Grantlee_TextDocument
++ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
++)
++
+ target_link_libraries(Grantlee_TextDocument
+ LINK_PUBLIC Qt5::Gui
+ )
diff --git a/libraries/grantlee-qt5/grantlee-qt5.SlackBuild b/libraries/grantlee-qt5/grantlee-qt5.SlackBuild
new file mode 100644
index 0000000000..1fae96c48c
--- /dev/null
+++ b/libraries/grantlee-qt5/grantlee-qt5.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for grantlee-qt5
+
+# Copyright 2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=grantlee-qt5
+SRCNAM=grantlee
+VERSION=${VERSION:-5.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+## upstreamable patches
+# Install headers into a versioned directory to be parallel-installable
+# based on:
+# https://github.com/steveire/grantlee/pull/1
+patch -p1 < $CWD/grantlee-5.1.0-install_headers_into_versioned_directory.patch
+
+mkdir build
+cd build
+ cmake -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DBUILD_TESTS:BOOL=FALSE \
+ -DLIB_SUFFIX:STRING="$LIBDIRSUFFIX" \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG COPYING.LIB README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/grantlee-qt5/grantlee-qt5.info b/libraries/grantlee-qt5/grantlee-qt5.info
new file mode 100644
index 0000000000..6d49364b8f
--- /dev/null
+++ b/libraries/grantlee-qt5/grantlee-qt5.info
@@ -0,0 +1,10 @@
+PRGNAM="grantlee-qt5"
+VERSION="5.1.0"
+HOMEPAGE="https://github.com/steveire/grantlee"
+DOWNLOAD="https://github.com/steveire/grantlee/archive/v5.1.0/grantlee-5.1.0.tar.gz"
+MD5SUM="3ce1e53cca2b5cad27d07ee82880e4c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="qt5"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/libraries/grantlee-qt5/slack-desc b/libraries/grantlee-qt5/slack-desc
new file mode 100644
index 0000000000..1aa092f454
--- /dev/null
+++ b/libraries/grantlee-qt5/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+grantlee-qt5: grantlee-qt5 (A string template engine written in Qt5)
+grantlee-qt5:
+grantlee-qt5: Grantlee is a set of Free Software libraries written using the Qt
+grantlee-qt5: framework. Currently two libraries are shipped with Grantlee:
+grantlee-qt5: Grantlee Templates and Grantlee TextDocument.
+grantlee-qt5:
+grantlee-qt5: The goal of Grantlee Templates is to make it easier for application
+grantlee-qt5: developers to separate the structure of documents from the data they
+grantlee-qt5: contain, opening the door for theming and advanced generation of other
+grantlee-qt5: text such as code.
+grantlee-qt5: Homepage: https://github.com/steveire/grantlee