summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+SBo@gmail.com>2017-04-17 12:08:10 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-22 08:10:42 +0700
commit1990dce4b0e9775124dde842c9001668ed9a489c (patch)
tree6e95147322117bb3ec710c2248748ca2dcce1f1a /libraries
parent28e1e074209de69e086dba6ecd5ef803552fa6d9 (diff)
downloadslackbuilds-1990dce4b0e9775124dde842c9001668ed9a489c.tar.gz
slackbuilds-1990dce4b0e9775124dde842c9001668ed9a489c.tar.xz
libraries/process-cpp: Added (C++11 library for handling processes).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/process-cpp/README3
-rw-r--r--libraries/process-cpp/process-cpp.SlackBuild96
-rw-r--r--libraries/process-cpp/process-cpp.info10
-rw-r--r--libraries/process-cpp/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/libraries/process-cpp/README b/libraries/process-cpp/README
new file mode 100644
index 0000000000..a93efb4bf5
--- /dev/null
+++ b/libraries/process-cpp/README
@@ -0,0 +1,3 @@
+process-cpp (C++11 library for handling processes)
+
+A simple convenience library for handling processes in C++11.
diff --git a/libraries/process-cpp/process-cpp.SlackBuild b/libraries/process-cpp/process-cpp.SlackBuild
new file mode 100644
index 0000000000..be59e115fb
--- /dev/null
+++ b/libraries/process-cpp/process-cpp.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for process-cpp
+
+# Copyright 2017 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=process-cpp
+VERSION=${VERSION:-3.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}*.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+truncate -s 0 tests/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/process-cpp/process-cpp.info b/libraries/process-cpp/process-cpp.info
new file mode 100644
index 0000000000..74f01ee7ad
--- /dev/null
+++ b/libraries/process-cpp/process-cpp.info
@@ -0,0 +1,10 @@
+PRGNAM="process-cpp"
+VERSION="3.0.1"
+HOMEPAGE="https://launchpad.net/process-cpp"
+DOWNLOAD="https://launchpad.net/ubuntu/+archive/primary/+files/process-cpp_3.0.1.orig.tar.gz"
+MD5SUM="95e187de74037b70b105679f85047c12"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="properties-cpp"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/libraries/process-cpp/slack-desc b/libraries/process-cpp/slack-desc
new file mode 100644
index 0000000000..e91c95337a
--- /dev/null
+++ b/libraries/process-cpp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+process-cpp: process-cpp (C++11 library for handling processes)
+process-cpp:
+process-cpp: A simple convenience library for handling processes in C++11.
+process-cpp:
+process-cpp: HOMEPAGE: https://launchpad.net/process-cpp
+process-cpp:
+process-cpp:
+process-cpp:
+process-cpp:
+process-cpp:
+process-cpp: