summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author dsomero <xgizzmo@gmail.com>2010-05-19 22:00:15 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-20 23:38:28 -0500
commitbc8d4751ef570f155392870d965b3dbe284ec97a (patch)
tree8527d189950faaab7de2c8104bc68bc4cc33afc4 /libraries
parent1bdf4b84edc3cd09ce9d4c3b887c6410166ac8e0 (diff)
downloadslackbuilds-bc8d4751ef570f155392870d965b3dbe284ec97a.tar.gz
slackbuilds-bc8d4751ef570f155392870d965b3dbe284ec97a.tar.xz
libraries/libpri: Removed (download link broken)
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libpri/README10
-rw-r--r--libraries/libpri/libpri-1.4.10.1-add_extra_cflags.patch12
-rw-r--r--libraries/libpri/libpri.SlackBuild74
-rw-r--r--libraries/libpri/libpri.info10
-rw-r--r--libraries/libpri/slack-desc19
5 files changed, 0 insertions, 125 deletions
diff --git a/libraries/libpri/README b/libraries/libpri/README
deleted file mode 100644
index 22482848fd..0000000000
--- a/libraries/libpri/README
+++ /dev/null
@@ -1,10 +0,0 @@
-libpri is a C implementation of the Primary Rate ISDN specification.
-It was based on the Bellcore specification SR-NWT-002343 for National
-ISDN. As of May 12, 2001, it has been tested work with NI-2, Nortel
-DMS-100, and Lucent 5E Custom protocols on switches from Nortel and
-Lucent.
-
-Please note that there are no man pages and precious little documentation
-for this library. The build is simple and straight forward though.
-
-libpri is an optional requirement to Asterisk.
diff --git a/libraries/libpri/libpri-1.4.10.1-add_extra_cflags.patch b/libraries/libpri/libpri-1.4.10.1-add_extra_cflags.patch
deleted file mode 100644
index fc52e296bd..0000000000
--- a/libraries/libpri/libpri-1.4.10.1-add_extra_cflags.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur libpri-1.4.10.1.orig/Makefile libpri-1.4.10.1/Makefile
---- libpri-1.4.10.1.orig/Makefile 2008-08-06 13:20:51.000000000 -0500
-+++ libpri-1.4.10.1/Makefile 2009-07-05 15:11:09.417405564 -0500
-@@ -43,7 +43,7 @@
- DYNAMIC_LIBRARY:=libpri.so.$(SONAME)
- STATIC_OBJS=copy_string.o pri.o q921.o prisched.o q931.o pri_facility.o version.o
- DYNAMIC_OBJS=copy_string.lo pri.lo q921.lo prisched.lo q931.lo pri_facility.lo version.lo
--CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(ALERTING) $(LIBPRI_COUNTERS)
-+CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(EXTRA_CFLAGS) $(ALERTING) $(LIBPRI_COUNTERS)
- INSTALL_PREFIX=$(DESTDIR)
- INSTALL_BASE=/usr
- libdir?=$(INSTALL_BASE)/lib
diff --git a/libraries/libpri/libpri.SlackBuild b/libraries/libpri/libpri.SlackBuild
deleted file mode 100644
index eb15071c17..0000000000
--- a/libraries/libpri/libpri.SlackBuild
+++ /dev/null
@@ -1,74 +0,0 @@
-#!/bin/bash
-# Copyright 2006, Alan Hicks, Lizella, GA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by Robby Workman <rworkman@slackbuilds.org>
-# No additional license terms :)
-
-PRGNAM=libpri
-VERSION=1.4.10.1
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- # "-fPIC" is already in the Makefile
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX="64"
-fi
-
-rm -fr $PKG $TMP/$PRGNAM-$VERSION
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chmod -R a-s,u+w,go+r-w .
-chown -R root:root .
-
-# Allow using our SLKCFLAGS
-patch -p1 < $CWD/libpri-1.4.10.1-add_extra_cflags.patch
-
-make libdir=/usr/lib${LIBDIRSUFFIX} EXTRA_CFLAGS="$SLKCFLAGS"
-make libdir=/usr/lib${LIBDIRSUFFIX} install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/install $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE README TODO $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libpri/libpri.info b/libraries/libpri/libpri.info
deleted file mode 100644
index d9ea8391ca..0000000000
--- a/libraries/libpri/libpri.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libpri"
-VERSION="1.4.10.1"
-HOMEPAGE="http://www.digium.com"
-DOWNLOAD="http://downloads.digium.com/pub/libpri/libpri-1.4.10.1.tar.gz"
-MD5SUM="55ce81cd0b2cf0c40e287fc5bd5b4883"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Alan Hicks"
-EMAIL="alan@lizella.net"
-APPROVED="rworkman"
diff --git a/libraries/libpri/slack-desc b/libraries/libpri/slack-desc
deleted file mode 100644
index e14a42cbed..0000000000
--- a/libraries/libpri/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-libpri: libpri (Primary Rate ISDN specification library)
-libpri:
-libpri: libpri is a C implementation of the Primary Rate ISDN specification.
-libpri: It was based on the Bellcore specification SR-NWT-002343 for National
-libpri: ISDN. As of May 12, 2001, it has been tested work with NI-2, Nortel
-libpri: DMS-100, and Lucent 5E Custom protocols on switches from Nortel and
-libpri: Lucent.
-libpri:
-libpri:
-libpri:
-libpri: