summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2011-10-19 07:48:31 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-10-19 07:48:31 -0200
commitc572b42ea8a53032de765636c42fa73503a7ecd1 (patch)
treeb1a816b6d712d1327c67f7d2df95c8bbb714ac0d /libraries
parent7ee07de82c3a51d3d659c45a756d710db3022706 (diff)
downloadslackbuilds-c572b42ea8a53032de765636c42fa73503a7ecd1.tar.gz
slackbuilds-c572b42ea8a53032de765636c42fa73503a7ecd1.tar.xz
python/Mako: Updated for version 0.5.0 (+new category)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/Mako/Mako.SlackBuild55
-rw-r--r--libraries/Mako/Mako.info10
-rw-r--r--libraries/Mako/README10
-rw-r--r--libraries/Mako/slack-desc19
4 files changed, 0 insertions, 94 deletions
diff --git a/libraries/Mako/Mako.SlackBuild b/libraries/Mako/Mako.SlackBuild
deleted file mode 100644
index f11016374e..0000000000
--- a/libraries/Mako/Mako.SlackBuild
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Mako
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=Mako
-VERSION=0.3.4
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG --no-compile
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES LICENSE README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/Mako/Mako.info b/libraries/Mako/Mako.info
deleted file mode 100644
index 263bd8c41a..0000000000
--- a/libraries/Mako/Mako.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Mako"
-VERSION="0.3.4"
-HOMEPAGE="http://www.makotemplates.org/"
-DOWNLOAD="http://pypi.python.org/packages/source/M/Mako/Mako-0.3.4.tar.gz"
-MD5SUM="2ae56ccc6c9b5c4e2e67f42b69475009"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="Erik Hanson"
diff --git a/libraries/Mako/README b/libraries/Mako/README
deleted file mode 100644
index 469dacc59a..0000000000
--- a/libraries/Mako/README
+++ /dev/null
@@ -1,10 +0,0 @@
-Mako is a template library written in Python. It provides a familiar, non-XML
-syntax which compiles into Python modules for maximum performance. Mako's
-syntax and API borrows from the best ideas of many others, including Django
-templates, Cheetah, Myghty, and Genshi. Conceptually, Mako is an embedded
-Python (i.e. Python Server Page) language, which refines the familiar ideas
-of componentized layout and inheritance to produce one of the most
-straightforward and flexible models available, while also maintaining close
-ties to Python calling and scoping semantics.
-
-This requires pysetuptools and MarkupSafe.
diff --git a/libraries/Mako/slack-desc b/libraries/Mako/slack-desc
deleted file mode 100644
index 98c2b86f0f..0000000000
--- a/libraries/Mako/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-Mako: Mako (A python templating language)
-Mako:
-Mako: Mako is a template library written in Python. It provides a familiar,
-Mako: non-XML syntax which compiles into Python modules for maximum
-Mako: performance. Mako's syntax and API borrows from the best ideas of many
-Mako: others, including Django templates, Cheetah, Myghty, and Genshi.
-Mako: Conceptually, Mako is an embedded Python (i.e. Python Server Page)
-Mako: language, which refines the familiar ideas of componentized layout and
-Mako: inheritance to produce one of the most straightforward and flexible
-Mako: models available, while also maintaining close ties to Python.
-Mako: Homepage: http://www.makotemplates.org/