summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2010-05-13 00:59:14 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:59:14 +0200
commitce235673647de9e54b08afb1a56760b2211e9910 (patch)
tree87b64441d9149c08de5aa3be9cb90e73b3409ea1 /libraries
parent7e60aaed6b7500de96bd200c99caf44a8148ed03 (diff)
downloadslackbuilds-ce235673647de9e54b08afb1a56760b2211e9910.tar.gz
slackbuilds-ce235673647de9e54b08afb1a56760b2211e9910.tar.xz
libraries/pydot: Added to 13.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pydot/README5
-rw-r--r--libraries/pydot/pydot.SlackBuild68
-rw-r--r--libraries/pydot/pydot.info10
-rw-r--r--libraries/pydot/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/libraries/pydot/README b/libraries/pydot/README
new file mode 100644
index 0000000000..1db185812e
--- /dev/null
+++ b/libraries/pydot/README
@@ -0,0 +1,5 @@
+pydot allows to easily create both directed and non directed graphs
+from Python. Currently all attributes implemented in the Dot
+language are supported (up to Graphviz 2.16).
+
+This requires pyparsing and graphviz.
diff --git a/libraries/pydot/pydot.SlackBuild b/libraries/pydot/pydot.SlackBuild
new file mode 100644
index 0000000000..2ea25853d4
--- /dev/null
+++ b/libraries/pydot/pydot.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for pydot
+
+# Copyright 2009 Heinz Wiesinger <pprkut@liwjatan.at>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pydot
+VERSION=1.0.2
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# remove wrongly installed docs
+rm -f $PKG/usr/{ChangeLog,LICENSE,README}
+
+find $PKG | xargs file | grep "shared object" | grep ELF | \
+ cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pydot/pydot.info b/libraries/pydot/pydot.info
new file mode 100644
index 0000000000..715844a8b5
--- /dev/null
+++ b/libraries/pydot/pydot.info
@@ -0,0 +1,10 @@
+PRGNAM="pydot"
+VERSION="1.0.2"
+HOMEPAGE="http://code.google.com/p/pydot/"
+DOWNLOAD="http://pydot.googlecode.com/files/pydot-1.0.2.tar.gz"
+MD5SUM="e5cbbe7ef3d221c05c96e4bd4bcf95f9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="pprkut"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="rworkman"
diff --git a/libraries/pydot/slack-desc b/libraries/pydot/slack-desc
new file mode 100644
index 0000000000..4ad4f38af1
--- /dev/null
+++ b/libraries/pydot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+pydot: pydot (Python interface to Graphviz's Dot language)
+pydot:
+pydot: pydot allows to easily create both directed and non directed graphs
+pydot: from Python. Currently all attributes implemented in the Dot
+pydot: language are supported (up to Graphviz 2.16).
+pydot:
+pydot: Homepage: http://code.google.com/p/pydot/
+pydot:
+pydot:
+pydot:
+pydot: