summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-02-17 14:41:41 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-02-18 14:59:54 -0600
commite6eba48c414ecf2e9e45b0b3f6de10f718ee7744 (patch)
tree81b3cd2542cbde289e966783b0b016ffc9861ae5 /libraries
parentffead9a2c2d5ffd40fdf5a91eab286b54d8231a9 (diff)
downloadslackbuilds-e6eba48c414ecf2e9e45b0b3f6de10f718ee7744.tar.gz
slackbuilds-e6eba48c414ecf2e9e45b0b3f6de10f718ee7744.tar.xz
libraries/ConfigParser: Added (backported configparser).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/ConfigParser/ConfigParser.SlackBuild86
-rw-r--r--libraries/ConfigParser/ConfigParser.info10
-rw-r--r--libraries/ConfigParser/README5
-rw-r--r--libraries/ConfigParser/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/libraries/ConfigParser/ConfigParser.SlackBuild b/libraries/ConfigParser/ConfigParser.SlackBuild
new file mode 100644
index 0000000000..bbee5420cd
--- /dev/null
+++ b/libraries/ConfigParser/ConfigParser.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for ConfigParser
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ConfigParser
+SRCNAM=configparser
+VERSION=${VERSION:-3.3.0r2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/ConfigParser/ConfigParser.info b/libraries/ConfigParser/ConfigParser.info
new file mode 100644
index 0000000000..c1d041dc56
--- /dev/null
+++ b/libraries/ConfigParser/ConfigParser.info
@@ -0,0 +1,10 @@
+PRGNAM="ConfigParser"
+VERSION="3.3.0r2"
+HOMEPAGE="http://docs.python.org/3/library/configparser.html"
+DOWNLOAD="https://pypi.python.org/packages/source/c/configparser/configparser-3.3.0r2.tar.gz"
+MD5SUM="dda0e6a43e9d8767b36d10f1e6770f09"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools ordereddict"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/ConfigParser/README b/libraries/ConfigParser/README
new file mode 100644
index 0000000000..78c255f079
--- /dev/null
+++ b/libraries/ConfigParser/README
@@ -0,0 +1,5 @@
+This library brings the updated configparser from Python 3.2+ to Python 2.6-2.7.
+
+The ancient ConfigParser module available in the standard library 2.x has
+seen a major update in Python 3.2. This is a backport of those changes so that
+they can be used directly in Python 2.6 - 2.7.
diff --git a/libraries/ConfigParser/slack-desc b/libraries/ConfigParser/slack-desc
new file mode 100644
index 0000000000..987f4f2470
--- /dev/null
+++ b/libraries/ConfigParser/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ConfigParser: ConfigParser (backported configparser)
+ConfigParser:
+ConfigParser: The ancient ConfigParser module available in the standard library 2.x
+ConfigParser: has seen a major update in Python 3.2. This is a backport of those
+ConfigParser: changes so that they can be used directly in Python 2.6 - 2.7.
+ConfigParser:
+ConfigParser: Homepage: http://docs.python.org/3/library/configparser.html
+ConfigParser:
+ConfigParser:
+ConfigParser:
+ConfigParser: