summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-03-11 08:33:11 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-03-12 12:42:50 -0500
commitf49205e6225b074d020cfecd103521f8c4000866 (patch)
tree6cd482770026d9cc93d1e610fb95e0fae45d0030 /libraries
parent32d8f3362ba09655b201670c1e3e67e2186aba41 (diff)
downloadslackbuilds-f49205e6225b074d020cfecd103521f8c4000866.tar.gz
slackbuilds-f49205e6225b074d020cfecd103521f8c4000866.tar.xz
libraries/fifechan: Added (C++ GUI library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/fifechan/README3
-rw-r--r--libraries/fifechan/fifechan.SlackBuild95
-rw-r--r--libraries/fifechan/fifechan.info10
-rw-r--r--libraries/fifechan/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/libraries/fifechan/README b/libraries/fifechan/README
new file mode 100644
index 0000000000..f3f8c741eb
--- /dev/null
+++ b/libraries/fifechan/README
@@ -0,0 +1,3 @@
+Fifechan is a lightweight cross platform GUI library written in C++ specifically
+designed for games. It has a small yet powerful built in set of extendable GUI
+Widgets allowing users to create virtually unlimited types of widgets.
diff --git a/libraries/fifechan/fifechan.SlackBuild b/libraries/fifechan/fifechan.SlackBuild
new file mode 100644
index 0000000000..7aafac779b
--- /dev/null
+++ b/libraries/fifechan/fifechan.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for fifechan
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fifechan
+VERSION=${VERSION:-0.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s| lib | lib${LIBDIRSUFFIX} |" CMakeLists.txt
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/fifechan/fifechan.info b/libraries/fifechan/fifechan.info
new file mode 100644
index 0000000000..c054286fdd
--- /dev/null
+++ b/libraries/fifechan/fifechan.info
@@ -0,0 +1,10 @@
+PRGNAM="fifechan"
+VERSION="0.1.1"
+HOMEPAGE="http://fifengine.github.io/fifechan/"
+DOWNLOAD="https://github.com/fifengine/fifechan/archive/0.1.1.tar.gz"
+MD5SUM="a6ebbd23d7ead7eee3248e6a77eec2f9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="allegro"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/fifechan/slack-desc b/libraries/fifechan/slack-desc
new file mode 100644
index 0000000000..8f2bfb4c9b
--- /dev/null
+++ b/libraries/fifechan/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fifechan: fifechan (C++ GUI library)
+fifechan:
+fifechan: Fifechan is a lightweight cross platform GUI
+fifechan: library written in C++ specifically designed for games.
+fifechan:
+fifechan: Homepage: http://fifengine.github.io/fifechan/
+fifechan:
+fifechan:
+fifechan:
+fifechan:
+fifechan: