summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2011-07-12 05:27:11 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:54:05 -0300
commitfc10d7ff1b194ec06be8c2d561ca72b324f5dd98 (patch)
treea19cdd9c129bd486e3dd8e4af316236e4fcc7e90 /libraries
parent2529a9a1b885b3dda5b838369872a0e7ae6ff41d (diff)
downloadslackbuilds-fc10d7ff1b194ec06be8c2d561ca72b324f5dd98.tar.gz
slackbuilds-fc10d7ff1b194ec06be8c2d561ca72b324f5dd98.tar.xz
python/lxml: Updated for version 2.3 and moved from libraries.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/lxml/README5
-rw-r--r--libraries/lxml/lxml.SlackBuild64
-rw-r--r--libraries/lxml/lxml.info10
-rw-r--r--libraries/lxml/slack-desc19
4 files changed, 0 insertions, 98 deletions
diff --git a/libraries/lxml/README b/libraries/lxml/README
deleted file mode 100644
index e258753366..0000000000
--- a/libraries/lxml/README
+++ /dev/null
@@ -1,5 +0,0 @@
-lxml is a Pythonic binding for the libxml2 and libxslt libraries.
-It is unique in that it combines the speed and feature completeness
-of these libraries with the simplicity of a native Python API.
-
-Lxml can optionally use Cython and pysetuptools.
diff --git a/libraries/lxml/lxml.SlackBuild b/libraries/lxml/lxml.SlackBuild
deleted file mode 100644
index e68b49fbb5..0000000000
--- a/libraries/lxml/lxml.SlackBuild
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/bin/sh
-# Slackware build script for lxml
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=lxml
-VERSION=2.2.7
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- *.txt PKG-INFO doc/licenses/* doc/FAQ.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-rm $PKG/usr/doc/$PRGNAM-$VERSION/version.txt
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/lxml/lxml.info b/libraries/lxml/lxml.info
deleted file mode 100644
index 6aacc86e37..0000000000
--- a/libraries/lxml/lxml.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="lxml"
-VERSION="2.2.7"
-HOMEPAGE="http://codespeak.net/lxml/"
-DOWNLOAD="http://codespeak.net/lxml/lxml-2.2.7.tgz"
-MD5SUM="c1da56b823fdc00804938d2b788dbfd0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="rworkman"
diff --git a/libraries/lxml/slack-desc b/libraries/lxml/slack-desc
deleted file mode 100644
index 35c7735bb9..0000000000
--- a/libraries/lxml/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-lxml: lxml
-lxml:
-lxml: lxml is a Pythonic binding for the libxml2 and libxslt libraries. It
-lxml: is unique in that it combines the speed and feature completeness of
-lxml: these libraries with the simplicity of a native Python API.
-lxml:
-lxml: Homepage: http://codespeak.net/lxml/
-lxml:
-lxml:
-lxml:
-lxml: