summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2016-12-16 23:38:32 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-17 01:18:30 +0700
commit70531054c49799ca9eb1820470c73f122652cdd1 (patch)
tree572d0022edcb59e0212124b453fb8d72ce4272ed /libraries
parentcb538f7e0479a5495f6459bb1031831056d51c73 (diff)
downloadslackbuilds-70531054c49799ca9eb1820470c73f122652cdd1.tar.gz
slackbuilds-70531054c49799ca9eb1820470c73f122652cdd1.tar.xz
libraries/hinnant-date: Added (A date and time library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/hinnant-date/CMakeLists.txt25
-rw-r--r--libraries/hinnant-date/README32
-rw-r--r--libraries/hinnant-date/hinnant-date.SlackBuild98
-rw-r--r--libraries/hinnant-date/hinnant-date.info10
-rw-r--r--libraries/hinnant-date/libdate.pc.in10
-rw-r--r--libraries/hinnant-date/slack-desc19
6 files changed, 194 insertions, 0 deletions
diff --git a/libraries/hinnant-date/CMakeLists.txt b/libraries/hinnant-date/CMakeLists.txt
new file mode 100644
index 0000000000..de22fa388b
--- /dev/null
+++ b/libraries/hinnant-date/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 3.2)
+
+project(date)
+set(LIBRARY_SHARED_OR_STATIC STATIC)
+
+set(header_files
+ date.h
+ tz.h tz_private.h
+ chrono_io.h
+ iso_week.h
+ julian.h
+ islamic.h)
+
+set(source_files
+ tz.cpp)
+
+add_library(${PROJECT_NAME} ${LIBRARY_SHARED_OR_STATIC} ${header_files} ${souce_files})
+set_target_properties(${PROJECT_NAME} PROPERTIES LINKER_LANGUAGE CXX)
+
+install(TARGETS ${PROJECT_NAME} DESTINATION lib${LIB_SUFFIX})
+install(FILES ${header_files} DESTINATION include)
+
+configure_file("libdate.pc.in" "libdate.pc" @ONLY)
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libdate.pc"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/pkgconfig")
diff --git a/libraries/hinnant-date/README b/libraries/hinnant-date/README
new file mode 100644
index 0000000000..fa21b3b670
--- /dev/null
+++ b/libraries/hinnant-date/README
@@ -0,0 +1,32 @@
+This is actually several separate C++11/C++14 libraries:
+
+ - date.h is a header-only library which builds upon <chrono>.
+ It adds some new duration types, and new time_point types. It
+ also adds field types such as year_month_day which is a
+ struct {year, month, day}. And it provides convenient means
+ to convert between the field types and the time_point types.
+
+ - tz.h / tz.cpp are a timezone library built on top of the
+ date.h library. This timezone library is a complete parser
+ of the IANA timezone database. It provides for an easy way to
+ access all of the data in this database, using the types from
+ date.h and <chrono>. The IANA database also includes data
+ on leap seconds, and this library provides utilities to compute
+ with that information as well.
+
+ - chrono_io.h is a header-only library for streaming out chrono
+ durations.
+
+ - iso_week.h is a header-only library built on top of the
+ date.h library which implements the ISO week date calendar.
+
+ - julian.h is a header-only library built on top of the date.h
+ library which implements a proleptic Julian calendar which is
+ fully interoperable with everything above.
+
+ - islamic.h is a header-only library built on top of the
+ date.h library which implements a proleptic Islamic calendar
+ which is fully interoperable with everything above.
+
+date.h and tz.h are now being proposed for standardization:
+http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2016/p0355r1.html
diff --git a/libraries/hinnant-date/hinnant-date.SlackBuild b/libraries/hinnant-date/hinnant-date.SlackBuild
new file mode 100644
index 0000000000..e1291ebfef
--- /dev/null
+++ b/libraries/hinnant-date/hinnant-date.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for Hinnant Date Library
+
+# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hinnant-date
+SRCNAM=date
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+cat $CWD/CMakeLists.txt > CMakeLists.txt
+cat $CWD/libdate.pc.in > libdate.pc.in
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar README.md test/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/hinnant-date/hinnant-date.info b/libraries/hinnant-date/hinnant-date.info
new file mode 100644
index 0000000000..a1e9d08df8
--- /dev/null
+++ b/libraries/hinnant-date/hinnant-date.info
@@ -0,0 +1,10 @@
+PRGNAM="hinnant-date"
+VERSION="2.0.0"
+HOMEPAGE="https://github.com/HowardHinnant/date"
+DOWNLOAD="https://github.com/HowardHinnant/date/archive/v2.0.0/date-2.0.0.tar.gz"
+MD5SUM="1685aaea4f73d1370245964489e0d33c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/libraries/hinnant-date/libdate.pc.in b/libraries/hinnant-date/libdate.pc.in
new file mode 100644
index 0000000000..fbf26d8efb
--- /dev/null
+++ b/libraries/hinnant-date/libdate.pc.in
@@ -0,0 +1,10 @@
+prefix=@CMAKE_INSTALL_PREFIX@
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib@LIB_SUFFIX@
+includedir=${prefix}/include
+
+Name: @CMAKE_PROJECT_NAME@
+Description: A date and time library based on the C++11
+Version: @VERSION@
+Libs: -L${libdir} -ldate
+Cflags: -I${includedir}
diff --git a/libraries/hinnant-date/slack-desc b/libraries/hinnant-date/slack-desc
new file mode 100644
index 0000000000..c8a68f0d3b
--- /dev/null
+++ b/libraries/hinnant-date/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hinnant-date: hinnant-date (A date and time library based on the C++11)
+hinnant-date:
+hinnant-date: This is actually several separate C++11/C++14 libraries:
+hinnant-date: date.h" is a header-only library which builds upon <chrono>.
+hinnant-date: tz.h are a timezone library built on top of the date.h library.
+hinnant-date: chrono_io.h is a library for streaming out chrono durations.
+hinnant-date: iso_week.h is a library which implements the ISO week date calendar.
+hinnant-date: julian.h library which implements a proleptic Julian calendar.
+hinnant-date: islamic.h library which implements a proleptic Islamic calendar.
+hinnant-date:
+hinnant-date: https://github.com/HowardHinnant/date