summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Mario Preksavec <mario at slackware dot hr>2017-08-09 01:17:25 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-08-12 06:57:39 +0700
commitd8cb1e19764ead7aa5b408042e20c47fa00f6ddf (patch)
treec079d3c86fac8770b19d2491a918d5c188722f3a /libraries
parent9d5aad10de6ae86ea2f5c4e5cb569e397fe30d0d (diff)
downloadslackbuilds-d8cb1e19764ead7aa5b408042e20c47fa00f6ddf.tar.gz
slackbuilds-d8cb1e19764ead7aa5b408042e20c47fa00f6ddf.tar.xz
libraries/ring-daemon: Added (LibRing - daemon).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/ring-daemon/README19
-rw-r--r--libraries/ring-daemon/patches/namedirectory.cpp.diff15
-rw-r--r--libraries/ring-daemon/patches/use_libexecdir.diff39
-rw-r--r--libraries/ring-daemon/ring-daemon.SlackBuild106
-rw-r--r--libraries/ring-daemon/ring-daemon.info10
-rw-r--r--libraries/ring-daemon/slack-desc19
6 files changed, 208 insertions, 0 deletions
diff --git a/libraries/ring-daemon/README b/libraries/ring-daemon/README
new file mode 100644
index 0000000000..b6c503fa82
--- /dev/null
+++ b/libraries/ring-daemon/README
@@ -0,0 +1,19 @@
+Ring is free software which allows its users to communicate in multiple ways.
+
+What is Ring?
+
+ A telephone: a simple tool to connect, communicate and share.
+
+ A teleconferencing tool: easily join calls to create conferences with
+ multiple participants.
+
+ A media sharing tool: Ring supports a variety of video input options,
+ including mutliple cameras and image and video files, and the selection of
+ audio inputs and outputs; all this is supported by multiple high quality
+ audio and video codecs.
+
+ A messenger: send text messeges during calls or out of calls (as long as
+ your peer is connected).
+
+ A building block for your IoT project: re-use the universal communications
+ technology of Ring with its portable library on your system of choice.
diff --git a/libraries/ring-daemon/patches/namedirectory.cpp.diff b/libraries/ring-daemon/patches/namedirectory.cpp.diff
new file mode 100644
index 0000000000..1657a5fb71
--- /dev/null
+++ b/libraries/ring-daemon/patches/namedirectory.cpp.diff
@@ -0,0 +1,15 @@
+--- ring-daemon-4.0.0/src/ringdht/namedirectory.cpp.orig 2017-07-19 23:27:21.000000000 +0200
++++ ring-daemon-4.0.0/src/ringdht/namedirectory.cpp 2017-08-01 15:50:13.311715765 +0200
+@@ -90,9 +90,9 @@
+ size_t getContentLength(restbed::Response& reply)
+ {
+ size_t length = 0;
+-#ifndef RESTBED_OLD_API
+- length =
+-#endif
++//#ifndef RESTBED_OLD_API
++// length =
++//#endif
+ reply.get_header("Content-Length", length);
+ return length;
+ }
diff --git a/libraries/ring-daemon/patches/use_libexecdir.diff b/libraries/ring-daemon/patches/use_libexecdir.diff
new file mode 100644
index 0000000000..1f9162bca8
--- /dev/null
+++ b/libraries/ring-daemon/patches/use_libexecdir.diff
@@ -0,0 +1,39 @@
+--- ring-daemon-4.0.0/configure.ac.orig 2017-07-19 23:27:21.000000000 +0200
++++ ring-daemon-4.0.0/configure.ac 2017-08-01 16:34:48.826571353 +0200
+@@ -368,8 +368,8 @@
+ AS_IF([test "x$with_dbus" = "xyes"], [
+ PKG_CHECK_MODULES(DBUSCPP, dbus-c++-1,, AC_MSG_WARN([Missing dbus development files]))
+
+- AS_AC_EXPAND(LIBDIR, $libdir)
+- AC_SUBST(LIBDIR)
++ AS_AC_EXPAND(LIBEXECDIR, $libexecdir)
++ AC_SUBST(LIBEXECDIR)
+
+ AC_CONFIG_FILES([bin/dbus/Makefile
+ bin/dbus/cx.ring.Ring.service])
+--- ring-daemon-4.0.0/globals.mk.orig 2017-07-19 23:27:21.000000000 +0200
++++ ring-daemon-4.0.0/globals.mk 2017-08-01 16:36:01.520567429 +0200
+@@ -1,7 +1,7 @@
+ # Global variables
+
+ src=$(abs_top_srcdir)
+-ringlibdir=$(DESTDIR)$(libdir)/ring
++ringlibdir=$(DESTDIR)$(libexecdir)/ring
+
+ ASTYLERC="$(top_srcdir)/../astylerc"
+ indent="/usr/bin/astyle"
+--- ring-daemon-4.0.0/bin/dbus/cx.ring.Ring.service.in.orig 2017-07-19 23:27:21.000000000 +0200
++++ ring-daemon-4.0.0/bin/dbus/cx.ring.Ring.service.in 2017-08-01 16:39:22.606556575 +0200
+@@ -1,3 +1,3 @@
+ [D-BUS Service]
+ Name=cx.ring.Ring
+-Exec=@LIBDIR@/ring/dring
++Exec=@LIBEXECDIR@/ring/dring
+--- ring-daemon-4.0.0/bin/Makefile.am.orig 2017-07-19 23:27:21.000000000 +0200
++++ ring-daemon-4.0.0/bin/Makefile.am 2017-08-01 16:51:06.985518556 +0200
+@@ -1,4 +1,4 @@
+-ringlibdir = $(libdir)/ring
++ringlibdir = $(libexecdir)/ring
+
+ if HAVE_WIN32
+ ringlib_PROGRAMS = ringcli
diff --git a/libraries/ring-daemon/ring-daemon.SlackBuild b/libraries/ring-daemon/ring-daemon.SlackBuild
new file mode 100644
index 0000000000..77cd7a01d0
--- /dev/null
+++ b/libraries/ring-daemon/ring-daemon.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# Slackware build script for ring-daemon
+
+# Copyright 2017 Mario Preksavec, Zagreb, Croatia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ring-daemon
+VERSION=${VERSION:-4.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 <$CWD/patches/namedirectory.cpp.diff
+patch -p1 <$CWD/patches/use_libexecdir.diff
+
+./autogen.sh
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-ipv6 \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CODING COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/ring-daemon/ring-daemon.info b/libraries/ring-daemon/ring-daemon.info
new file mode 100644
index 0000000000..e324341cd3
--- /dev/null
+++ b/libraries/ring-daemon/ring-daemon.info
@@ -0,0 +1,10 @@
+PRGNAM="ring-daemon"
+VERSION="4.0.0"
+HOMEPAGE="https://ring.cx/"
+DOWNLOAD="https://github.com/savoirfairelinux/ring-daemon/archive/4.0.0/ring-daemon-4.0.0.tar.gz"
+MD5SUM="6bab7f9c1939c422916a69eb36b77f2a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pjproject-ring yaml-cpp jsoncpp libdbus-c++ restbed gsm speex opendht cryptopp libupnp libnatpmp ffmpeg"
+MAINTAINER="Mario Preksavec"
+EMAIL="mario at slackware dot hr"
diff --git a/libraries/ring-daemon/slack-desc b/libraries/ring-daemon/slack-desc
new file mode 100644
index 0000000000..733f8bc164
--- /dev/null
+++ b/libraries/ring-daemon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ring-daemon: ring-daemon (LibRing - daemon)
+ring-daemon:
+ring-daemon: Ring is a free and universal communication platform which preserves
+ring-daemon: the users' privacy and freedoms.
+ring-daemon:
+ring-daemon: Homepage: https://ring.cx/
+ring-daemon:
+ring-daemon:
+ring-daemon:
+ring-daemon:
+ring-daemon: