summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-03-13 14:34:57 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-03-21 13:01:14 -0500
commit07474dacc2d35d41227460a2ad36e39ab8cd802b (patch)
treef3adbca34477094d8e535e94da862afe99016e44 /libraries
parent7c579abbd5df812ce3404284a232c9344e510b54 (diff)
downloadslackbuilds-07474dacc2d35d41227460a2ad36e39ab8cd802b.tar.gz
slackbuilds-07474dacc2d35d41227460a2ad36e39ab8cd802b.tar.xz
libraries/poco: Added (C++ class libraries).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/poco/README4
-rw-r--r--libraries/poco/doinst.sh3
-rw-r--r--libraries/poco/poco.SlackBuild109
-rw-r--r--libraries/poco/poco.info10
-rw-r--r--libraries/poco/poco_x64.patch22
-rw-r--r--libraries/poco/slack-desc19
6 files changed, 167 insertions, 0 deletions
diff --git a/libraries/poco/README b/libraries/poco/README
new file mode 100644
index 0000000000..a656cb51b4
--- /dev/null
+++ b/libraries/poco/README
@@ -0,0 +1,4 @@
+Modern, powerful open source C++ class libraries and
+frameworks for building network- and internet-based
+applications that run on desktop, server, mobile and
+embedded systems.
diff --git a/libraries/poco/doinst.sh b/libraries/poco/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/libraries/poco/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/libraries/poco/poco.SlackBuild b/libraries/poco/poco.SlackBuild
new file mode 100644
index 0000000000..41f1300966
--- /dev/null
+++ b/libraries/poco/poco.SlackBuild
@@ -0,0 +1,109 @@
+#!/bin/sh
+
+# Slackware build script for poco
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=poco
+VERSION=${VERSION:-1.4.6p2}
+SRCVERSION=$VERSION-all
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+cd $PRGNAM-$SRCVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "$ARCH" = "x86_64" ]; then
+ patch -p1 < $CWD/poco_x64.patch
+fi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --config=Linux \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -name perllocal.pod \
+ -o -name ".packlist" \
+ -o -name "*.bs" \
+ | xargs rm -f
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG CONTRIBUTORS NEWS LICENSE VERSION README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/poco/poco.info b/libraries/poco/poco.info
new file mode 100644
index 0000000000..8bf6d6fc02
--- /dev/null
+++ b/libraries/poco/poco.info
@@ -0,0 +1,10 @@
+PRGNAM="poco"
+VERSION="1.4.6p2"
+HOMEPAGE="http://pocoproject.org"
+DOWNLOAD="http://pocoproject.org/releases/poco-1.4.6/poco-1.4.6p2-all.tar.gz"
+MD5SUM="d52da79952ea454baa9eb3629aca9b98"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mysql-connector-c++ unixODBC"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/poco/poco_x64.patch b/libraries/poco/poco_x64.patch
new file mode 100644
index 0000000000..aeac7c1b06
--- /dev/null
+++ b/libraries/poco/poco_x64.patch
@@ -0,0 +1,22 @@
+--- poco-1.4.6p2-all/Makefile.original 2014-03-13 14:12:58.141661715 +0700
++++ poco-1.4.6p2-all/Makefile 2014-03-13 14:14:32.910933057 +0700
+@@ -33,7 +33,7 @@
+
+ install: libexecs
+ mkdir -p $(INSTALLDIR)/include/Poco
+- mkdir -p $(INSTALLDIR)/lib
++ mkdir -p $(INSTALLDIR)/lib64
+ mkdir -p $(INSTALLDIR)/bin
+ for comp in $(COMPONENTS) ; do \
+ if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
+@@ -43,8 +43,8 @@
+ find $(POCO_BUILD)/$$comp/bin -perm -700 -type f -exec cp -f {} $(INSTALLDIR)/bin \; ; \
+ fi ; \
+ done
+- find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
+- find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
++ find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
++ find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
+
+ libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
+ tests = Foundation-tests XML-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests Zip-tests
diff --git a/libraries/poco/slack-desc b/libraries/poco/slack-desc
new file mode 100644
index 0000000000..d1eb7304e9
--- /dev/null
+++ b/libraries/poco/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+poco: poco (C++ class libraries)
+poco:
+poco: Modern, powerful open source C++ class libraries and
+poco: frameworks for building network- and internet-based
+poco: applications that run on desktop, server, mobile and
+poco: embedded systems.
+poco:
+poco: Homepage: http://pocoproject.org
+poco:
+poco:
+poco: