summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Lockywolf <for_sbo.nghttp3_2023-05-17@lockywolf.net>2023-05-18 22:30:08 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:10 +0700
commit07f25875963aebe82c58bd9afb3fb9e78f852de4 (patch)
tree0c4202e80a979433d28bd9135dcec14e4379c016 /libraries
parent0b78d3df93c1198912c8a1177de1922ca1da8090 (diff)
downloadslackbuilds-07f25875963aebe82c58bd9afb3fb9e78f852de4.tar.gz
slackbuilds-07f25875963aebe82c58bd9afb3fb9e78f852de4.tar.xz
libraries/nghttp3: Added (RFC9114 HTTP/3 implementation over QUIC)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/nghttp3/README42
-rw-r--r--libraries/nghttp3/nghttp3.SlackBuild103
-rw-r--r--libraries/nghttp3/nghttp3.info10
-rw-r--r--libraries/nghttp3/slack-desc19
4 files changed, 174 insertions, 0 deletions
diff --git a/libraries/nghttp3/README b/libraries/nghttp3/README
new file mode 100644
index 0000000000..7170da6f09
--- /dev/null
+++ b/libraries/nghttp3/README
@@ -0,0 +1,42 @@
+nghttp3
+=======
+
+nghttp3 is an implementation of `RFC 9114
+<https://datatracker.ietf.org/doc/html/rfc9114>`_ HTTP/3 mapping over
+QUIC and `RFC 9204 <https://datatracker.ietf.org/doc/html/rfc9204>`_
+QPACK in C.
+
+It does not depend on any particular QUIC transport implementation.
+
+Documentation
+-------------
+
+`Online documentation <https://nghttp2.org/nghttp3/>`_ is available.
+
+HTTP/3
+------
+
+This library implements `RFC 9114
+<https://datatracker.ietf.org/doc/html/rfc9114>`_ HTTP/3. It does not
+support server push.
+
+The following extensions have been implemented:
+
+- `Extensible Prioritization Scheme for HTTP
+ <https://datatracker.ietf.org/doc/html/rfc9218>`_
+- `Bootstrapping WebSockets with HTTP/3
+ <https://datatracker.ietf.org/doc/html/rfc9220>`_
+
+QPACK
+-----
+
+This library implements `RFC 9204
+<https://datatracker.ietf.org/doc/html/rfc9204>`_ QPACK. It supports
+dynamic table.
+
+License
+-------
+
+The MIT License
+
+Copyright (c) 2019 nghttp3 contributors
diff --git a/libraries/nghttp3/nghttp3.SlackBuild b/libraries/nghttp3/nghttp3.SlackBuild
new file mode 100644
index 0000000000..9c23d2e362
--- /dev/null
+++ b/libraries/nghttp3/nghttp3.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/bash
+
+# Slackware build script for nghttp3
+# Copyright 2023 Lockywolf Earth
+
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nghttp3
+VERSION=${VERSION:-0.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+set -e
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i '/find_package(CUnit 2.1)/d' CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DENABLE_STATIC_LIB=OFF \
+ -DENABLE_LIB_ONLY=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/nghttp3/nghttp3.info b/libraries/nghttp3/nghttp3.info
new file mode 100644
index 0000000000..cbcc5bdbe1
--- /dev/null
+++ b/libraries/nghttp3/nghttp3.info
@@ -0,0 +1,10 @@
+PRGNAM="nghttp3"
+VERSION="0.10.0"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3"
+DOWNLOAD="https://github.com/ngtcp2/nghttp3/releases/download/v0.10.0/nghttp3-0.10.0.tar.xz"
+MD5SUM="a1123ac15ee18b4508d9dc43f3e6b379"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.nghttp3_2023-05-17@lockywolf.net"
diff --git a/libraries/nghttp3/slack-desc b/libraries/nghttp3/slack-desc
new file mode 100644
index 0000000000..efc49a5abb
--- /dev/null
+++ b/libraries/nghttp3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+nghttp3: nghttp3 (an implementation of RFC 9114 HTTP/3 over QUIC)
+nghttp3:
+nghttp3: nghttp3 is an implementation of RFC 9114 HTTP/3 mapping over QUIC
+nghttp3: and RFC 9204 QPACK in C.
+nghttp3: It does not depend on any particular QUIC transport implementation.
+nghttp3:
+nghttp3:
+nghttp3:
+nghttp3:
+nghttp3:
+nghttp3: