summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Lockywolf <for_sbo.python3-imapclient_2023-05-24@lockywolf.net>2023-05-26 19:05:00 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-27 08:08:51 +0700
commit6089b83993c87dd4e624d56b3de9bf6be28fefe4 (patch)
tree267b647698a704be9d014b8c2021ff9eee24edb2 /libraries
parentcfdc90785d94679a1c580063f94aa9a9684ad75a (diff)
downloadslackbuilds-6089b83993c87dd4e624d56b3de9bf6be28fefe4.tar.gz
slackbuilds-6089b83993c87dd4e624d56b3de9bf6be28fefe4.tar.xz
libraries/python3-imapclient: Added (Pythonic IMAP client library)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python3-imapclient/README18
-rw-r--r--libraries/python3-imapclient/python3-imapclient.SlackBuild78
-rw-r--r--libraries/python3-imapclient/python3-imapclient.info10
-rw-r--r--libraries/python3-imapclient/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/libraries/python3-imapclient/README b/libraries/python3-imapclient/README
new file mode 100644
index 0000000000..3a4f8d4bb8
--- /dev/null
+++ b/libraries/python3-imapclient/README
@@ -0,0 +1,18 @@
+IMAPClient is an easy-to-use, Pythonic and complete IMAP client
+library.
+
+Features:
+
+- Arguments and return values are natural Python types.
+- IMAP server responses are fully parsed and readily usable.
+- IMAP unique message IDs (UIDs) are handled transparently. There is
+ no need to call different methods to use UIDs.
+- Escaping for internationalised mailbox names is transparently
+ handled. Unicode mailbox names may be passed as input wherever a
+ folder name is accepted.
+- Time zones are transparently handled including when the server and
+ client are in different zones.
+- Convenience methods are provided for commonly used functionality.
+- Exceptions are raised when errors occur.
+
+This build only supports python3.
diff --git a/libraries/python3-imapclient/python3-imapclient.SlackBuild b/libraries/python3-imapclient/python3-imapclient.SlackBuild
new file mode 100644
index 0000000000..dc5d5c56a4
--- /dev/null
+++ b/libraries/python3-imapclient/python3-imapclient.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/bash
+
+# Slackware build script for python3-imapclient
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-imapclient
+TGZNAM=IMAPClient
+VERSION=${VERSION:-2.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+ARCH=noarch
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TGZNAM-$VERSION
+unzip $CWD/$TGZNAM-$VERSION.zip
+cd $TGZNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.rst NEWS.rst README.rst COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/python3-imapclient/python3-imapclient.info b/libraries/python3-imapclient/python3-imapclient.info
new file mode 100644
index 0000000000..1a75536617
--- /dev/null
+++ b/libraries/python3-imapclient/python3-imapclient.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-imapclient"
+VERSION="2.3.1"
+HOMEPAGE="https://imapclient.freshfoo.com/"
+DOWNLOAD="https://files.pythonhosted.org/packages/19/d8/a4a0337d5e39a0569d89793d5053d7535eefd9b8756df4e10dc114caf3c2/IMAPClient-2.3.1.zip"
+MD5SUM="785bc3d7560d14b0d6c2a4dfa257e11b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-imapclient_2023-05-24@lockywolf.net"
diff --git a/libraries/python3-imapclient/slack-desc b/libraries/python3-imapclient/slack-desc
new file mode 100644
index 0000000000..652dac16e8
--- /dev/null
+++ b/libraries/python3-imapclient/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-imapclient: python3-imapclient (Pythonic and complete IMAP client library)
+python3-imapclient:
+python3-imapclient: python3-imapclient is an easy, Pythonic and complete IMAP client
+python3-imapclient: library.
+python3-imapclient:
+python3-imapclient: Homepage: https://imapclient.freshfoo.com/
+python3-imapclient:
+python3-imapclient: This package is for the python3 version.
+python3-imapclient:
+python3-imapclient:
+python3-imapclient: