summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Giancarlo Dessì <slack@giand.it>2022-04-01 18:55:28 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:19:21 +0700
commit63b442bba655ad5fcbf22595fd9894787c738d49 (patch)
treeda9e5766c448112cb24f4f3c48809e2d685a9968 /libraries
parentc7deb90b5826f5a339e14c6418246475878d4e2d (diff)
downloadslackbuilds-63b442bba655ad5fcbf22595fd9894787c738d49.tar.gz
slackbuilds-63b442bba655ad5fcbf22595fd9894787c738d49.tar.xz
libraries/spglib: Added (ibrary for crystal symmetry search)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/spglib/README4
-rw-r--r--libraries/spglib/slack-desc19
-rw-r--r--libraries/spglib/spglib.SlackBuild110
-rw-r--r--libraries/spglib/spglib.info10
4 files changed, 143 insertions, 0 deletions
diff --git a/libraries/spglib/README b/libraries/spglib/README
new file mode 100644
index 0000000000..28524c3ec9
--- /dev/null
+++ b/libraries/spglib/README
@@ -0,0 +1,4 @@
+Spglib is a C library that implements a computer algorithm to search
+crystal symmetries of crystal structures.
+It is supported as optional dependency in Avogadro 2 or can be used
+with python, fortran, rust, and ruby interfaces.
diff --git a/libraries/spglib/slack-desc b/libraries/spglib/slack-desc
new file mode 100644
index 0000000000..1f5b97c312
--- /dev/null
+++ b/libraries/spglib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+spglib: spglib (software library for crystal symmetry search)
+spglib:
+spglib: Spglib is a library for finding and handling crystal symmetries
+spglib: written in C
+spglib:
+spglib:
+spglib:
+spglib:
+spglib: Homepage: https://spglib.github.io/spglib/
+spglib:
+spglib:
diff --git a/libraries/spglib/spglib.SlackBuild b/libraries/spglib/spglib.SlackBuild
new file mode 100644
index 0000000000..d628647ada
--- /dev/null
+++ b/libraries/spglib/spglib.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/bash
+
+# Slackware build script for spglib
+
+# Copyright 2020-2022 Giancarlo Dessì, Cagliari, IT
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+#
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=spglib
+VERSION=${VERSION:-1.16.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+#Build the python bindings
+(
+ cd python
+ python3 setup.py install --root=$PKG
+)
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/spglib/spglib.info b/libraries/spglib/spglib.info
new file mode 100644
index 0000000000..eefeb64444
--- /dev/null
+++ b/libraries/spglib/spglib.info
@@ -0,0 +1,10 @@
+PRGNAM="spglib"
+VERSION="1.16.3"
+HOMEPAGE="https://spglib.github.io/spglib/"
+DOWNLOAD="https://www.giand.it/tic/download/avogadro/spglib-1.16.3.tar.gz"
+MD5SUM="959ef6aa1f2c345531b73e62db5fdb24"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="numpy3"
+MAINTAINER="Giancarlo Dessì"
+EMAIL="slack@giand.it"