summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Ozan Türkyılmaz <ozan.turkyilmaz@gmail.com>2022-03-28 17:01:25 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:18:54 +0700
commitf862997883f18b2129989c675eecb655b0983345 (patch)
tree9a6440e4a395fd533e54511c6947f881f8f96958 /libraries
parentf7ae66333b5a73d5a4dc366973caeac65e76e0a9 (diff)
downloadslackbuilds-f862997883f18b2129989c675eecb655b0983345.tar.gz
slackbuilds-f862997883f18b2129989c675eecb655b0983345.tar.xz
libraries/liboop Update to 1.0.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/liboop/README4
-rw-r--r--libraries/liboop/liboop.SlackBuild12
-rw-r--r--libraries/liboop/liboop.info8
-rw-r--r--libraries/liboop/patches/tcl_dev.patch22
4 files changed, 39 insertions, 7 deletions
diff --git a/libraries/liboop/README b/libraries/liboop/README
index 08dd15820a..7727ed461e 100644
--- a/libraries/liboop/README
+++ b/libraries/liboop/README
@@ -6,3 +6,7 @@ It replaces the "select() loop" and allows the registration of event
handlers for file and network I/O, timers and signals. Since processes
use these mechanisms for almost all external communication, liboop can
be used as the basis for almost any application.
+
+adns is optional dependency. When adns is installed, the script will
+build a liboop adns version. No additinal commands are needed.
+Configure will catch it automatically.
diff --git a/libraries/liboop/liboop.SlackBuild b/libraries/liboop/liboop.SlackBuild
index 44830d4023..03115f0b52 100644
--- a/libraries/liboop/liboop.SlackBuild
+++ b/libraries/liboop/liboop.SlackBuild
@@ -12,7 +12,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=liboop
-VERSION=${VERSION:-1.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,6 +66,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch the configure etc so it can compile with Slackware's tcl.
+patch -p1 < $CWD/patches/tcl_dev.patch
+
+# Fool autotools so it won't complain and we can simple configure and make
+find . -exec touch -m {} +
+
# build including libwww adapter
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -79,7 +85,7 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-static \
--build=$ARCH-slackware-linux
-make -j1
+make
make install DESTDIR=$PKG
( cd $PKG || exit 1
@@ -91,7 +97,7 @@ make install DESTDIR=$PKG
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
diff --git a/libraries/liboop/liboop.info b/libraries/liboop/liboop.info
index 84d3176fb5..67d775c188 100644
--- a/libraries/liboop/liboop.info
+++ b/libraries/liboop/liboop.info
@@ -1,8 +1,8 @@
PRGNAM="liboop"
-VERSION="1.0"
-HOMEPAGE="http://liboop.ofb.net/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/liboop-1.0.tar.gz"
-MD5SUM="36cb971047d3af02369446f5e0b315a2"
+VERSION="1.0.1"
+HOMEPAGE="https://www.lysator.liu.se/liboop/"
+DOWNLOAD="https://ftp.lysator.liu.se/pub/liboop/liboop-1.0.1.tar.gz"
+MD5SUM="f2b3dff17355fd9a6e2229caca8993f0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/liboop/patches/tcl_dev.patch b/libraries/liboop/patches/tcl_dev.patch
new file mode 100644
index 0000000000..8a93aeb502
--- /dev/null
+++ b/libraries/liboop/patches/tcl_dev.patch
@@ -0,0 +1,22 @@
+--- a/configure
++++ b/configure
+@@ -12666,7 +12666,7 @@ fi
+ fi
+
+ if test xno != x$with_tcl; then
+- for version in 8.4 8.3 8.2 8.1 8.0 ; do
++ for version in "" 8.4 8.3 8.2 8.1 8.0 ; do
+ CPPFLAGS="$save_cppflags -I/usr/include/tcl$version"
+ as_ac_Lib=`$as_echo "ac_cv_lib_tcl$version''_Tcl_Main" | $as_tr_sh`
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Tcl_Main in -ltcl$version" >&5
+--- a/configure.ac
++++ b/configure.ac
+@@ -71,7 +71,7 @@ if test xno != x$with_glib; then
+ fi
+
+ if test xno != x$with_tcl; then
+- for version in 8.4 8.3 8.2 8.1 8.0 ; do
++ for version in "" 8.4 8.3 8.2 8.1 8.0 ; do
+ CPPFLAGS="$save_cppflags -I/usr/include/tcl$version"
+ AC_CHECK_LIB(tcl$version,Tcl_Main,[
+ AC_CHECK_HEADER(tcl.h,[