summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-24 14:10:28 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-24 14:10:28 -0400
commit80c17312fe5723f56980a7d1cd02900b556e4f9c (patch)
tree4abb49126e526063b45965fd2ee66b66a804dd1b /libraries
parent87b21e1d3f9d727224c25d0758f87d37e860c2d9 (diff)
downloadslackbuilds-80c17312fe5723f56980a7d1cd02900b556e4f9c.tar.gz
slackbuilds-80c17312fe5723f56980a7d1cd02900b556e4f9c.tar.xz
libraries/libvirt: Strip binaries.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libvirt/libvirt.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/libraries/libvirt/libvirt.SlackBuild b/libraries/libvirt/libvirt.SlackBuild
index cedba26d74..032b2fe58a 100644
--- a/libraries/libvirt/libvirt.SlackBuild
+++ b/libraries/libvirt/libvirt.SlackBuild
@@ -4,11 +4,14 @@
# Written by Michal Bialozor <bialyy@o2.pl>
# Maintained by Robby Workman <rworkman@slackbuilds.org>
+# 20220422 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - strip binaries.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libvirt
VERSION=${VERSION:-8.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -20,9 +23,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -64,9 +64,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# we have sysctld files in /etc/sysctl.d
sed -i "s|prefix / 'lib' / 'sysctl.d'|sysconfdir / 'sysctl.d'|" src/remote/meson.build
@@ -107,6 +107,7 @@ cd build
-Dstorage_sheepdog=disabled \
-Dstorage_vstorage=disabled \
-Ddtrace=disabled \
+ -Dstrip=true \
-Dinit_script=none
"${NINJA:=ninja}"
DESTDIR=$PKG $NINJA install
@@ -144,8 +145,7 @@ if [ -e $PKG/etc/libvirt/qemu.conf ]; then
$PKG/etc/libvirt/qemu.conf
fi
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION/