summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-24 15:24:40 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-24 15:24:40 -0400
commita0161a7e47b14bdc8f1017b838addd2f43bfea24 (patch)
tree0f4bd68388e187ff1d95eb80053591b066423575 /libraries
parenta08749f12670b1ba7b50e2ea2effe829429bb75a (diff)
downloadslackbuilds-a0161a7e47b14bdc8f1017b838addd2f43bfea24.tar.gz
slackbuilds-a0161a7e47b14bdc8f1017b838addd2f43bfea24.tar.xz
libraries/process-cpp: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/process-cpp/process-cpp.SlackBuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/libraries/process-cpp/process-cpp.SlackBuild b/libraries/process-cpp/process-cpp.SlackBuild
index 0eec4903b1..3e603834a9 100644
--- a/libraries/process-cpp/process-cpp.SlackBuild
+++ b/libraries/process-cpp/process-cpp.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220424 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - move HTML docs to proper Slackware doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=process-cpp
VERSION=${VERSION:-3.0.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +75,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
truncate -s 0 tests/CMakeLists.txt
@@ -89,13 +89,13 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+[ -e $PKG/usr/share/doc/$PRGNAM/html ] && \
+ mv $PKG/usr/share/doc/$PRGNAM/html $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share # 20220424 bkw: nothing here but doc/
cp -a COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild