summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2011-12-11 23:17:11 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:07:46 -0200
commit20d5a40ea0e29b7ca515bc24ad6d422213189250 (patch)
tree704f7ed660263bd9e1d3c70487dbe3c48e55ed98 /libraries
parent8eaeb0b42bf4090523feda8f2ffe37567ffeebcc (diff)
downloadslackbuilds-20d5a40ea0e29b7ca515bc24ad6d422213189250.tar.gz
slackbuilds-20d5a40ea0e29b7ca515bc24ad6d422213189250.tar.xz
libraries/libbluray: Added (Blu-Ray Disc playback library)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libbluray/README7
-rw-r--r--libraries/libbluray/libbluray.SlackBuild86
-rw-r--r--libraries/libbluray/libbluray.info10
-rw-r--r--libraries/libbluray/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/libraries/libbluray/README b/libraries/libbluray/README
new file mode 100644
index 0000000000..c6034fd5de
--- /dev/null
+++ b/libraries/libbluray/README
@@ -0,0 +1,7 @@
+libbluray is an open-source library designed for Blu-Ray Discs playback for
+media players, like VLC or MPlayer. libbluray integrates navigation, playlist
+parsing, menus and BD-J. libbluray is DRM-circumvention free, and thus, safe to
+integrate in your software.
+
+Most commercial Blu-Ray are protected by AACS or BD+ technologies and this
+library is not enough to playback those discs.
diff --git a/libraries/libbluray/libbluray.SlackBuild b/libraries/libbluray/libbluray.SlackBuild
new file mode 100644
index 0000000000..64d94a2520
--- /dev/null
+++ b/libraries/libbluray/libbluray.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for libbluray
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=libbluray
+VERSION=${VERSION:-0.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Hack for compiling xine plugin bindings for libbluray.
+sed -i -e '/pkg-config libbluray/d' -e 's|0644|0755|' player_wrappers/xine/Makefile
+
+# --enable-bdjava is turned off because specific files that are on vlc's
+# libbluray github site are not packaged in the source tarball.
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --enable-debug=no \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+CFLAGS="$SLKCFLAGS" make
+make install DESTDIR=$PKG
+CFLAGS="$SLKCFLAGS -I$PKG/usr/include" \
+LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX -lbluray" \
+make -C player_wrappers/xine DESTDIR=$PKG install
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING README.txt player_wrappers/xine/HOWTO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libbluray/libbluray.info b/libraries/libbluray/libbluray.info
new file mode 100644
index 0000000000..b0e816aa21
--- /dev/null
+++ b/libraries/libbluray/libbluray.info
@@ -0,0 +1,10 @@
+PRGNAM="libbluray"
+VERSION="0.2.1"
+HOMEPAGE="http://www.videolan.org/developers/libbluray.html"
+DOWNLOAD="ftp://ftp.videolan.org/pub/videolan/libbluray/0.2.1/libbluray-0.2.1.tar.bz2"
+MD5SUM="d4cfcf3f110e9d2afe01d29feb8c842b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"
diff --git a/libraries/libbluray/slack-desc b/libraries/libbluray/slack-desc
new file mode 100644
index 0000000000..a084f96cb0
--- /dev/null
+++ b/libraries/libbluray/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libbluray: libbluray (Blu-Ray Disc playback library)
+libbluray:
+libbluray: libbluray is an open-source library designed for Blu-Ray Discs
+libbluray: playback for media players, like VLC or MPlayer.
+libbluray:
+libbluray: Homepage: http://www.videolan.org/developers/libbluray.html
+libbluray:
+libbluray:
+libbluray:
+libbluray:
+libbluray: