summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-05-30 09:10:56 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-01 07:04:25 +0700
commitc98bf4ae30797e29b89219da23316c327e392882 (patch)
treee7769f0861d0a7a113701d57e637c718e223dbcd /libraries
parent6e7d4bea02d6073c6ffcfe8b549d485b8534f2ed (diff)
downloadslackbuilds-c98bf4ae30797e29b89219da23316c327e392882.tar.gz
slackbuilds-c98bf4ae30797e29b89219da23316c327e392882.tar.xz
libraries/python3-Jinja2: Removed (merged with libraries/Jinja2).
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python3-Jinja2/README8
-rw-r--r--libraries/python3-Jinja2/python3-Jinja2.SlackBuild87
-rw-r--r--libraries/python3-Jinja2/python3-Jinja2.info10
-rw-r--r--libraries/python3-Jinja2/slack-desc19
4 files changed, 0 insertions, 124 deletions
diff --git a/libraries/python3-Jinja2/README b/libraries/python3-Jinja2/README
deleted file mode 100644
index c3379952f5..0000000000
--- a/libraries/python3-Jinja2/README
+++ /dev/null
@@ -1,8 +0,0 @@
-python3-Jinja2 (python3 template engine)
-
-A small but fast and easy to use stand-alone template engine written
-in pure python.
-
-Jinja2 is a template engine written in pure Python. It provides a
-Django inspired non-XML syntax but supports inline expressions and an
-optional sandboxed environment.
diff --git a/libraries/python3-Jinja2/python3-Jinja2.SlackBuild b/libraries/python3-Jinja2/python3-Jinja2.SlackBuild
deleted file mode 100644
index b3cca2e178..0000000000
--- a/libraries/python3-Jinja2/python3-Jinja2.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-Jinja2
-# Copyright 2017 David Woodfall <dave@dawoodfall.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-Jinja2
-SRCNAM=Jinja2
-VERSION=${VERSION:-2.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS CHANGES.rst LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python3-Jinja2/python3-Jinja2.info b/libraries/python3-Jinja2/python3-Jinja2.info
deleted file mode 100644
index 9ced18e0a5..0000000000
--- a/libraries/python3-Jinja2/python3-Jinja2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-Jinja2"
-VERSION="2.10"
-HOMEPAGE="https://pypi.python.org/pypi/Jinja2"
-DOWNLOAD="https://pypi.org/packages/source/J/Jinja2/Jinja2-2.10.tar.gz"
-MD5SUM="61ef1117f945486472850819b8d1eb3d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-MarkupSafe"
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
diff --git a/libraries/python3-Jinja2/slack-desc b/libraries/python3-Jinja2/slack-desc
deleted file mode 100644
index e9723d850a..0000000000
--- a/libraries/python3-Jinja2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python3-Jinja2: python3-Jinja2 (python3 template engine)
-python3-Jinja2:
-python3-Jinja2: A small but fast and easy to use stand-alone template engine written
-python3-Jinja2: in pure python.
-python3-Jinja2:
-python3-Jinja2: Jinja2 is a template engine written in pure Python. It provides a
-python3-Jinja2: Django inspired non-XML syntax but supports inline expressions and an
-python3-Jinja2: optional sandboxed environment.
-python3-Jinja2:
-python3-Jinja2:
-python3-Jinja2: https://pypi.python.org/pypi/Jinja2