summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-12 17:42:06 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 17:42:06 +0200
commitd9056de419721cbaa0bf043639bcd312aabaaa25 (patch)
treec779a2950c026df4f150ffc6fe5211da78077189 /libraries
parent98ccecc2335d2c4ee7bd2375e106ac8801681aa8 (diff)
downloadslackbuilds-d9056de419721cbaa0bf043639bcd312aabaaa25.tar.gz
slackbuilds-d9056de419721cbaa0bf043639bcd312aabaaa25.tar.xz
libraries/pygame: Updated for version 1.7.1
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pygame/pygame.SlackBuild31
-rw-r--r--libraries/pygame/slack-desc2
2 files changed, 12 insertions, 21 deletions
diff --git a/libraries/pygame/pygame.SlackBuild b/libraries/pygame/pygame.SlackBuild
index 82c1a6a1a2..b50d9b3885 100644
--- a/libraries/pygame/pygame.SlackBuild
+++ b/libraries/pygame/pygame.SlackBuild
@@ -6,7 +6,7 @@
NAME=pygame
VERSION=1.7.1
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -16,28 +16,25 @@ OUTPUT=${OUTPUT:-/tmp}
SRCVERSION=${VERSION}release
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
rm -rf $NAME-$SRCVERSION
-tar -xzvf $CWD/$NAME-$SRCVERSION.tar.gz || exit 1
+tar xvf $CWD/$NAME-$SRCVERSION.tar.?z* || exit 1
cd $NAME-$SRCVERSION || exit 1
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python config.py || exit 1
+# Python programs use the CFLAGS specified used by python itself
+python -u config.py || exit 1
+python setup.py install --root=$PKG
-# Let's build the installable tarball, but we'll wait just a bit
-# to extract it into $PKG
-python setup.py bdist || exit 1
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
mkdir -p $PKG/usr/doc/$NAME-$VERSION
cp -a PKG-INFO WHATSNEW install.html readme.txt docs/* examples \
@@ -47,11 +44,5 @@ cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-# Let's extract the installable tarball now into $PKG
-# Since we're in the right place, strip everything and build the package
cd $PKG
-tar xzf $TMP/$NAME-$SRCVERSION/dist/$NAME-$SRCVERSION.linux-i686.tar.gz || exit 1
-find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pygame/slack-desc b/libraries/pygame/slack-desc
index 37fc40831f..17d175b84a 100644
--- a/libraries/pygame/slack-desc
+++ b/libraries/pygame/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler-------------------------------------------------------|
pygame: pygame (a set of Python modules designed for writing games)
pygame:
pygame: pygame is written on top of the excellent SDL library. This allows you