summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2017-12-20 22:43:17 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-12-21 08:19:31 +0700
commitff24b0ba7a7ab750ac096c0b29ff775e661787fa (patch)
tree12abec0a0ebdec4401dc825ffdb620b9421e6a43 /libraries
parentb5cde734ad415c3b5b126b0c11e4f0fc13496c2c (diff)
downloadslackbuilds-ff24b0ba7a7ab750ac096c0b29ff775e661787fa.tar.gz
slackbuilds-ff24b0ba7a7ab750ac096c0b29ff775e661787fa.tar.xz
libraries/pyPEG2: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pyPEG2/README13
-rw-r--r--libraries/pyPEG2/pyPEG2.SlackBuild9
-rw-r--r--libraries/pyPEG2/slack-desc2
3 files changed, 18 insertions, 6 deletions
diff --git a/libraries/pyPEG2/README b/libraries/pyPEG2/README
index 47811fd207..baf2045383 100644
--- a/libraries/pyPEG2/README
+++ b/libraries/pyPEG2/README
@@ -1,6 +1,11 @@
pyPEG2 (plain and simple intrinsic parser interpreter for Python)
-pyPEG2 is a plain and simple intrinsic parser interpreter framework
-for Python version 2.7 and 3.x. It is based on Parsing Expression
-Grammar (PEG). With pyPEG you can parse many formal languages
-in a very easy way.
+pyPEG2 is a plain and simple intrinsic parser interpreter framework
+for Python version 2.7 and 3.x. It is based on Parsing Expression
+Grammar (PEG). With pyPEG you can parse many formal languages in a
+very easy way.
+
+NOTE: to build mutagen with python3 run the slackbuild with option
+PYTHON3=yes.
+
+ # PYTHON3=yes ./pyPEG2.SlackBuild
diff --git a/libraries/pyPEG2/pyPEG2.SlackBuild b/libraries/pyPEG2/pyPEG2.SlackBuild
index 1b9ed36ae6..669bcfbf82 100644
--- a/libraries/pyPEG2/pyPEG2.SlackBuild
+++ b/libraries/pyPEG2/pyPEG2.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pyPEG2
VERSION=${VERSION:-2.15.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,8 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+python setup.py build
python setup.py install --root=$PKG
+# Build mutagen with python3. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/pyPEG2/slack-desc b/libraries/pyPEG2/slack-desc
index 3215957b83..654be9ac72 100644
--- a/libraries/pyPEG2/slack-desc
+++ b/libraries/pyPEG2/slack-desc
@@ -8,7 +8,7 @@
|-----handy-ruler------------------------------------------------------|
pyPEG2: pyPEG2 (plain and simple intrinsic parser interpreter for Python)
pyPEG2:
-pyPEG2: pyPEG2 is a plain and simple intrinsic parser interpreter framework
+pyPEG2: pyPEG2 is a plain and simple intrinsic parser interpreter framework
pyPEG2: for Python version 2.7 and 3.x.
pyPEG2:
pyPEG2: Home page: https://fdik.org/pyPEG/