summaryrefslogtreecommitdiffstats
path: root/misc/txt2tags/txt2tags.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2013-11-05 11:57:24 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-06 00:55:48 -0600
commitf634723bec5c951264fa2483e5d2c725a3d8bea4 (patch)
tree948e10305dbb4711f4bc5aa7de37005d42a652ba /misc/txt2tags/txt2tags.SlackBuild
parentc69e829c492ccea50058725fd1a971753a527115 (diff)
downloadslackbuilds-f634723bec5c951264fa2483e5d2c725a3d8bea4.tar.gz
slackbuilds-f634723bec5c951264fa2483e5d2c725a3d8bea4.tar.xz
misc/txt2tags: Updated for subversion revision r1172.
cleanups and refactoring Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'misc/txt2tags/txt2tags.SlackBuild')
-rw-r--r--misc/txt2tags/txt2tags.SlackBuild79
1 files changed, 50 insertions, 29 deletions
diff --git a/misc/txt2tags/txt2tags.SlackBuild b/misc/txt2tags/txt2tags.SlackBuild
index 159c0021c5..71b9457822 100644
--- a/misc/txt2tags/txt2tags.SlackBuild
+++ b/misc/txt2tags/txt2tags.SlackBuild
@@ -15,27 +15,41 @@
# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+# Modified by the SlackBuilds.org project
PRGNAM=txt2tags
-VERSION=2.5
-ARCH=noarch
+VERSION=${VERSION:-r1172}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ] ; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ] ; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ] ; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -44,38 +58,45 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
-
chown -R root:root .
find . \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 400 -o \
- -perm 440 \) -exec chmod 644 {} \; -o \
- \( -perm 777 -o -perm 775 -o -perm 511 -o -perm 711 -o -perm 555 \) \
- -exec chmod 755 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-# As txt2tags is a python program, all we have to do is copy it to /usr/bin
-mkdir -p $PKG/usr/bin
-cp -a txt2tags $PKG/usr/bin
+python setup.py install --root=$PKG
-# Give the man pages a nice home and then gzip them
mkdir -p $PKG/usr/man/man1
-cp doc/manpage.man $PKG/usr/man/man1/txt2tags.1
-# And the ones for other locales
-for locale in ca es fr it pt zh ; do
- mkdir -p $PKG/usr/man/$locale/man1
- cp doc/manpage-$locale.man $PKG/usr/man/$locale/man1/txt2tags.1
-done
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+gzip -9 -c doc/English/manpage.man > $PKG/usr/man/man1/$PRGNAM.1.gz
+# Install the available translations
+for i in pt de fr es zh eu ca it; do mkdir -p $PKG/usr/man/$i/man1; done
+gzip -9 -c doc/Portuguese/manpage-pt.man > $PKG/usr/man/pt/man1/$PRGNAM.1.gz
+gzip -9 -c doc/German/manpage-de.man > $PKG/usr/man/de/man1/$PRGNAM.1.gz
+gzip -9 -c doc/French/manpage-fr.man > $PKG/usr/man/fr/man1/$PRGNAM.1.gz
+gzip -9 -c doc/Spanish/manpage-es.man > $PKG/usr/man/es/man1/$PRGNAM.1.gz
+gzip -9 -c doc/Chinese/manpage-zh.man > $PKG/usr/man/zh/man1/$PRGNAM.1.gz
+gzip -9 -c doc/Basque/manpage-eu.man > $PKG/usr/man/eu/man1/$PRGNAM.1.gz
+gzip -9 -c doc/Catalan/manpage-ca.man > $PKG/usr/man/ca/man1/$PRGNAM.1.gz
+gzip -9 -c doc/Italian/manpage-it.man > $PKG/usr/man/it/man1/$PRGNAM.1.gz
+
+mkdir -p $PKG/usr/share/applications
+install -m 0644 dist/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+mkdir -p $PKG/usr/share/pixmaps
+install -m 0644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- COPYING ChangeLog README TODO extras samples test \
+ AUTHORS COPYING ChangeLog README extras samples test \
+ doc/English/txt2tags-quickref.pdf doc/English/userguide.pdf \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}