summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Oleg O. Chukaev <oleg.chukaev@mail.ru>2010-05-13 00:59:22 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:22 +0200
commit24476c05d65547bbb8352195d0be4cce8fc43b07 (patch)
tree46f448b45673bac238b85ca225586e7d8a581c31 /misc
parent2b1cd5198588ef220023b47e4e8fe121401cc4c7 (diff)
downloadslackbuilds-24476c05d65547bbb8352195d0be4cce8fc43b07.tar.gz
slackbuilds-24476c05d65547bbb8352195d0be4cce8fc43b07.tar.xz
misc/dbview: Added to 13.0 repository
Diffstat (limited to 'misc')
-rw-r--r--misc/dbview/Makefile.diff25
-rw-r--r--misc/dbview/README3
-rw-r--r--misc/dbview/dbview.SlackBuild71
-rw-r--r--misc/dbview/dbview.info10
-rw-r--r--misc/dbview/slack-desc19
5 files changed, 128 insertions, 0 deletions
diff --git a/misc/dbview/Makefile.diff b/misc/dbview/Makefile.diff
new file mode 100644
index 0000000000..a3102fe8b1
--- /dev/null
+++ b/misc/dbview/Makefile.diff
@@ -0,0 +1,25 @@
+--- Makefile.orig 2009-10-31 19:59:54.000000000 +0300
++++ Makefile 2009-10-31 20:09:49.000000000 +0300
+@@ -26,9 +26,9 @@
+ # Look where your install program is
+ #
+ INSTALL = /usr/bin/install
+-prefix = /usr
++prefix = ${DESTDIR}/usr
+ bindir = $(prefix)/bin
+-mandir = $(prefix)/share/$(MAN)
++mandir = $(prefix)/$(MAN)
+
+ obj = db_dump.o dbview.o version.o
+
+@@ -46,8 +46,8 @@
+ install: all
+ $(INSTALL) -d -o root -g root -m 755 $(bindir)
+ $(INSTALL) -s -o root -g root -m 755 dbview $(bindir)
+- $(INSTALL) -d -o $(MAN) -g $(MAN) -m 755 $(mandir)/man1
+- $(INSTALL) -o $(MAN) -g $(MAN) -m 644 dbview.1 $(mandir)/man1
++ $(INSTALL) -d -o root -g root -m 755 $(mandir)/man1
++ $(INSTALL) -o root -g root -m 644 dbview.1 $(mandir)/man1
+
+ clean:
+ rm -f dbview *.o *.log *~ *.orig Makefile.bak;
diff --git a/misc/dbview/README b/misc/dbview/README
new file mode 100644
index 0000000000..be91e63875
--- /dev/null
+++ b/misc/dbview/README
@@ -0,0 +1,3 @@
+dbview is a little tool that will display dBase III files. You can
+also use it to convert your old .dbf files for further use with Unix.
+It should also work with dBase IV files, but this is mostly untested.
diff --git a/misc/dbview/dbview.SlackBuild b/misc/dbview/dbview.SlackBuild
new file mode 100644
index 0000000000..3217ea4a92
--- /dev/null
+++ b/misc/dbview/dbview.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for dbview
+# Written by Oleg O. Chukaev <oleg.chukaev@mail.ru>
+
+PRGNAM=dbview
+VERSION=1.0.4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix paths and owners/groups
+patch -i $CWD/Makefile.diff
+
+make CFLAGS="$SLKCFLAGS -fomit-frame-pointer -Wall -pipe"
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES README dBASE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/dbview/dbview.info b/misc/dbview/dbview.info
new file mode 100644
index 0000000000..5fe3e99c5b
--- /dev/null
+++ b/misc/dbview/dbview.info
@@ -0,0 +1,10 @@
+PRGNAM="dbview"
+VERSION="1.0.4"
+HOMEPAGE="http://www.infodrom.org/projects/dbview/"
+DOWNLOAD="http://www.infodrom.org/projects/dbview/download/dbview-1.0.4.tar.gz"
+DOWNLOAD_x86_64=""
+MD5SUM="f77c9a85ca18dd1c80f72fcbc17c78ea"
+MD5SUM_x86_64=""
+MAINTAINER="Oleg O. Chukaev"
+EMAIL="oleg.chukaev@mail.ru"
+APPROVED="dsomero"
diff --git a/misc/dbview/slack-desc b/misc/dbview/slack-desc
new file mode 100644
index 0000000000..afb2859b4b
--- /dev/null
+++ b/misc/dbview/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+dbview: dbview (dBase files viewer)
+dbview:
+dbview: dbview is a little tool that will display dBase III files. You can
+dbview: also use it to convert your old .dbf files for further use with Unix.
+dbview: It should also work with dBase IV files, but this is mostly untested.
+dbview:
+dbview: Homepage: http://www.infodrom.org/projects/dbview/
+dbview:
+dbview:
+dbview:
+dbview: