summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2013-11-25 12:23:31 +0100
committer Heinz Wiesinger <pprkut@slackbuilds.org>2013-11-25 13:11:59 +0100
commit926b93d445e92be03e62efcd742b2ac88f0d96ed (patch)
treea9e1e616e37f2f7187d0b0ab2d8e83b3ad8eed63 /misc
parent7bc7feac90a3966ebaea1b1ad87431764a560344 (diff)
downloadslackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.gz
slackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.xz
various: Replace chmod command with find command from template.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/biosdisk/biosdisk.SlackBuild6
-rw-r--r--misc/bsdsfv/bsdsfv.SlackBuild6
-rw-r--r--misc/cksfv/cksfv.SlackBuild6
-rw-r--r--misc/iscan-firmware/iscan-firmware.SlackBuild6
-rw-r--r--misc/iscan-proprietary-drivers/iscan-proprietary-drivers.SlackBuild6
-rw-r--r--misc/kasumi/kasumi.SlackBuild6
-rw-r--r--misc/krename/krename.SlackBuild6
-rw-r--r--misc/lbdb/lbdb.SlackBuild6
-rw-r--r--misc/ltunify/ltunify.SlackBuild6
-rw-r--r--misc/megatunix/megatunix.SlackBuild6
-rw-r--r--misc/nfoview/nfoview.SlackBuild6
-rw-r--r--misc/recode/recode.SlackBuild6
-rw-r--r--misc/rsnapshot/rsnapshot.SlackBuild6
-rw-r--r--misc/tangogps/tangogps.SlackBuild6
-rw-r--r--misc/torrentinfo/torrentinfo.SlackBuild6
-rw-r--r--misc/vdpauinfo/vdpauinfo.SlackBuild6
-rw-r--r--misc/viking/viking.SlackBuild6
-rw-r--r--misc/xwinwrap/xwinwrap.SlackBuild6
18 files changed, 90 insertions, 18 deletions
diff --git a/misc/biosdisk/biosdisk.SlackBuild b/misc/biosdisk/biosdisk.SlackBuild
index b98f98fcc6..5dba20d494 100644
--- a/misc/biosdisk/biosdisk.SlackBuild
+++ b/misc/biosdisk/biosdisk.SlackBuild
@@ -25,7 +25,11 @@ rm -rf $PRGNAM-$VERSDIR
tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
cd $PRGNAM-$VERSDIR
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Procedure taken from the original install.sh by Dell.
# Added $PKG variable for package creation.
diff --git a/misc/bsdsfv/bsdsfv.SlackBuild b/misc/bsdsfv/bsdsfv.SlackBuild
index 2330f01f7d..ab5b7d2069 100644
--- a/misc/bsdsfv/bsdsfv.SlackBuild
+++ b/misc/bsdsfv/bsdsfv.SlackBuild
@@ -57,7 +57,11 @@ tar -xvzf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
mv $PRGNAM $PRGNAM-$VERSION
cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
-chmod -R a-s,u+rw,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
#64bit patch borrowed from gentoo
patch -p1 < $CWD/bsdsfv-1.18-64bit.patch
diff --git a/misc/cksfv/cksfv.SlackBuild b/misc/cksfv/cksfv.SlackBuild
index 3df7e1a972..086aec4f0c 100644
--- a/misc/cksfv/cksfv.SlackBuild
+++ b/misc/cksfv/cksfv.SlackBuild
@@ -66,7 +66,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+rw,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/misc/iscan-firmware/iscan-firmware.SlackBuild b/misc/iscan-firmware/iscan-firmware.SlackBuild
index d73ca814e8..e3fea493b2 100644
--- a/misc/iscan-firmware/iscan-firmware.SlackBuild
+++ b/misc/iscan-firmware/iscan-firmware.SlackBuild
@@ -44,7 +44,11 @@ mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
rpm2cpio $CWD/$PRGNAM-$VERSION-$RPMBUILD.noarch.rpm | cpio -imdv
#chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cd usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/misc/iscan-proprietary-drivers/iscan-proprietary-drivers.SlackBuild b/misc/iscan-proprietary-drivers/iscan-proprietary-drivers.SlackBuild
index 1adea3c564..49452bb354 100644
--- a/misc/iscan-proprietary-drivers/iscan-proprietary-drivers.SlackBuild
+++ b/misc/iscan-proprietary-drivers/iscan-proprietary-drivers.SlackBuild
@@ -59,7 +59,11 @@ mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
rpm2cpio $CWD/$PRGNAM-$VERSION-$RPMBUILD.$ARCH.rpm | cpio -imdv
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cd usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/misc/kasumi/kasumi.SlackBuild b/misc/kasumi/kasumi.SlackBuild
index 39cdf87b6c..ac52925621 100644
--- a/misc/kasumi/kasumi.SlackBuild
+++ b/misc/kasumi/kasumi.SlackBuild
@@ -44,7 +44,11 @@ cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/misc/krename/krename.SlackBuild b/misc/krename/krename.SlackBuild
index 0fd20b48ab..bc7950048d 100644
--- a/misc/krename/krename.SlackBuild
+++ b/misc/krename/krename.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
KDEPREF=$(kde4-config --prefix)
diff --git a/misc/lbdb/lbdb.SlackBuild b/misc/lbdb/lbdb.SlackBuild
index d5b70e37e1..63da52bfc6 100644
--- a/misc/lbdb/lbdb.SlackBuild
+++ b/misc/lbdb/lbdb.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM\_$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/misc/ltunify/ltunify.SlackBuild b/misc/ltunify/ltunify.SlackBuild
index 8db09512ab..4893f4886c 100644
--- a/misc/ltunify/ltunify.SlackBuild
+++ b/misc/ltunify/ltunify.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+rw,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make
make install DESTDIR=$PKG bindir=/usr/bin
diff --git a/misc/megatunix/megatunix.SlackBuild b/misc/megatunix/megatunix.SlackBuild
index 1f53ae3faf..333496e18e 100644
--- a/misc/megatunix/megatunix.SlackBuild
+++ b/misc/megatunix/megatunix.SlackBuild
@@ -57,7 +57,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Starting with glib 2.32 it is now mandatory to
# include glib.h instead of individual headers.
diff --git a/misc/nfoview/nfoview.SlackBuild b/misc/nfoview/nfoview.SlackBuild
index d4240f26b3..0d9bb1b878 100644
--- a/misc/nfoview/nfoview.SlackBuild
+++ b/misc/nfoview/nfoview.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root $PKG
diff --git a/misc/recode/recode.SlackBuild b/misc/recode/recode.SlackBuild
index a8b0465b94..d9b79a31f2 100644
--- a/misc/recode/recode.SlackBuild
+++ b/misc/recode/recode.SlackBuild
@@ -52,7 +52,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Some important fixes from debian and ubuntu.
# We normally don't like this idea, as it puts us maintaining the upstream
diff --git a/misc/rsnapshot/rsnapshot.SlackBuild b/misc/rsnapshot/rsnapshot.SlackBuild
index bc40c86e5b..c20bde65eb 100644
--- a/misc/rsnapshot/rsnapshot.SlackBuild
+++ b/misc/rsnapshot/rsnapshot.SlackBuild
@@ -61,7 +61,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix for the newer pod2man
patch -p1 < $CWD/patch_pod2man.diff
diff --git a/misc/tangogps/tangogps.SlackBuild b/misc/tangogps/tangogps.SlackBuild
index 224aeed867..0ca2460b6d 100644
--- a/misc/tangogps/tangogps.SlackBuild
+++ b/misc/tangogps/tangogps.SlackBuild
@@ -44,7 +44,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix for glib>=2.31
sed -i "s|^#include\ <glib/.*||" src/map_management.c
diff --git a/misc/torrentinfo/torrentinfo.SlackBuild b/misc/torrentinfo/torrentinfo.SlackBuild
index 5db9d97a1d..06d506e443 100644
--- a/misc/torrentinfo/torrentinfo.SlackBuild
+++ b/misc/torrentinfo/torrentinfo.SlackBuild
@@ -42,7 +42,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/misc/vdpauinfo/vdpauinfo.SlackBuild b/misc/vdpauinfo/vdpauinfo.SlackBuild
index 04f7f3c193..9c253c1d9d 100644
--- a/misc/vdpauinfo/vdpauinfo.SlackBuild
+++ b/misc/vdpauinfo/vdpauinfo.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/misc/viking/viking.SlackBuild b/misc/viking/viking.SlackBuild
index 46b6f3b90e..e36dc2a473 100644
--- a/misc/viking/viking.SlackBuild
+++ b/misc/viking/viking.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/misc/xwinwrap/xwinwrap.SlackBuild b/misc/xwinwrap/xwinwrap.SlackBuild
index 2d730c47ef..acefafa345 100644
--- a/misc/xwinwrap/xwinwrap.SlackBuild
+++ b/misc/xwinwrap/xwinwrap.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# He is the MELBA-BEING ... the ANGEL CAKE ... XEROX him ... XEROX him --
gcc $SLKCFLAGS -Wall -lX11 -lXext -lXrender xwinwrap.c -o xwinwrap