summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2010-04-19 18:52:07 -0400
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-15 10:38:30 +0200
commitd99d6aba3e181f287210b69c33cd96fa4507c6b0 (patch)
tree0a906ff581024edccb70c1bcd1575959c3ec10bf /misc
parent50cf5d8ac663367bb8297bd5cc73c5d0da40efb8 (diff)
downloadslackbuilds-d99d6aba3e181f287210b69c33cd96fa4507c6b0.tar.gz
slackbuilds-d99d6aba3e181f287210b69c33cd96fa4507c6b0.tar.xz
misc/conkyforecast Added (weather plugin for conky)
Diffstat (limited to 'misc')
-rw-r--r--misc/conkyforecast/README8
-rw-r--r--misc/conkyforecast/conkyforecast.SlackBuild55
-rw-r--r--misc/conkyforecast/conkyforecast.info11
-rw-r--r--misc/conkyforecast/doinst.sh11
-rw-r--r--misc/conkyforecast/slack-desc19
5 files changed, 104 insertions, 0 deletions
diff --git a/misc/conkyforecast/README b/misc/conkyforecast/README
new file mode 100644
index 0000000000..8aa7b8599c
--- /dev/null
+++ b/misc/conkyforecast/README
@@ -0,0 +1,8 @@
+conkyforecast (Provides weather information to be displayed in conky)
+
+conkyForecast is a python script created to provide weather forecast
+information to be displayed in Conky. It uses the Weather.com XOAP
+service to retrieve data for all over the world.
+
+Requires: cronky available at SlackBuilds.org.
+
diff --git a/misc/conkyforecast/conkyforecast.SlackBuild b/misc/conkyforecast/conkyforecast.SlackBuild
new file mode 100644
index 0000000000..ea19a83dde
--- /dev/null
+++ b/misc/conkyforecast/conkyforecast.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for conkyforecast
+
+# Written by M.Dinslage (daedra1980@gmail.com)
+
+PRGNAM=conkyforecast
+VERSION=${VERSION:-2.09}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf src
+tar xvf $CWD/conkyforecast_2.09.tar.gz
+cd src
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix font path for slackware
+sed -i 's,/usr/share/fonts/truetype/conkyforecast,/usr/share/fonts/TTF,g' setup.py
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# remove font .sfd files, they shouldn't be needed
+rm -r $PKG/usr/share/fonts/TTF/*.tar.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGELOG COPYING README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/conkyforecast/conkyforecast.info b/misc/conkyforecast/conkyforecast.info
new file mode 100644
index 0000000000..a1c55f34e0
--- /dev/null
+++ b/misc/conkyforecast/conkyforecast.info
@@ -0,0 +1,11 @@
+PRGNAM="conkyforecast"
+VERSION="2.09"
+HOMEPAGE="https://code.launchpad.net/~m-buck/+junk/conkyforecast"
+DOWNLOAD="https://launchpad.net/%7Em-buck/+archive/conky/+files/conkyforecast_2.09.tar.gz"
+MD5SUM="59df6be9114bb377526b2511daca355a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="M.Dinslage"
+EMAIL="daedra1980@gmail.com"
+APPROVED="dsomero"
+
diff --git a/misc/conkyforecast/doinst.sh b/misc/conkyforecast/doinst.sh
new file mode 100644
index 0000000000..3884b2a547
--- /dev/null
+++ b/misc/conkyforecast/doinst.sh
@@ -0,0 +1,11 @@
+# Update the X font indexes:
+if [ -x /usr/bin/mkfontdir ]; then
+ ( cd /usr/share/fonts/TTF
+ mkfontscale .
+ mkfontdir .
+ )
+fi
+if [ -x /usr/bin/fc-cache ]; then
+ /usr/bin/fc-cache -f
+fi
+
diff --git a/misc/conkyforecast/slack-desc b/misc/conkyforecast/slack-desc
new file mode 100644
index 0000000000..b37a020d2b
--- /dev/null
+++ b/misc/conkyforecast/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+conkyforecast: conkyforecast (Provides weather information to be displayed in conky)
+conkyforecast:
+conkyforecast: conkyForecast is a python script created to provide weather forecast
+conkyforecast: information to be displayed in Conky. It uses the Weather.com XOAP
+conkyforecast: service to retrieve data for all over the world.
+conkyforecast:
+conkyforecast:
+conkyforecast:
+conkyforecast:
+conkyforecast:
+conkyforecast: