summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-17 02:27:08 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-19 12:09:24 +0700
commit4de44686ed59f59f81bcd3fc939416b2135e4b1e (patch)
treeba525fd1cdc6bf52641ff520ce31b558918d24da /misc
parent555c48c6312ccd2ad4720e5019b02f5068d06b66 (diff)
downloadslackbuilds-4de44686ed59f59f81bcd3fc939416b2135e4b1e.tar.gz
slackbuilds-4de44686ed59f59f81bcd3fc939416b2135e4b1e.tar.xz
misc/protobuf: Removed (use protobuf3 instead).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/protobuf/README14
-rw-r--r--misc/protobuf/protobuf.SlackBuild100
-rw-r--r--misc/protobuf/protobuf.info10
-rw-r--r--misc/protobuf/slack-desc19
4 files changed, 0 insertions, 143 deletions
diff --git a/misc/protobuf/README b/misc/protobuf/README
deleted file mode 100644
index 7197f97d5b..0000000000
--- a/misc/protobuf/README
+++ /dev/null
@@ -1,14 +0,0 @@
-protobuf (Google's data interchange format)
-
-Protocol buffers are a flexible, efficient, automated mechanism for
-serializing structured data, think XML, but smaller, faster, and
-simpler. You define how you want your data to be structured once,
-then you can use special generated source code to easily write and
-read your structured data to and from a variety of data streams
-and using a variety of languages. You can even update your data
-structure without breaking deployed programs that are compiled
-against the "old" format.
-
-If you've already installed the compiz packages you will need
-to rebuild the libcompizconfig and compizconfig-python against
-the new version of protobuf.
diff --git a/misc/protobuf/protobuf.SlackBuild b/misc/protobuf/protobuf.SlackBuild
deleted file mode 100644
index a0697bcdf8..0000000000
--- a/misc/protobuf/protobuf.SlackBuild
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for protobuf
-
-# Written by M.Dinslage (daedra1980@gmail.com)
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=protobuf
-VERSION=${VERSION:-2.6.1}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-PYTHON=${PYTHON:-yes}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --disable-static \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-# Install the python bindings
-if [ "${PYTHON:-yes}" = "yes" ]; then
- cd python ; python setup.py install --root=$PKG ; cd ..
-fi
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES.txt CONTRIBUTORS.txt INSTALL.txt README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-rm -f $PKG/usr/lib*/*.la
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/misc/protobuf/protobuf.info b/misc/protobuf/protobuf.info
deleted file mode 100644
index 5a679edc2d..0000000000
--- a/misc/protobuf/protobuf.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="protobuf"
-VERSION="2.6.1"
-HOMEPAGE="https://github.com/google/protobuf/"
-DOWNLOAD="https://github.com/google/protobuf/releases/download/v2.6.1/protobuf-2.6.1.tar.bz2"
-MD5SUM="11aaac2d704eef8efd1867a807865d85"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pytz python2-dateutil python-gflags google-apputils"
-MAINTAINER="M.Dinslage"
-EMAIL="daedra1980{at}gmail{dot}com"
diff --git a/misc/protobuf/slack-desc b/misc/protobuf/slack-desc
deleted file mode 100644
index bdfe48de63..0000000000
--- a/misc/protobuf/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-protobuf: protobuf (Google's data interchange format)
-protobuf:
-protobuf: Protocol buffers are a flexible, efficient, automated mechanism for
-protobuf: serializing structured data, think XML, but smaller, faster, and
-protobuf: simpler. You define how you want your data to be structured once,
-protobuf: then you can use special generated source code to easily write and
-protobuf: read your structured data to and from a variety of data streams
-protobuf: and using a variety of languages. You can even update your data
-protobuf: structure without breaking deployed programs that are compiled
-protobuf: against the "old" format.
-protobuf: