summaryrefslogtreecommitdiffstats
path: root/multimedia/subtitleripper
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2010-05-13 00:59:51 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:51 +0200
commitb306bec02de4d00da083fc9132ec6346ac14ccfe (patch)
tree295bf1c24ca86ec46e60a0ddd9644cacaaf94563 /multimedia/subtitleripper
parent6e2bad015e6b6530311bd8d4efb96df79d776332 (diff)
downloadslackbuilds-b306bec02de4d00da083fc9132ec6346ac14ccfe.tar.gz
slackbuilds-b306bec02de4d00da083fc9132ec6346ac14ccfe.tar.xz
multimedia/subtitleripper: Added to 13.0 repository
Diffstat (limited to 'multimedia/subtitleripper')
-rw-r--r--multimedia/subtitleripper/CMakeLists.txt64
-rw-r--r--multimedia/subtitleripper/README13
-rw-r--r--multimedia/subtitleripper/slack-desc19
-rw-r--r--multimedia/subtitleripper/subtitleripper.SlackBuild92
-rw-r--r--multimedia/subtitleripper/subtitleripper.info10
5 files changed, 198 insertions, 0 deletions
diff --git a/multimedia/subtitleripper/CMakeLists.txt b/multimedia/subtitleripper/CMakeLists.txt
new file mode 100644
index 0000000000..4bb3222fcb
--- /dev/null
+++ b/multimedia/subtitleripper/CMakeLists.txt
@@ -0,0 +1,64 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(subtitleripper)
+
+SET(CMAKE_C_FLAGS $ENV{CFLAGS})
+
+SET ( PNG
+ "ON"
+ CACHE BOOL "Enable PNG support")
+SET ( PPM
+ "ON"
+ CACHE BOOL "Enable PPM support")
+SET ( ZLIB
+ "ON"
+ CACHE BOOL "Enable ZLIB support")
+
+SET(BIN_INSTALL_DIR bin)
+SET(DATA_INSTALL_DIR share)
+
+SET(subtitle2pgm_sources subtitle2pgm.c spudec.c)
+SET(subtitle2vobsub_sources subtitle2vobsub.c vobsub.c)
+SET(srttool_sources srttool.c)
+SET(vobsub2pgm_sources vobsub2pgm.c vobsub.c spudec.c)
+
+
+# LIBRARIES (MATH LIBPPM-NETPBM LIBPNG LIBZ)
+LINK_LIBRARIES(m)
+
+IF ( ${PPM} STREQUAL "ON" )
+ ADD_DEFINITIONS( -D_HAVE_LIB_PPM_ )
+ LINK_LIBRARIES(netpbm)
+ENDIF ( ${PPM} STREQUAL "ON" )
+
+IF ( ${PNG} STREQUAL "ON" )
+ ADD_DEFINITIONS( -D_HAVE_PNG_ -DPNG_SKIP_SETJMP_CHECK )
+ LINK_LIBRARIES(png)
+ENDIF ( ${PNG} STREQUAL "ON" )
+
+IF ( ${ZLIB} STREQUAL "ON" )
+ ADD_DEFINITIONS( -D_HAVE_ZLIB_ )
+ LINK_LIBRARIES(z)
+ENDIF ( ${ZLIB} STREQUAL "ON" )
+
+ADD_EXECUTABLE(subtitle2pgm ${subtitle2pgm_sources})
+ADD_EXECUTABLE(subtitle2vobsub ${subtitle2vobsub_sources})
+ADD_EXECUTABLE(srttool ${srttool_sources})
+ADD_EXECUTABLE(vobsub2pgm ${vobsub2pgm_sources})
+
+EXECUTE_PROCESS(
+ INPUT_FILE pgm2txt
+ OUTPUT_FILE pgm2txt.new
+ COMMAND sed s|PATH_TO_LANGUAGE_FILTER.*|PATH_TO_LANGUAGE_FILTER=@CMAKE_INSTALL_PREFIX@/@DATA_INSTALL_DIR@/subtitleripper|
+)
+
+EXECUTE_PROCESS(
+ COMMAND mv pgm2txt.new pgm2txt
+)
+
+INSTALL(FILES "gocrfilter_en.sed" "gocrfilter_fr.sed" "gocrfilter_nl.sed" "gocrfilter_none.sed" DESTINATION ${DATA_INSTALL_DIR}/subtitleripper )
+INSTALL(PROGRAMS "pgm2txt" DESTINATION ${BIN_INSTALL_DIR})
+INSTALL(TARGETS subtitle2pgm DESTINATION ${BIN_INSTALL_DIR})
+INSTALL(TARGETS subtitle2vobsub DESTINATION ${BIN_INSTALL_DIR})
+INSTALL(TARGETS srttool DESTINATION ${BIN_INSTALL_DIR})
+INSTALL(TARGETS vobsub2pgm DESTINATION ${BIN_INSTALL_DIR})
diff --git a/multimedia/subtitleripper/README b/multimedia/subtitleripper/README
new file mode 100644
index 0000000000..786c35ddfa
--- /dev/null
+++ b/multimedia/subtitleripper/README
@@ -0,0 +1,13 @@
+DVD Subtitle Ripper for Linux
+
+If you want to convert DVD subtitles into text format (e.g. subrip format) or
+VobSub format this program could be useful for you. However, it is only one
+tiny tool that you need in the process of producing srt files. This software
+depends heavily on transcode for its input and is therefore part of the
+transcode package (see transcode's contrib directory). So, if you want to
+convert some subtitles, grap a copy of the lates transcode distribution.
+
+For srt file production the output of this program should be processed
+by some OCR software.
+
+For VobSub output no other tools are required.
diff --git a/multimedia/subtitleripper/slack-desc b/multimedia/subtitleripper/slack-desc
new file mode 100644
index 0000000000..1de9501f6e
--- /dev/null
+++ b/multimedia/subtitleripper/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+subtitleripper: subtitleripper (DVD Subtitle Ripper for Linux)
+subtitleripper:
+subtitleripper: If you want to convert DVD subtitles into text format or VobSub
+subtitleripper: format this program could be useful for you. However, it is only one
+subtitleripper: tiny tool that you need in the process of producing srt files. This
+subtitleripper: software depends heavily on transcode for its input and is
+subtitleripper: therefore part of the transcode package
+subtitleripper:
+subtitleripper:
+subtitleripper: Homepage: http://subtitleripper.sourceforge.net/
+subtitleripper:
diff --git a/multimedia/subtitleripper/subtitleripper.SlackBuild b/multimedia/subtitleripper/subtitleripper.SlackBuild
new file mode 100644
index 0000000000..f14c86a223
--- /dev/null
+++ b/multimedia/subtitleripper/subtitleripper.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for subtitleripper
+
+# Written by Andre Barboza <bmg.andre@gmail.com>
+
+# Copyright 2009 Andre Barboza
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=subtitleripper
+SRCVER=${SRCVER:-0.3-4}
+VERSION=`echo $SRCVER|sed 's/-/_/'`
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM-$SRCVER.tgz
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cat $CWD/CMakeLists.txt > CMakeLists.txt
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+# Compile the application and install it into the $PKG directory
+make
+make install DESTDIR=$PKG
+
+# Strip binaries and libraries - this can be done with 'make install-strip'
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+# Copy program documentation into the package
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog README README.gocr README.srttool README.subtitle2pgm README.vobsub \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/subtitleripper/subtitleripper.info b/multimedia/subtitleripper/subtitleripper.info
new file mode 100644
index 0000000000..040823ade0
--- /dev/null
+++ b/multimedia/subtitleripper/subtitleripper.info
@@ -0,0 +1,10 @@
+PRGNAM="subtitleripper"
+VERSION="0.3_4"
+HOMEPAGE="http://subtitleripper.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/subtitleripper/subtitleripper-0.3-4.tgz"
+MD5SUM="c0bd49a88f667c68c4430ad25bbed510"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
+APPROVED="dsomero"