summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Nishant Limbachia <nishant@mnspace.net>2010-04-24 03:57:12 -0500
committer Erik Hanson <erik@slackbuilds.org>2010-05-15 10:50:24 +0200
commit3a51fab3c61bf88ea1100e36c91236df7cf625b7 (patch)
tree30aa7b5a242066e6757a2b29d97df378e7203106 /multimedia
parentae9dc301ed79f03da5064b6a94b7d4e7e37b40ff (diff)
downloadslackbuilds-3a51fab3c61bf88ea1100e36c91236df7cf625b7.tar.gz
slackbuilds-3a51fab3c61bf88ea1100e36c91236df7cf625b7.tar.xz
multimedia/vobcopy: Build bump, script cleanup.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vobcopy/README7
-rw-r--r--multimedia/vobcopy/slack-desc1
-rw-r--r--multimedia/vobcopy/vobcopy.SlackBuild39
-rw-r--r--multimedia/vobcopy/vobcopy.info2
4 files changed, 23 insertions, 26 deletions
diff --git a/multimedia/vobcopy/README b/multimedia/vobcopy/README
index f974d930de..7d4a96b367 100644
--- a/multimedia/vobcopy/README
+++ b/multimedia/vobcopy/README
@@ -1,5 +1,6 @@
-vobcopy copies .vob files from DVD to hard drives. vobcopy also uses
-libdvdcss (if available) for encrypted dvds.
+vobcopy copies .vob files from DVD to hard drives. I primarily needs
+libdvdread but also used libdvdcss (if available) for encrypted dvds.
Please refer README or manpages in the package for usage info.
-Optional dependency: libdvdcss for encrypted dvds available at SBo.
+vobcopy requires libdvdread (available at SBo). Optional dependency is
+libdvdcss for encrypted dvds (also available at SBo).
diff --git a/multimedia/vobcopy/slack-desc b/multimedia/vobcopy/slack-desc
index 8a3dda6bc8..e77666c1b2 100644
--- a/multimedia/vobcopy/slack-desc
+++ b/multimedia/vobcopy/slack-desc
@@ -4,7 +4,6 @@
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
-
|-----handy-ruler---------------------------------------------------|
vobcopy: vobcopy (decrypts and copies the dvd vob files)
vobcopy:
diff --git a/multimedia/vobcopy/vobcopy.SlackBuild b/multimedia/vobcopy/vobcopy.SlackBuild
index 6dbc5f4b68..07c8b7e1c2 100644
--- a/multimedia/vobcopy/vobcopy.SlackBuild
+++ b/multimedia/vobcopy/vobcopy.SlackBuild
@@ -3,13 +3,13 @@
# Slackware Package Build Script for vobcopy
# Home Page http://vobcopy.org/
-# Copyright (c) 2007-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
+# Copyright (c) 2007-2010, Nishant Limbachia, Hoffman Estates, IL, USA (nishant _AT_ mnspace _DOT_ net)
# All rights reserved.
-# Redistribution and use of this script, with or without modification, is
+# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
-# 1. Redistributions of script must retain the above copyright notice,
+# 1. Redistributions of script must retain the above copyright notice,
# this list of conditions and the following disclaimer.
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
@@ -27,7 +27,7 @@
PRGNAM=vobcopy
VERSION=1.2.0
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
TMP=${TMP:-/tmp/SBo}
@@ -53,12 +53,15 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $TMP/$PRGNAM-$VERSION
+
chown -R root.root .
+
find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+\( -perm 664 -o -perm 666 -o -perm 600 -o -perm 440 -o -perm 444 -o -perm 400 \) \
+-exec chmod 644 {} \;
+find . \
+\( -perm 777 -o -perm 755 -o -perm 711 -o -perm 700 -o -perm 555 -o -perm 511 -o -perm 500 \) \
+-exec chmod 755 {} \;
### patch makefile
patch -p0 < $CWD/Makefile.patch
@@ -71,23 +74,17 @@ sed -i "s|@LIBDIRSUFFIX@|$LIBDIRSUFFIX|" Makefile
CFLAGS=${SLKCFLAGS} make
make install DESTDIR=$PKG
-### strip binary
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+### strip binaries
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+### compress man pages
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+### putting slack-desc in place
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+### building package
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/vobcopy/vobcopy.info b/multimedia/vobcopy/vobcopy.info
index 3a94030cb8..ad7c7b51f7 100644
--- a/multimedia/vobcopy/vobcopy.info
+++ b/multimedia/vobcopy/vobcopy.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Nishant Limbachia"
EMAIL="nishant@mnspace.net"
-APPROVED="dsomero"
+APPROVED="Erik Hanson"