summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author dhabyx <slack.dhabyx@gmail.com>2011-05-08 14:15:02 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-05-13 23:25:46 -0500
commite08404ffdc0ae083de64b2ab54b7e47fc955c0f6 (patch)
tree73985ab457642b342416dd9f1f605abcc410981c /multimedia
parent30fb16f94fe28f84a8164b9b232b32d8561250c3 (diff)
downloadslackbuilds-e08404ffdc0ae083de64b2ab54b7e47fc955c0f6.tar.gz
slackbuilds-e08404ffdc0ae083de64b2ab54b7e47fc955c0f6.tar.xz
multimedia/mozplugger: Updated for version 1.14.3.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mozplugger/Makefile.in.diff31
-rw-r--r--multimedia/mozplugger/README11
-rw-r--r--multimedia/mozplugger/mozplugger.SlackBuild46
-rw-r--r--multimedia/mozplugger/mozplugger.info8
-rw-r--r--multimedia/mozplugger/slack-desc6
5 files changed, 67 insertions, 35 deletions
diff --git a/multimedia/mozplugger/Makefile.in.diff b/multimedia/mozplugger/Makefile.in.diff
new file mode 100644
index 0000000000..c2c01addb7
--- /dev/null
+++ b/multimedia/mozplugger/Makefile.in.diff
@@ -0,0 +1,31 @@
+diff -Nur mozplugger-1.14.3.orig//Makefile.in mozplugger-1.14.3/Makefile.in
+--- mozplugger-1.14.3.orig//Makefile.in 2011-03-03 15:40:49.000000000 -0600
++++ mozplugger-1.14.3/Makefile.in 2011-05-08 14:10:21.550678141 -0500
+@@ -152,17 +152,16 @@
+ make localinstall BROWSERDIR=.opera
+
+ install:
+- -@$(MKDIR) @bindir@
+- -@$(MKDIR) $(prefix)$(libprefix)/mozilla/plugins
+- -@$(MKDIR) @mandir@/man7
+- -@$(MKDIR) @sysconfdir@
+- cp mozplugger-helper @bindir@
+- cp mozplugger-controller @bindir@
+- cp mozplugger-linker @bindir@
+- for target in ${PLUGINDIRS}; do cp mozplugger.so $${target}; done
+-# cp mozplugger.so $(prefix)$(libprefix)/mozilla/plugins/
+- cp $(srcdir)/mozpluggerrc @sysconfdir@
+- cp $(srcdir)/mozplugger.7 @mandir@/man7/
++ -@$(MKDIR) $(root)/@bindir@
++ -@$(MKDIR) $(root)/@mandir@/man7
++ -@$(MKDIR) $(root)/@sysconfdir@
++ cp mozplugger-helper $(root)/@bindir@
++ cp mozplugger-controller $(root)/@bindir@
++ cp mozplugger-linker $(root)/@bindir@
++ for target in ${PLUGINDIRS}; do $(MKDIR) $(root)/$${target} ; cp mozplugger.so $(root)/$${target}; done
++# cp mozplugger.so $(root)/$(prefix)$(libprefix)/mozilla/plugins/
++ cp $(srcdir)/mozpluggerrc $(root)/@sysconfdir@
++ cp $(srcdir)/mozplugger.7 $(root)/@mandir@/man7/
+
+ mozplugger.tar.gz: $(SOURCE_FILES)
+ @( DIR=`pwd`;\
diff --git a/multimedia/mozplugger/README b/multimedia/mozplugger/README
index 74cb5218da..29c31b66b8 100644
--- a/multimedia/mozplugger/README
+++ b/multimedia/mozplugger/README
@@ -1,7 +1,4 @@
-mozplugger
-
-The goal of the project is to provide a minimalist, clean and
-stable general purpose Mozilla plugin module that allows the
-user to embed and launch their favourite application to handle
-the various different types of media found on the Internet.
-
+The goal of the mozplugger project is to provide a minimalist, clean,
+ and stable general purpose Mozilla plugin module that allows the
+user to embed and launch their favorite application to handle the
+various different types of media found on the Internet.
diff --git a/multimedia/mozplugger/mozplugger.SlackBuild b/multimedia/mozplugger/mozplugger.SlackBuild
index 8019ef4f91..c1a4caa94e 100644
--- a/multimedia/mozplugger/mozplugger.SlackBuild
+++ b/multimedia/mozplugger/mozplugger.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mozplugger
-# Copyright (c) jue oct 15 18:27:01 CST 2009, Dhaby Xiloj <slack.dhabyx@gmail.com>
+# Copyright (c) jue 2009, Dhaby Xiloj <slack.dhabyx@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -22,16 +22,14 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mozplugger
-VERSION=${VERSION:-1.13.0}
+VERSION=${VERSION:-1.14.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -41,8 +39,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="COPYING ChangeLog README"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -50,7 +46,7 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
+ SLKCFLAGS="-O2 -march=native -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -72,25 +68,34 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-RPM_OPT_FLAGS="$SLKCFLAGS" \
-make linux libprefix=/lib${LIBDIRSUFFIX}
-make install libprefix=/lib${LIBDIRSUFFIX} root=$PKG
+# sigh --rworkman
+patch -p1 < $CWD/Makefile.in.diff
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+make \
+ XCFLAGS="$SLKCFLAGS" \
+ PLUGINDIRS=/usr/lib${LIBDIRSUFFIX}/mozilla/plugins \
+ libprefix=/lib64
+
+make install \
+ PLUGINDIRS=/usr/lib${LIBDIRSUFFIX}/mozilla/plugins \
+ libprefix=/lib64 \
+ root=$PKG
-# relocating files
-mv $PKG/usr/share/man $PKG/usr/man
-rm -Rf $PKG/usr/share
mv $PKG/etc/mozpluggerrc $PKG/etc/mozpluggerrc.new
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -99,4 +104,3 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/multimedia/mozplugger/mozplugger.info b/multimedia/mozplugger/mozplugger.info
index 3a333ffa01..29a7a1ea72 100644
--- a/multimedia/mozplugger/mozplugger.info
+++ b/multimedia/mozplugger/mozplugger.info
@@ -1,10 +1,10 @@
PRGNAM="mozplugger"
-VERSION="1.13.0"
+VERSION="1.14.3"
HOMEPAGE="http://mozplugger.mozdev.org/"
-DOWNLOAD="http://mozplugger.mozdev.org/files/mozplugger-1.13.0.tar.gz"
-MD5SUM="c87acaccbd9378f6f68bdf8fe8e01518"
+DOWNLOAD="http://mozplugger.mozdev.org/files/mozplugger-1.14.3.tar.gz"
+MD5SUM="ac2f916ac93c3b59dec2ebfc511d00a0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="dhabyx"
EMAIL="slack.dhabyx@gmail.com"
-APPROVED="dsomero"
+APPROVED="rworkman"
diff --git a/multimedia/mozplugger/slack-desc b/multimedia/mozplugger/slack-desc
index 52fde3e8c6..7af7774c66 100644
--- a/multimedia/mozplugger/slack-desc
+++ b/multimedia/mozplugger/slack-desc
@@ -7,13 +7,13 @@
|-----handy-ruler----------------------------------------------------|
mozplugger: mozplugger (Mozilla media plugin)
-mozplugger:
+mozplugger:
mozplugger: The goal of the project is to provide a minimalist, clean and
mozplugger: stable general purpose Mozilla plugin module that allows the
mozplugger: user to embed and launch their favourite application to handle
mozplugger: the various different types of media found on the Internet.
-mozplugger:
-mozplugger:
+mozplugger:
mozplugger: Homepage: http://mozplugger.mozdev.org/
mozplugger:
mozplugger:
+mozplugger: