summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author bassmadrigal <admin@bassmadrigal.com>2010-05-13 00:59:48 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:48 +0200
commit4027982e9477120f4127875eaa06ccc565e8c7fc (patch)
tree389f53959d2cee6b4aa347c173f2d58e0c98bf1b /multimedia
parent933f1a42766556e36cd3bdfd4f3352fabcf6e73d (diff)
downloadslackbuilds-4027982e9477120f4127875eaa06ccc565e8c7fc.tar.gz
slackbuilds-4027982e9477120f4127875eaa06ccc565e8c7fc.tar.xz
multimedia/picard: Added to 13.0 repository
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/picard/README10
-rw-r--r--multimedia/picard/doinst.sh4
-rw-r--r--multimedia/picard/picard.SlackBuild64
-rw-r--r--multimedia/picard/picard.info10
-rw-r--r--multimedia/picard/slack-desc20
5 files changed, 108 insertions, 0 deletions
diff --git a/multimedia/picard/README b/multimedia/picard/README
new file mode 100644
index 0000000000..d419ab0790
--- /dev/null
+++ b/multimedia/picard/README
@@ -0,0 +1,10 @@
+Picard is the next generation MusicBrainz tagging application. This new
+tagging concept is album oriented, as opposed to track/file oriented like
+the ClassicTagger was. Picard is written in Python, which is a cross-platform
+language, and makes use of cross-platform libraries - this allows the same
+code to run both on Windows, Linux and Mac OS X.
+
+Requires mutagen and optionally but recommended fftw and libofa
+used for fingerprinting the songs for automagic tagging
+
+All packages available on SlackBuilds.org
diff --git a/multimedia/picard/doinst.sh b/multimedia/picard/doinst.sh
new file mode 100644
index 0000000000..65fd352418
--- /dev/null
+++ b/multimedia/picard/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/multimedia/picard/picard.SlackBuild b/multimedia/picard/picard.SlackBuild
new file mode 100644
index 0000000000..f40019d3c1
--- /dev/null
+++ b/multimedia/picard/picard.SlackBuild
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+# Slackware build script for picard
+# Written by Jeremy Brent Hansen admin -at- bassmadrigal.com
+
+PRGNAM=picard
+VERSION=0.11
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build || exit 1
+python setup.py install --root $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/multimedia/picard/picard.info b/multimedia/picard/picard.info
new file mode 100644
index 0000000000..3e7a5beb20
--- /dev/null
+++ b/multimedia/picard/picard.info
@@ -0,0 +1,10 @@
+PRGNAM="picard"
+VERSION="0.11"
+HOMEPAGE="http://musicbrainz.org/doc/Picard_Tagger"
+DOWNLOAD="ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/picard-0.11.tar.gz"
+MD5SUM="02ddcff3e201b2cf54f1b52b02d44fad"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="bassmadrigal"
+EMAIL="admin@bassmadrigal.com"
+APPROVED="dsomero"
diff --git a/multimedia/picard/slack-desc b/multimedia/picard/slack-desc
new file mode 100644
index 0000000000..b092071a63
--- /dev/null
+++ b/multimedia/picard/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+picard: Picard Tagger (next generation MusicBrainz tagging application)
+picard:
+picard: Picard is the next generation MusicBrainz tagging application. This
+picard: new tagging concept is album oriented, as opposed to track/file
+picard: oriented like the ClassicTagger was. Picard is written in Python,
+picard: which is a cross-platform language, and makes use of cross-platform
+picard: libraries - this allows the same code to run both on Windows, Linux
+picard: and Mac OS X.
+picard:
+picard: Homepage: http://musicbrainz.org/doc/Picard_Tagger
+picard:
+