summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Jonathan Larsen <agentc0re@learnix.net>2010-05-13 00:59:48 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:48 +0200
commit933f1a42766556e36cd3bdfd4f3352fabcf6e73d (patch)
treee241fe8bb9e865559977eb479290482bb5f03cb0 /multimedia
parentb4e38617b578ec00718fa35881aab93f94402712 (diff)
downloadslackbuilds-933f1a42766556e36cd3bdfd4f3352fabcf6e73d.tar.gz
slackbuilds-933f1a42766556e36cd3bdfd4f3352fabcf6e73d.tar.xz
multimedia/openshot: Added to 13.0 repository
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/openshot/README4
-rw-r--r--multimedia/openshot/doinst.sh7
-rw-r--r--multimedia/openshot/openshot.SlackBuild83
-rw-r--r--multimedia/openshot/openshot.info10
-rw-r--r--multimedia/openshot/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/multimedia/openshot/README b/multimedia/openshot/README
new file mode 100644
index 0000000000..d08c42b94a
--- /dev/null
+++ b/multimedia/openshot/README
@@ -0,0 +1,4 @@
+OpenShot Video Editor(TM) is an open-source program that creates, modifies,
+and edits video files.
+
+Requirements: mlt, frei0r, and pygoocanvas. Available at SlackBuilds.org
diff --git a/multimedia/openshot/doinst.sh b/multimedia/openshot/doinst.sh
new file mode 100644
index 0000000000..9a8ded3c60
--- /dev/null
+++ b/multimedia/openshot/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/multimedia/openshot/openshot.SlackBuild b/multimedia/openshot/openshot.SlackBuild
new file mode 100644
index 0000000000..d454353249
--- /dev/null
+++ b/multimedia/openshot/openshot.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/bash
+
+# Copyright 2009, Jonathan Larsen (agentc0re), SLC, UT
+# Contact Info: agentc0re 'AT' learnix 'DOT' net
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=openshot
+VERSION=1.0.0
+SRC=-1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_${VERSION}${SRC}.tar.gz || exit 1
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/
+rm -rf $PKG/usr/share/man
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/openshot/openshot.info b/multimedia/openshot/openshot.info
new file mode 100644
index 0000000000..069dd6e4d3
--- /dev/null
+++ b/multimedia/openshot/openshot.info
@@ -0,0 +1,10 @@
+PRGNAM="openshot"
+VERSION="1.0.0-1"
+HOMEPAGE="http://www.openshotvideo.com"
+DOWNLOAD="http://launchpad.net/openshot/1.0/1.0.0/+download/openshot_1.0.0-1.tar.gz"
+MD5SUM="bb3e0b397c905e5fae11bc2e5ecccdbb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Jonathan Larsen"
+EMAIL="agentc0re@learnix.net"
+APPROVED="dsomero"
diff --git a/multimedia/openshot/slack-desc b/multimedia/openshot/slack-desc
new file mode 100644
index 0000000000..f62ee738e6
--- /dev/null
+++ b/multimedia/openshot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+openshot: OpenShot (an open-source video editor)
+openshot:
+openshot: OpenShot Video Editor(TM) is an open-source program that creates,
+openshot: modifies, and edits video files.
+openshot:
+openshot:
+openshot:
+openshot:
+openshot:
+openshot:
+openshot: