summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2013-11-15 07:26:31 +0700
committer Robby Workman <rworkman@slackbuilds.org>2013-11-14 23:00:13 -0600
commita23950a58c6382a243aeb3d0312c971e9014cf72 (patch)
tree6c2c7e4f0bbf8121fcd34db3541b0d2bada20b1c /multimedia
parentb7448da42aca8d402b2332451bd61a55773240d0 (diff)
downloadslackbuilds-a23950a58c6382a243aeb3d0312c971e9014cf72.tar.gz
slackbuilds-a23950a58c6382a243aeb3d0312c971e9014cf72.tar.xz
multimedia/gnash: Fix a linking error
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gnash/gnash.SlackBuild9
-rw-r--r--multimedia/gnash/gnash.info2
-rw-r--r--multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch24
-rw-r--r--multimedia/gnash/slack-desc8
4 files changed, 34 insertions, 9 deletions
diff --git a/multimedia/gnash/gnash.SlackBuild b/multimedia/gnash/gnash.SlackBuild
index 679769f480..a6dc531744 100644
--- a/multimedia/gnash/gnash.SlackBuild
+++ b/multimedia/gnash/gnash.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gnash
-# Copyright 2012 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2012-2013 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=gnash
VERSION=${VERSION:-0.8.10}
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-5}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -78,13 +78,14 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+chmod -R u+w,go-w,a+rX-st .
# Fix compilation with GCC 4.7.
patch -p1 < $CWD/patch/gcc47.patch
-# Fix paths for kde plugin and a cve patch.
+# Fix a boost linking error, paths for kde plugin, and a cve patch.
# Ripped from gentoo
+patch -p1 < $CWD/patch/gnash-0.8.10-boost-1.50.patch
patch -p1 < $CWD/patch/gnash-0.8.10-klash.patch
patch -p1 < $CWD/patch/gnash-0.8.10-kde4-libdir.patch
patch -p1 < $CWD/patch/gnash-0.8.10-cve-2012-1175.patch
diff --git a/multimedia/gnash/gnash.info b/multimedia/gnash/gnash.info
index 7fe6727ee4..e96c76792e 100644
--- a/multimedia/gnash/gnash.info
+++ b/multimedia/gnash/gnash.info
@@ -5,6 +5,6 @@ DOWNLOAD="ftp://mirrors.kernel.org/gnu/gnash/0.8.10/gnash-0.8.10.tar.bz2"
MD5SUM="63e9f79c41d93d48c5a2fa94856548c4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="agg xulrunner"
+REQUIRES="%README% agg xulrunner"
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"
diff --git a/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch b/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch
new file mode 100644
index 0000000000..23282d1e89
--- /dev/null
+++ b/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch
@@ -0,0 +1,24 @@
+diff -ur a/macros/boost.m4 b/macros/boost.m4
+--- a/macros/boost.m4 2012-09-03 17:11:43.000000000 +0200
++++ b/macros/boost.m4 2012-10-16 01:58:28.000000000 +0200
+@@ -37,7 +37,7 @@
+ boost_headers="detail/lightweight_mutex.hpp thread/thread.hpp multi_index_container.hpp multi_index/key_extractors.hpp thread/mutex.hpp program_options/options_description.hpp iostreams/stream.hpp"
+ dnl this is a list of *required* libraries. If any of these are missing, this
+ dnl test will return a failure, and Gnash won't build.
+- boost_libs="thread program_options iostreams"
++ boost_libs="thread program_options iostreams system"
+
+ dnl this is a list of *recommended* libraries. If any of these are missing, this
+ dnl test will return a warning, and Gnash will build, but testing won't work.
+diff -ur a/plugin/npapi/Makefile.am b/plugin/npapi/Makefile.am
+--- a/plugin/npapi/Makefile.am 2012-09-03 17:11:43.000000000 +0200
++++ b/plugin/npapi/Makefile.am 2012-10-16 01:58:57.000000000 +0200
+@@ -78,7 +78,7 @@
+
+ libgnashplugin_la_LIBADD = \
+ $(GLIB_LIBS) \
+- -lboost_iostreams \
++ $(BOOST_LIBS) \
+ $(NULL)
+
+ # Scriptable plugin support
diff --git a/multimedia/gnash/slack-desc b/multimedia/gnash/slack-desc
index f75f5c3f5b..79386951c5 100644
--- a/multimedia/gnash/slack-desc
+++ b/multimedia/gnash/slack-desc
@@ -1,8 +1,8 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|