summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-02 11:51:24 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-02 11:51:24 -0400
commitf8232aa07ae35ba45b6e2d643e7fe2aa17d9c27d (patch)
treef82cb85da62c28449dd2aec4dff76b9e83f3ad0a /multimedia
parent7bd4195a8c2f85fb2804d51cc9753d8c56e86d79 (diff)
downloadslackbuilds-f8232aa07ae35ba45b6e2d643e7fe2aa17d9c27d.tar.gz
slackbuilds-f8232aa07ae35ba45b6e2d643e7fe2aa17d9c27d.tar.xz
multimedia/avidemux: Fix man page.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avidemux/avidemux.SlackBuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/multimedia/avidemux/avidemux.SlackBuild b/multimedia/avidemux/avidemux.SlackBuild
index 0a1ff5a386..c592912848 100644
--- a/multimedia/avidemux/avidemux.SlackBuild
+++ b/multimedia/avidemux/avidemux.SlackBuild
@@ -25,11 +25,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220402 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - man page was getting installed as a *file* called /usr/man/man1. fix.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=avidemux
VERSION=${VERSION:-2.8.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,9 +80,9 @@ cd ${PRGNAM}_${VERSION}
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash || exit 1
sed -i 's|0.19|1.0|' avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt || exit 1
@@ -95,7 +95,8 @@ make -C buildPluginsCLI DESTDIR="$PKG" install
make -C buildPluginsCommon DESTDIR="$PKG" install
install -Dm 644 avidemux_icon.png $PKG/usr/share/pixmaps/avidemux.png
-install -Dm 644 man/avidemux.1 $PKG/usr/man/man1
+mkdir -p $PKG/usr/man/man1
+gzip -9c < man/avidemux.1 > $PKG/usr/man/man1/avidemux.1.gz
make -C buildQt5 DESTDIR="$PKG" install
make -C buildPluginsQt5 DESTDIR="$PKG" install