summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Antonio Leal <antonioleal@yahoo.com>2024-02-17 07:58:19 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-17 08:27:19 +0700
commit84969457bcd76b3a755cbf4d30d6759edb8410c9 (patch)
tree7dd5102c4159664e434cdaca3ec2dc005f240f44 /multimedia
parent0ee30faaf29a80915d6274d9247fec2abe13331d (diff)
downloadslackbuilds-84969457bcd76b3a755cbf4d30d6759edb8410c9.tar.gz
slackbuilds-84969457bcd76b3a755cbf4d30d6759edb8410c9.tar.xz
multimedia/MuseScore: Updated for version 4.2.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/MuseScore/MuseScore.SlackBuild100
-rw-r--r--multimedia/MuseScore/MuseScore.desktop15
-rw-r--r--multimedia/MuseScore/MuseScore.info18
-rw-r--r--multimedia/MuseScore/README1
4 files changed, 83 insertions, 51 deletions
diff --git a/multimedia/MuseScore/MuseScore.SlackBuild b/multimedia/MuseScore/MuseScore.SlackBuild
index 2db14943c6..13a0709fe0 100644
--- a/multimedia/MuseScore/MuseScore.SlackBuild
+++ b/multimedia/MuseScore/MuseScore.SlackBuild
@@ -1,19 +1,33 @@
#!/bin/bash
+
# Slackware build script for MuseScore
-# Copyright 2022 Klaatu <klaatu@member.fsf.org> | Lawrence NZ
+# Copyright 2024 Antonio Leal, Porto Salvo, Oeiras, Portugal
+# Copyright 2022-2023 Klaatu <klaatu@member.fsf.org> | Lawrence NZ
# Thanks to Tim Dickson
-
-# GNU All-Permissive License
-# Copying and distribution of this file, with or without modification,
-# are permitted in any medium without royalty provided the copyright
-# notice and this notice are preserved. This file is offered as-is,
-# without any warranty.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=MuseScore
-VERSION=${VERSION:-3.6.2}
+VERSION=${VERSION:-4.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -26,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,46 +64,31 @@ else
fi
set -e
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+
+tar xvfz $CWD/$PRGNAM-$VERSION.tar.gz
+
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Copy over sound files for installation.
-cp $CWD/MuseScore_General_License.md share/sound
-cp $CWD/MuseScore_General.sf3 share/sound
-
-# Turn off Qt crash reporter. Option isn't available in Makefile,
-# so turn it off in CMakeLists.txt
-sed -i '/(BUILD_CRASH_REPORTER/s|ON)|OFF)|' CMakeLists.txt
-sed -i 's|share/man|man|' CMakeLists.txt
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
mkdir b
cd b
-cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS_RELEASE="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS" \
- -DCMAKE_MODULE_LINKER_FLAGS_RELEASE="-pthread" \
- -DMUSESCORE_BUILD_CONFIG=release \
- -DDOWNLOAD_SOUNDFONT=OFF \
- -DUSE_SYSTEM_FREETYPE=ON \
- -DBUILD_WEBENGINE=OFF \
- -DBUILD_TELEMETRY_MODULE=OFF \
- -DBUILD_PORTAUDIO=ON \
- -DBUILD_PORTMIDI=ON \
- -DQMAKE=/usr/lib"${LIBDIRSUFFIX}"/qt5/bin/qmake \
- -DQT_QMAKE_EXECUTABLE=/usr/lib"${LIBDIRSUFFIX}"/qt5/bin/qmake \
- ..
+cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/opt/MuseScore \
+ -DCMAKE_C_FLAGS_RELEASE="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_MODULE_LINKER_FLAGS_RELEASE="-pthread" \
+ -DQMAKE=/usr/lib"${LIBDIRSUFFIX}"/qt5/bin/qmake \
+ -DQT_QMAKE_EXECUTABLE=/usr/lib"${LIBDIRSUFFIX}"/qt5/bin/qmake
make install \
DESTDIR=$PKG \
@@ -100,13 +96,37 @@ make install \
cd ..
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+mkdir -p $PKG/usr/share/icons
+mv $PKG/opt/MuseScore/share/icons/hicolor $PKG/usr/share/icons/
+rm -rf $PKG/opt/MuseScore/share/icons
+
+mkdir -p $PKG/usr/share/applications
+cp $CWD/MuseScore.desktop $PKG/usr/share/applications/
+rm -rf $PKG/opt/MuseScore/share/applications
+
+mkdir -p $PKG/usr/man/man1
+mv $PKG/opt/MuseScore/share/man/man1/mscore.1.gz $PKG/usr/man/man1/
find $PKG/usr/man -type f -exec gzip -9 {} \;
+rm -rf $PKG/opt/MuseScore/share/man
+
+mv $PKG/opt/MuseScore/share/metainfo $PKG/usr/share/
+
+mv $PKG/opt/MuseScore/share/mime $PKG/usr/share/
+
+mkdir -p $PKG/usr/bin
+( cd $PKG/usr/bin ; rm -rf mscore )
+( cd $PKG/usr/bin ; ln -sf ../../opt/MuseScore/bin/mscore mscore )
+( cd $PKG/usr/bin ; rm -rf MuseScore )
+( cd $PKG/usr/bin ; ln -sf ../../opt/MuseScore/bin/mscore MuseScore )
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.* README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/MuseScore/MuseScore.desktop b/multimedia/MuseScore/MuseScore.desktop
new file mode 100644
index 0000000000..d183c1284b
--- /dev/null
+++ b/multimedia/MuseScore/MuseScore.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=MuseScore
+GenericName=Music notation
+Comment=Create, play and print beautiful sheet music
+Exec=mscore
+Icon=mscore
+Terminal=false
+StartupNotify=true
+NoDisplay=false
+MimeType=application/x-musescore;application/x-musescore+xml;x-scheme-handler/musescore;application/vnd.recordare.musicxml;application/vnd.recordare.musicxml+xml;audio/midi;application/x-bww;application/x-biab;application/x-capella;audio/x-gtp;application/x-musedata;application/x-overture;audio/x-ptb;application/x-sf2;application/x-sf3;
+Categories=AudioVideo;
+Keywords=music;notation;composition;composing;arranging;making;sheet music;music notation software;lead sheet;leadsheet;score;full score;scorewriter;MIDI;musicxml;playback;instrument;
+
diff --git a/multimedia/MuseScore/MuseScore.info b/multimedia/MuseScore/MuseScore.info
index 99ce17e172..59c4ac2ecf 100644
--- a/multimedia/MuseScore/MuseScore.info
+++ b/multimedia/MuseScore/MuseScore.info
@@ -1,14 +1,10 @@
PRGNAM="MuseScore"
-VERSION="3.6.2"
-HOMEPAGE="http://www.musescore.org/"
-DOWNLOAD="https://github.com/musescore/MuseScore/archive/v3.6.2/MuseScore-3.6.2.tar.gz \
-http://ftp.osuosl.org/pub/musescore/soundfont/MuseScore_General/MuseScore_General.sf3 \
-http://ftp.osuosl.org/pub/musescore/soundfont/MuseScore_General/MuseScore_General_License.md"
-MD5SUM="682c4a38b8b39d246d196c392ae08ab7 \
- 7b354559c7ef4e859a2bfad8738d477d \
- bc7b4fbe58b37788876b6c36f19577d0"
+VERSION="4.2.1"
+HOMEPAGE="https://github.com/musescore/MuseScore"
+DOWNLOAD="https://github.com/musescore/MuseScore/archive/v4.2.1/MuseScore-4.2.1.tar.gz"
+MD5SUM="be651dd658905545bfd3601c23d8831b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jack portaudio portmidi"
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.fsf.org"
+REQUIRES="allegro"
+MAINTAINER="Antonio Leal"
+EMAIL="antonioleal@yahoo.com"
diff --git a/multimedia/MuseScore/README b/multimedia/MuseScore/README
index 449a4c6663..4ccaf8e4d9 100644
--- a/multimedia/MuseScore/README
+++ b/multimedia/MuseScore/README
@@ -8,3 +8,4 @@ program, licenced under GNU GPL. Features:
* import and export of MusicXml and standard midifiles (SMF)
* platform independent code for Linux, Windows, Mac
+This package partially installs to /opt/MuseScore