summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackware-id.org>2011-12-18 09:33:23 -0600
committer Robby Workman <rworkman@slackbuilds.org>2011-12-18 09:33:23 -0600
commit1014868c1ce10b10af2af3681980d28e0e3d7f7d (patch)
tree88a454a38c0fe909a42074a43b37502cc5e55919 /multimedia
parentbccc3810b5039a7ed056aae0f6b1b7878568098e (diff)
downloadslackbuilds-1014868c1ce10b10af2af3681980d28e0e3d7f7d.tar.gz
slackbuilds-1014868c1ce10b10af2af3681980d28e0e3d7f7d.tar.xz
multimedia/gimp-gap: Included a patch for internal ffmpeg / texlive
This commit also includes some tweaks to option setting (rworkman) Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gimp-gap/README6
-rw-r--r--multimedia/gimp-gap/gimp-gap.SlackBuild60
-rw-r--r--multimedia/gimp-gap/patch-ffmpeg-Makefile.diff16
3 files changed, 36 insertions, 46 deletions
diff --git a/multimedia/gimp-gap/README b/multimedia/gimp-gap/README
index b301e54f1b..c16ad0b847 100644
--- a/multimedia/gimp-gap/README
+++ b/multimedia/gimp-gap/README
@@ -10,5 +10,9 @@ FAAC=yes|no (default: yes), requires faac
FAAD=yes|no (default: yes), requires faad2
X264=yes|no (default: yes), requires x264
AVFORMAT=yes|no (default: yes), requires ffmpeg
-MPEG=yes|no (default: yes), requires libmpeg
+MPEG=yes|no (default: yes), requires libmpeg2
XVID=yes|no (default: yes), requires xvidcore
+
+NOTE: If you build this package using internal ffmpeg package and
+using texlive instead of tetex, you need to uncomment line 102 of
+the build script (remove the "#" character).
diff --git a/multimedia/gimp-gap/gimp-gap.SlackBuild b/multimedia/gimp-gap/gimp-gap.SlackBuild
index 72a750cf1e..20e4a3bfcd 100644
--- a/multimedia/gimp-gap/gimp-gap.SlackBuild
+++ b/multimedia/gimp-gap/gimp-gap.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for gimp-gap
-# Copyright 2010 Willy Sudiarto Raharjo <willysr@slackware-id.org>
+# Copyright 2010-2011 Willy Sudiarto Raharjo <willysr@slackware-id.org>
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for any purpose
@@ -21,7 +21,7 @@
PRGNAM=gimp-gap
VERSION=${VERSION:-2.6.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,47 +55,13 @@ DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README \
docs/howto/txt/HOWTO-do-lossless-MPEG-cut.txt \
docs/howto/txt/HOWTO-write-animated-plug-ins.txt"
-if [ "${LAME:-yes}" = "no" ]; then
- mp3lame="--disable-ff-libmp3lame"
-else
- mp3lame=""
-fi
-
-if [ "${FAAC:-yes}" = "no" ]; then
- libfaac="--disable-ff-libfaac"
-else
- libfaac=""
-fi
-
-if [ "${FAAD:-yes}" = "no" ]; then
- libfaad="--disable-ff-libfaad"
-else
- libfaad=""
-fi
-
-if [ "${X264:-yes}" = "no" ]; then
- libx264="--disable-ff-libx264"
-else
- libx264=""
-fi
-
-if [ "${AVFORMAT:-yes}" = "no" ]; then
- libavformat="--disable-libavformat"
-else
- libavformat=""
-fi
-
-if [ "${MPEG:-yes}" = "no" ]; then
- libmpeg="--disable-libmpeg3"
-else
- libmpeg=""
-fi
-
-if [ "${XVID:-yes}" = "no" ]; then
- libxvid="--disable-libxvidcore"
-else
- libxvid=""
-fi
+mp3lame="" ; [ "${LAME:-yes}" != "yes" ] && mp3lame="--disable-ff-libmp3lame"
+libfaac="" ; [ "${FAAC:-yes}" != "yes" ] && libfaac="--disable-ff-libfaac"
+libfaad="" ; [ "${FAAD:-yes}" != "yes" ] && libfaad="--disable-ff-libfaad"
+libx264="" ; [ "${X264:-yes}" != "yes" ] && libx264="--disable-ff-libx264"
+libavformat="" ; [ "${AVFORMAT:-yes}" != "yes" ] && libavformat="--disable-libavformat"
+libmpeg="" ; [ "${MPEG:-yes}" != "yes" ] && libmpeg="--disable-libmpeg3"
+libxvid="" ; [ "${XVID:-yes}" != "yes" ] && libxvid="--disable-libxvidcore"
set -e
@@ -122,14 +88,18 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--disable-audio-support \
+ --build=$ARCH-slackware-linux \
$mp3lame \
$libfaac \
$libfaad \
$libx264 \
$libavformat \
$libmpeg \
- $libxvid \
- --build=$ARCH-slackware-linux
+ $libxvid
+
+# Thanks to Heinz Wiesinger for the patch
+# This patch should fix compilation if internal ffmpeg is used
+#patch -p0 -i $CWD/patch-ffmpeg-Makefile.diff
make
make install DESTDIR=$PKG
diff --git a/multimedia/gimp-gap/patch-ffmpeg-Makefile.diff b/multimedia/gimp-gap/patch-ffmpeg-Makefile.diff
new file mode 100644
index 0000000000..46db6c20b0
--- /dev/null
+++ b/multimedia/gimp-gap/patch-ffmpeg-Makefile.diff
@@ -0,0 +1,16 @@
+--- extern_libs/ffmpeg/Makefile.orig 2010-08-04 19:25:32.000000000 -0700
++++ extern_libs/ffmpeg/Makefile 2010-08-04 19:27:27.000000000 -0700
+@@ -113,9 +113,10 @@
+ VHOOK_DEPS = $(HOOKS:$(SLIBSUF)=.d)
+ depend dep: $(VHOOK_DEPS)
+
+-documentation: $(addprefix doc/, ffmpeg-doc.html faq.html ffserver-doc.html \
+- ffplay-doc.html general.html hooks.html \
+- $(ALLMANPAGES))
++documentation:
++# documentation: $(addprefix doc/, ffmpeg-doc.html faq.html ffserver-doc.html \
++# ffplay-doc.html general.html hooks.html \
++# $(ALLMANPAGES))
+
+ doc/%.html: doc/%.texi
+ texi2html -monolithic -number $<