summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author dsomero <xgizzmo@gmail.com>2010-05-20 23:38:40 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-21 00:52:38 -0500
commitc84ab3f0a72efea6ffd22942a1dcf672bb4fd86e (patch)
tree69dd1901282ae5e893151be84a3f69ee73f45ed1 /multimedia
parent4d6aa00dd0b6a4e5acbb62921768cdf35dbd6f18 (diff)
downloadslackbuilds-c84ab3f0a72efea6ffd22942a1dcf672bb4fd86e.tar.gz
slackbuilds-c84ab3f0a72efea6ffd22942a1dcf672bb4fd86e.tar.xz
multimedia/miro: Removed (build failure)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/miro/README11
-rw-r--r--multimedia/miro/README.runtime24
-rw-r--r--multimedia/miro/doinst.sh14
-rw-r--r--multimedia/miro/miro.SlackBuild91
-rw-r--r--multimedia/miro/miro.info10
-rw-r--r--multimedia/miro/slack-desc19
6 files changed, 0 insertions, 169 deletions
diff --git a/multimedia/miro/README b/multimedia/miro/README
deleted file mode 100644
index d5215a844d..0000000000
--- a/multimedia/miro/README
+++ /dev/null
@@ -1,11 +0,0 @@
-Miro is a free Internet television application for the online
-Democracy Network.
-
-Requires gst-python and gnome-python-extras.
-
-Optional dependencies are libtorrent-rasterbar and notify-python.
-If libtorrent-rasterbar is not installed, then Miro will install
-libtorrent-rasterbar 0.14.4. Fortunately, this will not interfere
-with libtorrent-rasterbar if installed later.
-
-See README.runtime for additional runtime requirements.
diff --git a/multimedia/miro/README.runtime b/multimedia/miro/README.runtime
deleted file mode 100644
index be38132c9f..0000000000
--- a/multimedia/miro/README.runtime
+++ /dev/null
@@ -1,24 +0,0 @@
-Gstreamer is the default video renderer for Miro. Gstreamer requires additional
-python plugins to extend video and audio capabilities.
-
-For good codec support there is gst-plugins-good, gst-plugins-bad, gst-ffmpeg and
-gst-plugins-ugly.
-
-Xine is the other video renderer. The option to change renderer can also be made
-after installation in the Video->Options->Playback menu.
-
-Xine uses the "xv" driver by default. If you find instability issues with "xv"
-then you can try "xshm" or "opengl". You can test out the driver by running from
-the command line and passing:
-
-# miro --set=renderer=xine --set=xine-driver=xshm
-
-or, alternatively
-
-# miro --set=renderer=xine --set=xine-driver=opengl
-
-These settings will stay persistent on next program launch.
-
-Note: The linux version of Miro doesn't support the flash-plugin, so video from sites
-like Hulu and Youtube won't display inside the Miro player. But they can be launched
-in an external browser. \ No newline at end of file
diff --git a/multimedia/miro/doinst.sh b/multimedia/miro/doinst.sh
deleted file mode 100644
index 9830478e8c..0000000000
--- a/multimedia/miro/doinst.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
diff --git a/multimedia/miro/miro.SlackBuild b/multimedia/miro/miro.SlackBuild
deleted file mode 100644
index 39370bb012..0000000000
--- a/multimedia/miro/miro.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Miro
-
-# Copyright 2009 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=miro
-VERSION=${VERSION:-2.5.3}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-cd platform/gtk-x11
- # Fix the location of man pages.
- sed -i 's|share/man|man|g' setup.py
- python setup.py install --root=$PKG
-cd -
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Miro makes an executable that is hard linked to the seamonkey version.
-# Let's use the symlink version instead to avoid issues on seamonkey upgrades.
-SEA_VERSION=$(seamonkey-config --version)
-sed -i "s|seamonkey-${SEA_VERSION}|seamonkey|g" $PKG/usr/bin/miro
-
-# Remove unneeded files.
-PYVER=$(python -c 'import sys; print sys.version[:3]')
-rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/python${PYVER}/site-packages/miro/test
-rm -rf $PKG/usr/share/miro/resources/testdata
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CREDITS LAYOUT license.txt README \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/README.runtime > $PKG/usr/doc/$PRGNAM-$VERSION/README.runtime
-cat platform/gtk-x11/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.linux
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/miro/miro.info b/multimedia/miro/miro.info
deleted file mode 100644
index 398b43385d..0000000000
--- a/multimedia/miro/miro.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="miro"
-VERSION="2.5.3"
-HOMEPAGE="http://www.getmiro.com/"
-DOWNLOAD="http://ftp.osuosl.org/pub/pculture.org/miro/src/miro-2.5.3.tar.gz"
-MD5SUM="de3ada44e9904f2b046a6503b1a47a6d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="rworkman"
diff --git a/multimedia/miro/slack-desc b/multimedia/miro/slack-desc
deleted file mode 100644
index 46d02a13e2..0000000000
--- a/multimedia/miro/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-miro: miro (Online media aggregator)
-miro:
-miro: Miro is a free Internet television application for the online
-miro: Democracy Network.
-miro:
-miro: Homepage: http://www.getmiro.com/
-miro:
-miro:
-miro:
-miro:
-miro: