summaryrefslogtreecommitdiffstats
path: root/network/deluge
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2010-05-20 00:23:47 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-21 01:08:35 -0500
commit50a90028fc106a9e2a1f9302063c3c763072d8a9 (patch)
tree844d0b7d2e6380d2db22e835731872d55a8f982c /network/deluge
parentf062299969f188ebae98cfbc4d2e79cce803d740 (diff)
downloadslackbuilds-50a90028fc106a9e2a1f9302063c3c763072d8a9.tar.gz
slackbuilds-50a90028fc106a9e2a1f9302063c3c763072d8a9.tar.xz
network/deluge: Miscellaneous cleanups.
Diffstat (limited to 'network/deluge')
-rw-r--r--network/deluge/README5
-rw-r--r--network/deluge/deluge.SlackBuild19
-rw-r--r--network/deluge/slack-desc8
3 files changed, 19 insertions, 13 deletions
diff --git a/network/deluge/README b/network/deluge/README
index b869ad9cff..292e3ba5b5 100644
--- a/network/deluge/README
+++ b/network/deluge/README
@@ -2,6 +2,5 @@ Deluge is a bittorrent client for Linux and other Unix-Like operating
systems. Deluge was created because of the lack of a good, native, GTK based
torrent solution for Linux.
-Deluge requires boost from Slackware and libtorrent-rasterbar, pyxdg,
-pysetuptools, python-twisted, zope.interface, pyOpenSSL, chardet, Mako and
-optionaly notify-python that can be found in SlackBuilds.org repository.
+This requires libtorrent-rasterbar, pyxdg, pysetuptools, python-twisted,
+zope.interface, pyOpenSSL, chardet, and Mako.
diff --git a/network/deluge/deluge.SlackBuild b/network/deluge/deluge.SlackBuild
index 77218bb3c9..d2229da11e 100644
--- a/network/deluge/deluge.SlackBuild
+++ b/network/deluge/deluge.SlackBuild
@@ -24,10 +24,19 @@
PRGNAM=deluge
VERSION=${VERSION:-1.2.0}
-ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -41,6 +50,8 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
fi
set -e
@@ -61,7 +72,6 @@ find . \
-exec chmod 644 {} \;
python setup.py build || exit 1
-
python setup.py install --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
@@ -70,10 +80,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
mkdir -p $PKG/usr/man
mv $PKG/usr/share/man/man1 $PKG/usr/man
rm -r $PKG/usr/share/man
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/network/deluge/slack-desc b/network/deluge/slack-desc
index 3c8f7aea03..146ed5014b 100644
--- a/network/deluge/slack-desc
+++ b/network/deluge/slack-desc
@@ -13,7 +13,7 @@ deluge: operating systems. Deluge was created because of the lack of
deluge: a good, native, GTK based torrent solution for Linux.
deluge:
deluge: http://www.deluge-torrent.org
-deluge:
-deluge:
-deluge:
-deluge: \ No newline at end of file
+deluge:
+deluge:
+deluge:
+deluge: